Using the Forum Via Email

Here are the short instruction on using discourse (exclusively) via email, for those who don’t like javascript / prefer email.

Enable Mailing List mode

This will forward every new post on the forum to your inbox. You may unsubscribe later from specific categories.

  1. Go to your user settings

    https://forum.qubes-os.org/u/<USERNAME>/preferences/emails – replace with your username

  2. Click on :white_check_mark: Enable mailing list mode

Replying to emails

If you want to reply, just reply to the email and your response will show up on the forum.

You may notice that email you receive has a reply-to: header set. When replying, please respect this header, or your email will not be delivered!

You can also carry out some actions on posts by replying with a command. Supported operations are:

  • +1 or like : likes the post
  • watch : watches the topic
  • track : tracks the topic
  • mute : mutes the topic

Creating new topic via email

You may also create new discussions. For that you’ll need to find the category’s email address under the respective About this category for that category. It should be pinned to the top.

Note: to use this you need to be at least trust level 2. This means you must have been spending a bit of time on the forum. But if you’re an email-only person and have been relatively active replying, please notify the moderators so we can review your trust level.


For any issues, please contact the moderators.

1 Like

I’ve done that, and I set the mailing list mode to:

Send an email for every new post except my own

Send an email for every new post except my own

And that’s what it does, but that creates bit holes in the mailing list thread, and in case I started a topic I don’t see that initial post.

Therefore, I would like ask whether it’s possible to add a third option like:

Send an email for every new post including my own

That would be fantastic. :smiley:

I don’t recall how, but I get a copy of all replies. I assume that i did
not select the options you chose.
I was told when the discourse forum was being discussed that email users
could not generate new topics. I don’t know if this is true and have not
tested it.

What if you have your MUA set up to BCC yourself on all emails?

Sorry I obviously wasn’t clear enough. I do get all replies, but not the one from the initial post, which I made in the forum.

I’ve BCC set, but I haven’t started a discussion via email yet, and what I could see so far not all categories’ email address are published.

I am a bit confused as to what you are proposing as the option Send me an email for every new post should do what you are suggesting as your third option. I just tested and I did get the first post of a topic as well as every reply.

But I checked the outbound emails and I can confirm that for this topic neither the first nor the third were sent (which could only make sense in the case you have the option Send an email for every new post except my own.

So this means that the problem probably is discourse related and not associated with BBC.

Could you just confirm again that that’s not the option that you have selected? @qufo


It should be working. See:

The only ones that should be missing that are the ones in the “In your language section”, since it’s probably better to find someone to translate the instruction on sending an email to that category in the native language rather than in English. But if you see it’s missing in other categories, please let me know.

Yes, that’s rather different from what I thought you were saying.
It may well be a deficiency in discourse. If you use a decent MUA you
could set some rules to CC you on this type of message, or save it to
the “forum” mail folder

Your right chose that option. I got confused because the other option has at the end, in parentheses: about 35 per day. I interpreted that as upper limit not as an estimate. Sorry for the confusion, and thanks for poke my nose in it. :wink:

1 Like

Added documentation on some more things that can be done via email. Inspiration from:

I find that I am unable to open new topics because I do not have the
relevant trust level - Cant say I am surprised.
I was trying to crosspost news on the Focal template to “General
Discussion”. Can someone post that for me?

Sorry about that. Upped your trust level to “member”, which you certainly are! So feel free to try it again :slight_smile:

The problem is a lot of the metrics getting to the next trust level (discourse’s way of encouraging participation and discouraging spam) do rely on in-forum participation. I’ll follow that up on the discourse meta.

However, I’m not very hopeful there will be any other solution than manual approval. For this reason, I’ve edited the original post to include note that users in that situation should notify the moderators (like you did).

We’re sorry, but your email message to [“qubes_os@discoursemail.com”] (titled Re: [Qubes Forum] SecBrowser has been deprecated [General Discussion]) didn’t work. Do you use more than one email address? Did you reply from a different email address? Email replies require that you use the same email address when replying. Alternately, the Message-ID header in the email may have been modified.

Here is the mail I sent:

From - Thu Jan 21 17:33:57 2021
X-Mozilla-Status: 1011
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:
Subject: Re: [Qubes Forum] SecBrowser has been deprecated [General Discussion]
To: fsflover via Qubes OS Community Forum qubes_os@discoursemail.com
References: topic/2271@qubes-os.discourse.group
topic/2271/8857@qubes-os.discourse.group
topic/2271/8863@qubes-os.discourse.group
From: Sven Semmler Sven@SvenSemmler.org
Message-ID: 5320b396-fcbf-dbb4-969c-1c62dfdd75ab@SvenSemmler.org
Date: Thu, 21 Jan 2021 17:33:56 -0600
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101
Thunderbird/78.6.0
MIME-Version: 1.0
In-Reply-To: topic/2271/8863@qubes-os.discourse.group
Content-Type: multipart/signed; micalg=pgp-sha256;
protocol=“application/pgp-signature”;
boundary=“DFyyoQO2iqRfHSmTcXZswPt7rdE8rDoyD”

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
–DFyyoQO2iqRfHSmTcXZswPt7rdE8rDoyD
Content-Type: multipart/mixed; boundary=“GW5Sl1z9eNG1scdFazI6kvMLkQM9VCN9b”;
protected-headers=“v1”
From: Sven Semmler Sven@SvenSemmler.org
To: fsflover via Qubes OS Community Forum qubes_os@discoursemail.com
Message-ID: 5320b396-fcbf-dbb4-969c-1c62dfdd75ab@SvenSemmler.org
Subject: Re: [Qubes Forum] SecBrowser has been deprecated [General Discussion]
References: topic/2271@qubes-os.discourse.group
topic/2271/8857@qubes-os.discourse.group
topic/2271/8863@qubes-os.discourse.group
In-Reply-To: topic/2271/8863@qubes-os.discourse.group

–GW5Sl1z9eNG1scdFazI6kvMLkQM9VCN9b
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Language: en-US
Content-Transfer-Encoding: quoted-printable

I don’t see why not. You can simply clone anon-whonix qube and connect =
it to the clearnet.

Not quite. You will also have to convince Tor Browser to allow clearnet=20
connections, which was recently discussed in this forum and answered by=20
a link to the whonix forum.

–GW5Sl1z9eNG1scdFazI6kvMLkQM9VCN9b–

–DFyyoQO2iqRfHSmTcXZswPt7rdE8rDoyD
Content-Type: application/pgp-signature; name=“OpenPGP_signature.asc”
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename=“OpenPGP_signature”

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEE18ry22WNibwI1qeq2m4We49UH7YFAmAKD2QACgkQ2m4We49U
H7Yz4xAArIKpV77so+mpW1QxtNUMjAqrfzRWAIRbQ/+exlSdvqMDBz1eNFTruaVa
yEX/DX9MH5YijclsE6/Lb5O3qDIddk8ifG+bYgBU4DfDpzaaNQmtWg/cRRqkWvhk
rmkLs/277plptx9CHGqpPFW0NsLaPKnOM59vMYcpQQeb+dPYxVaAwB6Wc8KGQ+5X
Z5RKpRqZBblNWmSHNPprI4wr8F9rG+4E6uxhpAJVfH7sxgBJbJdUmuX4fPTRvgXL
O5pElL+sOOJGtc2QMQgJndatcQFaSmWwBdMjspHPOMnGK//NW+ZLAtaA8zF2veCT
zEpjIzgcvkbIxs5UztiKYc/lbIVoSyfHL4kirmDscdWwCWIfg+WDDMrFjknJON7K
12PRmBRrzjaKFmqncqD9Sx/QrP7vivfWWAl9YuCoRjTWZ1wEg26UhUaSAadWrY5a
3xuC14ej9SweanD48q27jTVCLLJHgtCFrI+gGDgDop6A+xld9EwhCoQhzRb1RrHj
LYTbdckoCtlSnvuZAJSur1EkrJjpoMzb5iy1Sbo1lLENtQy/1n+Wf2Q8zStRVEY3
kQp7OuxlBy9LUTmZHf4HSb+jycaOrU0cDTs9rc1n9MxbNYe7VhXxHDiLeCUl7yfp
IUGSBy7kOgCd98rKmFuSuAe2y8IWYxNWHpM0ihGy58LcvD8O2lE=
=t79F
-----END PGP SIGNATURE-----

–DFyyoQO2iqRfHSmTcXZswPt7rdE8rDoyD–

I checked the logs and it seems the main difference from other responses via email is that instead of replying to qubes_os+[some_topic_numbers]@discoursemail.com you sent to qubes_os@discoursemail.com. Quoting from your email headers:

My first guess is you replied somehow differently than usual. Could that be the case? Please double-check the reply to header and see if it it arrived somehow differently on your inbox (compared to other emails from the forum)

My first guess is you replied somehow differently than usual. Could that be the case?

Yes, it must have been my fault: I didn’t hit the ‘reply to list’ but the
simple ‘reply to author’

Sorry & Thanks for checking!

1 Like

I’ve just sent message to list cc’ed to General, but it doesnt seem to
have hit the Forum - ? Likely my fault, as I rarely open topics, but can
you help?

Interesting behavior… In this case you sent the topic and it did arrive well, but to the wrong category: it arrived in the mailinglist mirror.

Basically the mailing list mirroring is done in discourse is it filters anything sent to the qubes-users@googlegroup… to that category. Because you had both addresses it went into that one instead of the general category.

So a way to go around that may be to send one email to the mailing list and then resend exclusively to the forum address. It’s a bit of an extra effort. Sorry about that.

If you get some error because (at least created manually) one cannot create two topics with the same name. Then just change the title a tiny bit. Idk.

Sorry about this. Trying to harmonize email users and forum user’s experiences is an ever-improving process…

This is the unlikely combination of two niche features of discourse playing: the new topics by email and the mailing list. Although individually they are not terribly supported, my guess is the combination of both features is so rare… Regardless, I’ve asked on the discourse meta forum if there is any solution.

Good to know, thanks.
No more cc’ing

1 Like

Since today I don’t get any forum emails. I checked my user preferences and discovered that “Enable mailing list mode” is not there any more.

What happened? Got it removed deliberately or is this a software glitch?

1 Like