Qubes 4.1 installation failure

Hello,
I’ve been using Qubes 4.0 on my laptop for about a month now and I’m very excited so far.
Now I want to take the step to install Qubes 4.1 on my desktop PC (first as dualboot for for testing).

The installation with provided alpha (Signed Q4.1 alpha iso) works fine, but at the first boot I get the error with default configuration of Qubes:
“Qubes initial configuration failed. Login to the system and check /var/log/salt/minion for details. You can retry configuration by calling ‘sudo qubesctl --all state.highstate’ in dom0 (you will get detailed state there)”.

Here is /var/log/salt/minion https://easyupload.io/ugj6uo
And here is the journalctr output: https://easyupload.io/rn21g4
(Btw: Is there any better tool to upload logfiles? These will expire in 30 days)

My system:

workstation
description: Desktop Computer
product: System Product Name (SKU)
vendor: System manufacturer
version: System Version
serial: System Serial Number
width: 64 bits
capabilities: smbios-3.3.0 dmi-3.3.0 smp vsyscall32
configuration: boot=normal chassis=desktop family=To be filled by O.E.M. sku=SKU uuid=2ADF8601-ADFA-0C05-4035-04D9F5805CFD
*-core
description: Motherboard
product: ROG STRIX X570-F GAMING
vendor: ASUSTeK COMPUTER INC.
physical id: 0
version: Rev X.0x
serial: 190856392802379
slot: Default string
*-firmware
description: BIOS
vendor: American Megatrends Inc.
physical id: 0
version: 2802
date: 10/21/2020
size: 64KiB
capacity: 16MiB
capabilities: pci apm upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification uefi
*-memory
description: System Memory
physical id: 33
slot: System board or motherboard
size: 64GiB
*-bank:0
description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 3066 MHz (0,3 ns)
product: 3200 C16 Series
vendor: Patriot
physical id: 0
serial: 00000000
slot: DIMM_A1
size: 32GiB
width: 64 bits
clock: 3066MHz (0.3ns)
*-bank:1
description: [empty]
product: Unknown
vendor: Unknown
physical id: 1
serial: Unknown
slot: DIMM_A2
*-bank:2
description: DIMM DDR4 Synchronous Unbuffered (Unregistered) 3066 MHz (0,3 ns)
product: 3200 C16 Series
vendor: Patriot
physical id: 2
serial: 00000000
slot: DIMM_B1
size: 32GiB
width: 64 bits
clock: 3066MHz (0.3ns)
*-bank:3
description: [empty]
product: Unknown
vendor: Unknown
physical id: 3
serial: Unknown
slot: DIMM_B2
*-cache:0
description: L1 cache
physical id: 36
slot: L1 - Cache
size: 512KiB
capacity: 512KiB
clock: 1GHz (1.0ns)
capabilities: pipeline-burst internal write-back unified
configuration: level=1
*-cache:1
description: L2 cache
physical id: 37
slot: L2 - Cache
size: 4MiB
capacity: 4MiB
clock: 1GHz (1.0ns)
capabilities: pipeline-burst internal write-back unified
configuration: level=2
*-cache:2
description: L3 cache
physical id: 38
slot: L3 - Cache
size: 32MiB
capacity: 32MiB
clock: 1GHz (1.0ns)
capabilities: pipeline-burst internal write-back unified
configuration: level=3
*-cpu
description: CPU
product: AMD Ryzen 7 5800X 8-Core Processor
vendor: Advanced Micro Devices [AMD]
physical id: 39
bus info: cpu@0
version: AMD Ryzen 7 5800X 8-Core Processor
serial: Unknown
slot: AM4
size: 2150MHz
capacity: 3800MHz
width: 64 bits
clock: 100MHz

Samsung SSD 980 Pro
Nvidia 1070 (conneceted to monitors)
AMD Radeon Vega 64 (intended for gpu passthroug)

Is there any information missing?

Thanks in advance!

Edit: I just noticed that secure boot was still enabled.
Now I am receiving
[Dom0] Error
Delfault DVM failed:
unsupported operand type(s) for +:‘NoneType’ and ‘str’
and no qubes are created.

I don’t see any templates installed. What options did you have in initial setup wizard (like this one)?

It was not possible to enable the templates. They were greyed out.

Did you changed template selection earlier during installation (here)? If not, something went wrong at that stage, can you search for “qubes-template” in /var/log/anaconda and share logs that you find this way?

I reinstalled qubes and took some photos:
There is no option to select any templates


After clicking on ‘finish configuration’ I get

Here are all the logs of /var/log/anaconda (https://easyupload.io/315ben)
Is there a better way to share logs?

I don’t see a stage where templates are copied into the system. On successful install program.log contains near the end lines like this:

18:16:35,505 INF program: Running... /bin/sh /tmp/ks-script-nl7cqm5_
18:17:20,171 INF program: Unable to detect release version (use '--releasever' to specify release version)
18:17:20,174 INF program: Adding repo from: file:///tmp/installer.repo
18:17:20,174 INF program: Unable to detect release version (use '--releasever' to specify release version)
18:17:20,174 INF program: anaconda                                         36 MB/s | 1.1 MB     00:00
18:17:20,174 DBG program: Return code: 0

But I don’t see those in your logs. In a later version this output is saved to one of ks-script-*.log files, but it isn’t there neither in your install.
Honestly I have no idea what went wrong. I don’t see any relevant error message, installer simply skipped that step for some reason.

As for sharing logs, not sure. @deeplow is there any way to attach files directly here?

Is there a way to manually start the installation script (and get a proper log)? I am able to login but there exists only the Dom0 qube in the qube manager.

Edit: I installed it aigan and chose ‘Do not configure anything’. -> No error. But how do I configure the qubes? I just need the default settings.

1 Like

Are you using custom partitions layout?

No, I wiped out a whole ssd. But there is another ssd running ubuntu as dualboot.

Is it possible that my multi gpu setup is breaking this?

Would it be helpful to reinstall in verbose mode and share the logs?

You can check notably if in tmux session panes (CTRL-ALT-F1 or F2 if I remember correctly then you can switch tmux panes) there is issue at the end of the install process before reboot. Specifically it’s during post-script phase and you could check for what’s done for templates: https://github.com/QubesOS/qubes-anaconda/blob/master/30-qubes-templates.ks.

That did it!
There were already files in /mnt/sysimage/var/lib/qubes/template-packages

So i just excuted
dnf config-manager --add-repo /tmp/installer.repo
dnf download --downloaddir=/mnt/sysimage/var/lib/qubes/template-packages qubes-template-*

And now it’s fine:) Thank you!
Is this now a valid installation? What issues could arise now?

Were files already here before you executed the commands? Because if files were already here it’s the expected behavior. In a normal install you don’t need to do that manually of course.

Yes, files were there but I think the repo was not added.

Files are here because of repo setup and dnf download from it. Do you have templates shown at the firstboot screen now ? If yes, can you retry the same without any manual procedure please?

On first boot I was able to select templates like here (https://openqa.qubes-os.org/tests/14363#step/firstboot/5). And now it seems fine. But if I didn’t add repo then it fails.

Honestly, I don’t see what’s wrong as I cannot reproduce it. If qubes-template-*.rpm files where in /mnt/sysimage/var/lib/qubes/template-packages, this is because a local repository has been added into anaconda running system. So there should be no consequence to add the repository again and downloading templates rpm again into freshly created /mnt/sysimage root system.

yes, there is. Currently enabled for .yaml files (for the HCLs). but we can add more file extensions. Which ones would be need? .log (not that file extensions mean a lot. Just the way discourse settings work). I’ll talk to the other mods.

@marmarek users should now be able to attach .log files by dragging and dropping.