Qubes 4.2 "Initial configuration failed"

This is originally from this forum: Qubes 4.1 installation failure - #20 by eftryuio347h
I figured I would make a new post for this issue because the original thread is like 4 years old

Essentially, this is the issue: You install the OS for the first time, reboot system after it is done, and it does not let you install whonix, as it is greyed out. Once you get into the system, there is nothing but the dom0 cube.

After pressing done with the template config, it loads and then gives you an error saying “Qubes initial configuration failed”:

On my first install, checking /var/log/salt/minion would give me this error twice (I could be mistaken, I do not remember specifically):
[CRITICAL] Specified ext_pillar interface qvm_prefs is unavailable

And then, I would run ‘sudo qubesctl --all state.highstate’ and it would give me the same error twice, and then print out a message regarding a fail, saying that there was 1 fail and 1 success. After this, I googled the error and found a forum telling me to run:

  • sudo qubesctl saltutil.sync_all
  • sudo qubes state.highstate
    I ran these, but it did not seem to do anything.
    After this, I wiped this install and reinstalled, as I found the forum linked at the start of the post and I wanted to try the solution from that forum. I am going to copypaste the rest from that forum below:

— begin copy paste —
I waited for install to complete (got to where it asked me to reboot system now), then I switched to the terminal and tried checking for files in /var/lib/qubes/template-packages, but there was no template-packages folder at all. I figured I would try to do the steps that were mentioned previously, by running:
dnf config-manager --add-repo /tmp/installer.repo
dnf download --downloaddir=/mnt/sysimage/var/lib/qubes/template-packages qubes-template-*

This hung on a screen that seemed to be a download screen (see below)

After this (while it was still hanging, wasn’t sure if it was doing anything or not), I tried to quit to go to the reboot button but I wasn’t sure how, so I rebooted the system. After this, it brought me to the configuration part like usual, but whonix was not available, just like my last attempt:

Any pointer on where to go from here? I don’t really know what to do – if there are logs that I can provide, please let me know. I’m not very familiar with Qubes nor Anaconda.
— end copy paste —

This was last night. This morning, I opened the machine and decided to try running some of the commands (I did not do this last night)
I checked /var/log/salt/minion, but there did not appear to be any errors this time.
I ran: ‘sudo qubesctl --all state.highstate’ and it appears to actually have succeeded in doing something. The output reads as follows:

However, I do not really know where to go from here… there is still only the dom0 qube available. I was able to pull the anaconda.log if that helps, please let me know if there are any other log files that would be useful for troubleshooting.
anaconda.log (488.4 KB)

Regarding hardware, I am on a Lenovo IdeaPad Flex 5; According to the Hardware compatibility list (HCL) | Qubes OS page, everything should be compatible (or actually, looking at it now shows that it was only tested on R4.1, should I try to downgrade and see how that works?)

Thank you in advance

I installed QubesOS 4.1.2 and the templates with whonix,debian,fedora worked. I’m still not sure why 4.2.0 doesn’t work, but for the moment 4.1.2 is working for me.

Probably your downloaded ISO or installation media is corrupted.
Did you verify the downloaded ISO?
Verifying signatures | Qubes OS
Did you re-verify installation media after writing?
Verifying signatures | Qubes OS

the .iso was verified beforehand. I’m not sure of how to verify after writing

Check the second link in my previous reply.

I am on a windows-based system, so unfortunately those steps won’t work for me

Something very similar happened to me when I tried to install Qubes 4.2 from the download page.

  • After the reboot, in Template Configuration, almost all checkbox were greyed out.
  • I also had the Qubes initial configuration failed error after pressing Done.
  • I also did that solution you mentioned:
# dnf config-manager --add-repo /tmp/installer.repo
# dnf download --downloaddir=/mnt/sysimage/var/lib/qubes/template-packages qubes-template-*
  • Result: It did not work.

I verified the iso before dd in the usb, and also verified at boot. Everything was fine. Even though the iso has the correct hash, the qubes-template-* inside the iso did not pass the dnf signature test. That is why dnf download refused to copy qubes-template-* in /mnt/sysimage/var/lib/qubes/template-packages. I guess that is why the qubes-template-* were unavailable to create the template-vm and the sys vms when I pressed Done during the initial configuration which leads to the Qubes initial configuration failed error.

Here is what I did to install 4.2 while avoiding that problem:

  • Install Qubes 4.1.*, using an iso I know will function correctly during the install process
  • Update/Upgrade dom0 and all the qubes to their latest versions available in 4.1 (the os and the packages as well)
  • Upgrade to 4.2 using the instruction here
  • Replace the template-vm from 4.1 with fresh ones in 4.2 using qvm-template.

Hi, I’m smashing my head on the exact same problem. No additional software, no templates and no default Vms.

Tried writing the usb with dd, rufus, etcher.

Switched 5 usb drives

Switched 3 different machines

Still same result.

Could you point me a 4.1.* Iso that works for you?

Thank you

having the same problem with 4.2, the whonix/debian/etc initial templates get installed fine, and then the rest of the default cubes fail to install (network cubes/vault/etc). and when i get into the OS, and attempt to open say for example the Whonix cube. it says i do not have permission to start the cube ( or any cube )

In my case, I already had the 4.1.0 iso in my backups when 4.1 was released. It worked last time I installed on my system, it should work now on that same system.
The list of iso available are here

This was also, precisely, my problem - but I thought I’d try something: I have an Intel NUC5i3BNH and I have two monitors - one on the HDMI port - a “Smart TV” and a second via the Type C USB port on the NUC via a HUB with another HDMI port. I always had problems with the NUC dealing with these displays and setting the TV as the primary - even under Windows 10 and 11. In this case I disconnected the HDMI TV and booted the Qubes 4.2.0 install only using the monitor via the Type C USB port. Curiously, it all “worked as expected”. I therefore suspect this is a firmware issue with particular types of hardware.

For me, the problem was the dd command I used to burn the iso onto the Qubes USB thumb drive. I got the “Initial configuration failed” errors described above when (in ubuntu) I used this dd command and then, failing the Qubes installation initial media check, bypassed that check:
sudo dd if=(path to iso)Qubes-R4.2.1-x86_64.iso of=/dev/(USB thumb drive device) bs=1M status=progress

When I used this dd command instead, everything worked:
sudo dd if= {path to iso)Qubes-R4.2.1-x86_64.iso of=/dev/(USB thumb drive device) status=progress bs=1048576 conv=fsync