Signed Q4.1 alpha iso

I’m just following up on this:

It would be great to have a signed alpha iso for Q4.1. I wouldn’t mind running Q4.1 on a secondary machine, even if it breaks big time sometimes, but I would prefer to know that what I’m installing was built in a trusted environment and can be verified before I install it. This would enable me to provide feedback and submit bug reports. But I totally understand if the developers are already getting too much feedback to deal with :slight_smile:

Thanks for your hard work!


In our process for new releases, the release candidate stage features a signed ISO for broader testing by users who don’t want to build Qubes themselves, so you could wait for that.

Any hints on which year we will see 4.1? Next or 2021 or even later? :frowning:

When a release schedule becomes available, you will be able to see it here:

I’m afraid I do not have any information beyond that.

You can also see the progress towards the 4.1 milestone (in terms of open issues). Find it here.

Here is the long requested alpha build: and its signature: This isn’t “release candidate”-stable yet, but most of the things should work already.


Thanks a lot! :slight_smile:

(looking at the click counters is a little strange, though…)



I have been using R4.1 for a while now, without any major issues :slight_smile:

EDIT: But I haven’t tried the shiny new GuiVM yet.

Hi, when 4.1 will be out, will it be possible to upgrade from 4.0.1 (I mean current version) without having to reinstall from ISO?

It is being worked on, but seemingly not currently ready. You can see
progress at

No ETA yet, I’m afraid.

Sorry, I don’t know yet.

Hi I’m trying to install the qubes OS R4.1.0 Alpha, I had flashed the iso file by rufus. Im trying to install. The booting process went smooth but in the installation progress screen, I get a bug while creating ext4 on /dev/mapper/qubes_dom0-vm-pool.
I get an error popup saying an unknown error has occured.
Error g-io-error-quark GDBus error not known.error.LVMError waiting for ‘LvcreateLinear’

Motherboard Asus ROG Hero VII(disabled fastboot)
Ryzen 3700X(Virtualization enabled)
RTX 2060 AMP

Trying to Installing to an 128GB USB drive.
I will attach the debug log with an update

A post was split to a new topic: How to enable the (new) GUI VM?

Did Qubes change their signing key? I thought it was:

When I run verify with:
[user@untrusted Downloads]$ gpg2 --verify Qubes-R4.1.0-alpha20201014-x86_64.iso.DIGESTS

I get the key as:

Where is my mistake?

1 Like

That’s the release signing key, which is in turn signed by the Qubes Master Key. The verification process has two stages. First, you verify the release signing key, and then you verify the installation media. The bottom line is “read the docs how to do this!”


My apologies, I wasn’t catching the link between the master key and the signing key.

5 posts were split to a new topic: Failing to verify ISO with .iso.asc (no valid OpenPGP data found)