Please help me - Not asking for VMC because we don't have a network

I downloaded a fresh install of QubesOS. Twice. Both times I followed the installation guide for the install. Both times I arrived in dom0 with zero templates to create a VM, no sys-net, no sys-firewall, no sys-usb, no Whonix, no Fedora, no Debian, no personal, no work, no vault, nothing. None of the default vm’s.

So I have spent hours and hours trying to figure out how in the world am I going to get this to work. I’ve been working on this for two days.

I have soured through the forums, reddit, google, everywhere I can think to look.

I cannot use any commands that require an update VM because I have no VM templates to make into the default Update VM.

Well, to try to at least accomplish something I found a command that creates the vm’s using the salt state files hoping to be able to install the default vm’s that were supposed to be there because in Packages I can see the default template package is on the system. Well this is what I get:

$ sudo qubesctl state.sls qvm.sys-net
/usr/bin/qvm-create sys-net --class=AppVM --label=red
app: Error creating VM: Got empty response from qubesd. See journalctl in dom0 for details

Can someone please help me?

*** Read Comments for Update***

Did you uncheck every flag at the Initial Setup stage?
Maybe related:

At this stage for software installation, I did not have the options shown in the link to the installation guide for Debian and Whonix in the “Add-Ons for Selected Environment”. The only option I had for add-ons was “Qubes UI (Audio/GUI) - Qubes UI Daemons”. I left it checked to install.

At the First Boot stage I had two options listed for operating system: Xen hypervisor v4.14.3, and Xen hypervisor v4.14.3.config. I selected the non-config version because I couldn’t find any mention of the .config version anywhere.

This entire Initial Setup did not exist for me in either of the two times that I installed Qubes OS. It completely skips this stage, I never see an OS to select, and there are no checkboxes anywhere. It immediately goes to the user login screen.

In reference to the linked thread, when i go to Filesystem root, and I navigate to /var/log there is no folder named anaconda so filepath /var/log/anaconda does not exist for me. There is also not a document named anaconda in the log folder.

This installation guide is for Qubes 4.0 and in Qubes 4.1 the options changes and what you see is normal. You can check installation process for Qubes 4.1 here:

Where did you get the installation image? Did you test the installation media through the test and install option from the first bootscreen of the media? Maybe the image is corrupted?

I think I found what the problem is, but I am unsure of how to fix it.

So during the install, when anaconda starts, I get a message that says

Not asking for VMC because we don't have a network
X startup failed, aboring installation
THe installation cannot continue and the system will be rebooted

I found a few articles on it, and I’ve tried booting bios in legacy, and in UEFI mode and it does the same thing either way.

Do you think if I was able to get an older version of Qubes installed properly, that I would be able to perform an update to the latest version and be able to run 4.1 without any issues?

If you install Qubes 4.0 and then upgrade it to 4.1 it should work, but the disk encryption will be old:

  • The script does not convert LUKS1 to LUKS2 disk encryption format (fresh Qubes 4.1 install uses LUKS2 for disk encryption, while earlier versions use LUKS1).
    How to upgrade to Qubes 4.1 | Qubes OS

If you have a working dom0 in Qubes 4.1 and can mount install ISO to this system then you can install the templates from this ISO manually. The templates are stored in the Packages folder on this ISO.
Search for qubes-template-*.rpm there and install them in dom0 with:
sudo dnf install qubes-template-*.rpm

Or if you can’t mount the ISO in dom0 then you can boot from LiveCD and manually transfer these files to dom0.

Have you verified you have VT-d/IOMMU enabled in BIOS? Not sure if you’re at that part of the install where it asks…

1 Like

According to my BIOS, VT-d is Enabled

Maybe this can help (or not)

I am not sure (some time ago), but I think I had that kind of problem trying to install Qubes 4.1 on a dell inspiron i7-11xxx.

In dom0, do you get anything like this:

$ lspci
0000:00:00.0 Host bridge: Intel Corporation …



$ sudo qvm-pci
Failed to list ‘pci’ devices, this device type either does not exist or you do not have access to it

if the qvm-pci output looks similar to the lspci output, it is not your problem.

Background: It seems to be a problem (bug?) with qubes scanning/parsing pci/usb devices (because of the 10000:e lines) on some 11th gen intel hardware. And then the corresponding qubes are not installed (or all of them, I can’t remember). So until the issue is fixed by the qubes team or you can disactivate the faulty devices in the bios, you are out of luck with your hardware for the time being.

An issue/bug report has been created on GitHub and the Qubes OS team has marked as a bug that needs diagnosing. If any future users run into a similar issue as this one you can find this bug report to add any additional details or information you may have at the following link

Thank you so much to everyone who tried to assist me with this issue, I truly appreciate it!

Did you try the latest Qubes 4.1 ISO build with kernel-latest from Index of /qubes/iso/ ?
I had the same errors with Qubes release 4.1.0 installer from as you:

But the Qubes installer with kernel-latest worked for me as I’ve described here:

Attempting the installation now. Used the link Index of /qubes/iso/ to download this file:


I used the “Troubleshoot - Verbose Installation” to see if I noticed any strange errors pop-up in the installation process. I’ve made it to the point where the anaconda installer gives the message that reads

Not asking for VMC because we don’t have a network

And I am currently looking at an all-black screen, not even a white cursor is visible. Been looking at the black screen for about 10 minutes now, and going to leave it be in case it’s doing something in the background. I’ll give it about an hour to do something and keep you updated, and will update on GitHub as well.

Why not the latest build from May?
Do you have single GPU or more than one GPU?

Oops, my mistake. I thought the top one was the most recent lol, I’ll download the newest one now.

It’s a bare metal server with no GPU

Here are the specs for my remote, bare metal dedicated server

CPU: Intel i7-7700(k) 4.2GHz
Mobo: Supermicro X11SSH-F
BIOS: Supermicro Version 2.7 (Most recent update)
GPU: None
Memory: 64GB DDR4 RAM 2400MHz
Storage: 4 - 500GB NVMe SSD (2 RAID0 Configured with a hardware Raid Controller)
Network: 1GBps Ethernet

You have integrated GPU in Intel i7-7700:
Processor Graphics Intel® HD Graphics 630
So how are you getting the video output? You connected your display to your motherboard VGA port?

It’s rented out of a Data Center, I currently connect via IPMI and if it’s able to be configured with Qubes OS - if I can ever get it installed - Remote Desktop Connection is preferred as it seems to run much more smoothly than IPMI.

I’m not sure if it’s related or helpful, but I did successfully install Alpine Linux on the machine when I was just testing out other distros to see what alternatives were available or would be compatible with my server. I did run into an issue during that installation process that I worked out and it was that using DHCP to automatically configure wouldn’t work. I had to go back and manually enter in the static IP, subnet, and gateway and then I was finally able to ping Then, because I had to manually configure the network, I had to manually edit their resolv.conf to enter in public DNS nameservers to be able to resolve sending pings to I don’t know if that would adversely affect anything with the way that the Qubes OS installation process works. Just giving any information I can think of that might be useful.