Abortive Qubes Install: Missing Templates



The Qubes installer completes, apparently successfully :slight_smile: But when I reboot, it’s clear that it’s missing important components: namely, the qube OS templates (for Debian, Whonix etc). Any help gratefully received. Thank you :slight_smile:


I tried Qubes a few years ago, and I liked it a lot - it’s a brilliant project :+1: I was able to install it fine, and I used it for a few months. But the laptop I was using at the time didn’t support VT-d (I/O MMU virtualisation) which I understand is sub-optimal in security terms.

My current laptop has a much better spec, and - importantly - supports both VT-x with EPT, and VT-d (…both of which are enabled in the BIOS, which I updated to the latest version).

The problem is that I can’t install Qubes on it :frowning: The installer boots OK, and I can:

  • change l10n
  • configure storage
  • create a user account successfully

But the “software” page in Anaconda has no options for OS templates (Debian, Whonix etc.): the only option in the RH pane is dom0 with xfce (?)

I’m fairly confident the issue isn’t the USB sticks: I’ve tried two different sticks (one 8GB, one 16GB), I tested them both before use with badblocks and f3, and dd’ed the Qubes .isos to them in the recommended way. I carefully validated the .isos after downloading them, and I (re)validated the installers after creation (kudos to whoever wrote the documentation, BTW: I think it’s excellent :+1: )

Other things I’ve tried:

  • downloading the previous version of Qubes (4.1.2 instead of 4.2.1) (same result)
  • going to a tty while the installer is running, to check what’s going on (see below)

I read this, which sounds like the same thing. But the suggested solution doesn’t work for me: there is no /mnt/sysimage (presumably because the installer mounts stuff elsewhere now).

If I run find / -name '*.repo' I can see:


…and I’m assuming they’re what I need. But they’re (apparently) not recognised by the installer(?)

Does anyone have any advice, please?

TIA and best regards

The templates are installed at Initial Setup stage at first boot after the installation completes and not in Anaconda:

Hi @apparatus, and thanks for responding so quickly :slight_smile:

The templates are installed at Initial Setup stage at first boot after the installation completes and not in Anaconda

Ah: “user error” on my part :blush:

(Embarrassingly, I did RTFM…but clearly not well enough).

Thanks for pointing me in the right direction :+1: