QubesOS freeze, crash and reboots

I updated QubesOS using the command

sudo qubes-dom0-update

and after it completed QubesOS crashes 3 or 4 times per day which makes working really difficult as you lose your work, open windows etc. each time it crashes.

It happens when:

  1. I click on the Q at the top of the screen. It freezes for 2-4 seconds, crashes, and machine reboots.
  2. I click on a window, like the browser, to move it, it freezes for 2-4 seconds, crashes, and machine reboots.

It seems to be related to the window manager as it is particular with moving a window or clicking the Qubes menu.

Second issue is that when using Firefox (whatever Fedora Qube) it no longer refreshes the screen. If I click on a new tab, or scroll it does it, but does not show it. I need to leave (by alt+tab for example) and return and the screen is refreshed.

I wonder what log files I can look up to see why this happens since the update.

My machine have 32GB memory and a fast HDD and it happens even just after reboot when I do not have any additional Qubes running. Just the basic work Qube for example. Nothing else, so resources is not the issue.

1 Like

I can confirm that I also experience this regularly at least on Fedora 36. It’s been happening for quite some time but got worse recently. Sometimes even alt+tab stops helping.

I have no crashes of the whole system though.

It must be related to QubesOS or the GUI because I do not have Fedora 36 I have Fedora 35.

I wonder if it’s kernel related like this issue: random freeze / crashes using 5.4.x and 5.10.x kernels

I wonder if this is due to some issue with the Qubes video driver not able to interact the way it wants to with a particular rendering thread under memory or cpu pressure.

Maybe other video drivers might be able to request the last update of the sub-window, but Qubes’ request might be for a full re-rendering which isn’t currently possible due to cpu or memory constraints. Maybe Qubes doesn’t know to ask for the most recent rendering?


This could be. The lighter I keep it, the less likely it happens. Still before the QubesOS update I could run many Qubes at the same time but now I try to keep it simple so QubesOS only crash and reboots once or twice per day.

A hacky workaround for this is to press F11 twice, which should cycle through what Firefox perceives as “full-screen mode”, forcing it to redraw its window.

But I agree that it still in a bit of a pain…

Today I had a crash round about every hour.

I think it becomes impossible for me to continue to use QubesOS.

I was just working on some documents and then I dragged a window a bit to the left and it freezes up while rendering the move or trying to display the screen dragging and waits a few seconds and crashes and reboots which is especially difficult to cope with.

Where tolook for a possible reason?

Have you tried CTRL + ALT + F4 to open the xTerm and come back with CTRL + ALT + F1 ?

@trounces, can you run the following command in your dom0 terminal and post the output:

lspci -k

What it does: Lists all PCI devices in your computer, along with the kernel modules and drivers that are in use

If you need to get it into an AppVM to paste it into a web browser, do this:

lspci -k > lspci-output.txt
qvm-copy-to-vm <AppVM name> lspci-output.txt

Obviously, replace “<AppVM name>” with the name of the AppVM you use your web browser in.

It will be very helpful to know your GPU and graphics kernel modules, drivers and firmware. That’s why the output of this command will be very helpful.

1 Like

In the Qubes Global Manager I selected 5.10 as the default kernel (instead of 5.15) and I have the impression that resolved the matter but I need to wait a bit to confirm if Qubes no longer crashes.

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
	Subsystem: CLEVO/KAPOK Computer Device 1303
	Kernel driver in use: i915
	Kernel modules: i915

In all honestly, it’s likely that it will. Intel fixed a lot of things with their i915 kernel modules in recents versions.

Let’s hope it works for you!

I mean I went back to kernel 5.10. So far it did not crash with 5.10. I think the new 5.15 kernel is causing the crashes.

It was too early to celebrate. It just froze, crashed and rebooted again. Right after boot the machine is pretty busy and even I drag the windows around or whatever I try I cannot make it crash. But then an hour later or when the machine is quiet with maybe one window open I move or resize the window and it hangs and crashes. This wasn’t the case before the QubesOS dom0 updates.

See also:

I’ve got the exact same issue with kernel 5.15. Now I’ve tried the latest kernel (sudo qubes-dom0-update kernel-latest kernel-latest-qubes-vm) which resulted in kernel 5.18.16-1 and I’m not getting crashes as often. When a freeze does happen I’m only logged out instead of having to power cycle the computer. Will try a bit more to figure out which kernel might be the most stable.

1 Like

I’ve done some extensive testing with kernels 5.10, 5.15, 5.16, 5.18 and combinations of those as well as installing Qubes-20220806-kernel-latest-x86_64.iso from https://qubes.notset.fr/iso/.

I could not avoid Qubes freezing up after 30-60 minutes of standard usage with moderate load. This leads me to believe that it is not a kernel problem.
When using some kernels the Window Manager is restarted when a freeze occurs allowing the user to login again and restart certain hung VMs (which is better than a full restart). Still these problems are quite annoying and will likely mean I’ll have to wait for a future Qubes version or go back to Qubes 4.1.

I agree it is not a kernel problem. I have had this issue trying the various available versions of the kernel with the same results.

Might be worth updating this thread’s title, something like Qubes 4.1.1 freeze for others searching for this issue as it doesn’t seem to be related to the kernel.