Installing and running KDE as Desktop Environment

I found this documentation on the topic: KDE | Qubes OS
However this doesn’t seem to work, at least not in 4.1
Running “sudo qubes-dom0-update @kde-desktop-qubes” downloads all (at least 276 of them) the packages, but then exits with the message "Module or Group ‘kde-desktop-qubes’ is not available.

This may be related

any idea for this. I tried kde on 4.1 and it didnt work . I would like to try again if i have the right command to complete the installation.

KDE is being refactored for 4.1 and currently is not available.

1 Like

Here’s the open issue for this:

well, it’s mostly working, just not the qubes-specific bits.

Its being refactored? I thought the support basically died when you decided to switch to xfce. But kde will still be activelly maintained down the line?

Absolutely not - works well in 4.0 and will work in 4.1
imo KDE is just better for Qubes use than alternatives.

3 Likes

I am using Kde in Qubes 4.1 ,too . Sometimes… Sometimes i3…
And it is working. The problem that the module or group ist not found can be fixed
if u run first
sudo-qubes-dom0-update @kde-desktop-qubes
and then sudo dnf install plasma-workspace
If u like to have Dolphin, too u need to install sudo dnf install dolphin manually, too.
Everything running in Dom0.
And then u can install sddm in dom0. sudo-qubes-dom0-update sddm and can
sudo systemctl disable lightdm and sudo systemctl enable sddm ,use the default kde display manager. For me that has better performance then Lightdm and I prefer it. But I like to switch to the display manager ly as soon I know the compiling. But that is off topic.
A few shortcuts are not working and u have to confgure ur own, but the is the only thing I noticed.
Hope that helps

1 Like

Worked perfectly fine, thank you :slight_smile:

Hello, im new with linux and qubes, using 4.1 (without testing repro yet) tryed to install kde with commands in post above, and all work fine, but couple moments only. On display manager i see virtual keyboard opened and only “enter” closing it. Also first password going empty. Little, but how fix it?
And bigger problem - can’t change keyboard layouts in VMs now. Also, if i trying open “keyboars layout” throught Qube Manager - its just closing. I found some info in google about this type of issues but it was about Qubes 3, and i not sure how i can fix it.

I also tried to use plasma on 4.1, everything seems OK Except that some VM trays icons (like nm-applet) are invisible. Is is OK for you ? Am I missing a package on dom0 or templates ?
thanks !

Hmm indeed, missing nm at least, MS Teams icon missing and a few more. Worked on default xfce.
How about you @rasta ?

1 Like

If you have more than 1 monitor, you need to install kscreen to manage the displays, especially if you intend to mirror a laptop display with an external monitor:

sudo qubes-dom0-update kscreen

2 Likes

I have got the problem with some missing icons, too especially I don*t have an icon to switch beetween virtual desktops. Is there anything more packages to install? I installed sudo qubes-dom0-update latte-dock,too as a dock and sudo dnf install kdelibs . I try to install kscreen now, maybe that is enough for my icon problems, but as soon I know what the problem is, I will post an update. :slight_smile:

At me teams has got a T and some other things as the shortcut item. I am running the orig ms teams version not the electron.

1 Like

The problem is not related to multi monitor, it’s identical on single laptop. Items are there, right-click is operational, but the icon is not shown at all.
Is seems to affect gtk based apps. Qt apps like Qcopy has it’s icon totally operational…

the network manager icon in the tray is here ,if u switch from xfce to kde session ,but if u boot in kde directly then it is missing but if u know where the symbol is then u can click at the taskbar and it will open. But with some other widgets (nearly all) I am not able to place any in the taskbar or whereever. There are some dependencies missing but I don’t know which one. But that should be get fixed anyway:)

1 Like

Absence of nm appplet is a known bug , features (or doesn’t) in 4.0 too

finally, I get the plasma 5 extension virutal desktop bar running fine. U have to install all the dependencies of our own and not like described via the script. That is not working and now with these dependecies a few more icons and things are working. u have to run sudo qubes-dom0-update for each of this packages.
qt5-qtbase-devel
qt5-qtdeclarative-devel
qt5-qtx11extras-devel
kf5-plasma-devel
kf5-kglobalaccel-devel
kf5-kxmlgui-devel

then u can use a widget like this. Just download the .zip -copy it to dom0 run ./scripts/install-applet.sh
and then install the .plasmoid file via add local widgets and u will find the widget and can place it in a bar. maybe there are more dependencies to get it fully working

update: installing these packages makes kde much more working and shows icon like the pager, showing the desktop and else in the task bar or where u prefer. installing sudo qubes-dom0-update latte-dock makes it even more flexible if u like to work with docks and u can choose a good selection of ur bars ,enable autohide and else to have a “big desktop”

4 Likes

Hello to everybody,
I have got a “problem” with the icons, too. In the deskop pannel (standart and latte-dock pannel) it is not using the icons I have set and selected. At the desktop there are the right icons but as I start it then there will be the standart colored icons of the xfce vm’s. I tried to change a icon in xfce and in kde for the same app, but then it even shows the standard icon. How can I change the path in latte config or whereever I need to edit, that it will select the icons from kde everywhere, not only at my desktop? Of course it will be nice tio have them in the pannel ,too. I think I need to change some link to the right folder or sth. like that?
Can u tell me where the standart icons are located? maybe I can copy the other one in the folder and overwrite it and then it will use the icon I prefer for the app.
And it would be nice to know in general how to change an icon for example for firefox in a vm, because then I think it will be on all my desktops the same.

much blesses and thank you very much for your help.

Ps: accoring to the problem with the pager icon, u have to enable on time a second desktop for example in the virtual desktop bar or with a shortcut and then ur are able to put it in the pannel of your chose. And as a tipp ; using the pannel of latte dock is better for customizing if u lake to change ur startmenu or whatever.

1 Like