Windows Camouflage for Qubes

Continuing the discussion from Qubes OS Wallpapers:

Oh, that’s an interesting one. Using a windows background is probably the most cost-effective solution, but there are fancier things. For example, tails used to have a camouflage theme that looked like this:

Sadly it has since become unsupported.

Maybe something like this could be created for Qubes? (one big issue will be how the actual windows are colored… something for which there is just no way around).

3 Likes

a i saw to late the topic was split up sorry.

anyway, you could run a windows HVM in fullscreen? (aside from the regular warning that running applications in fullscreen doest really make it easy for you if you’re working in dom0 or some other VM faking to be dom0)

Ah. Brilliant point! If for a brief moment you needed to pretend this could help.

No, you didn’t. I usually post on the thread and then immediately split my own topic (as a moderator) so it’s more visible that the conversation was split. If I just “reply as a linked topic” people don’t really notice as it just adds a little grey link bellow the post.

1 Like

Is this for a more anonymous fingerprinting profile?

There is also a Debian-based distribution called Q4OS which supports the Trinty desktop. There you have a very much Windows-like environment and can also load themes that look like Windows XP, 7 or 10.

Currently Q4OS runs under Qubes as standalone, template and AppVM, but there is no qrexec support. It would be nice if someone could provide a template, which might not be too difficult, as this is a rather plain (and very fast) debian system.

1 Like

I guess the use-case is here is if someone is in a public place and doesn’t want to draw too much attention to the fact that they are using a “weird” operating system. Can raise unnecessary suspicions for some threat models.

1 Like

Like this?

2 Likes

Wow. I have no words. This is exactly what I was looking for when I started this thread.

How does one get to that configuration, if I may ask?

Looks like KDE: change desktop background, icon for launcher and window decoration, I suppose. There are likely multiple “Windows 10” themes you could download and apply.

Nope, it’s Xfce.

  1. Move the panel to the bottom of the screen
  2. Create ~/.icons and ~/.themes in dom0
  3. Go to B00merang Project · GitHub and bow down before them.

In a qube:
4. wget https://github.com/B00merang-Artwork/Windows-10/archive/master.zip
5. wget https://github.com/B00merang-Project/Windows-10/archive/master.zip

In dom0:
Transfer those files into dom0
6. Unzip the file from 4 in ~/.icons
7. Unzip the file from 5 in ~/.themes
8. Open “Appearance” - set Style to “Windows-10-master”, and Icons to “Windows 10”
9. Open “Window Manager” - under Style set Theme to “Windows-10-master”,

Fine tuning:
10. Right click on Applications Menu, Properties, Change Icon to “Start here”
11. Right Click on Desktop, “Desktop Settings”, change Background to a Windows wallpaper.
12. Right Click on Desktop, “Desktop Settings”, “Icons”, select “Home”,“Filesystem”,“Wastebasket”

Most Windows machines seem to have a search tool next to Start, and Bluetooth next to the clock.
You want these icons, not those functions.
Right click on Panel, Panel->“Add New Items”, select launcher and choose an application.
(You could , for example, add a launcher for xfce4-screenshooter.)
Change the icon to a Windows Icon - e.g the search glass.

Done.
This will pass casual inspection.
All usual warnings about transferring files in to dom0 apply.

7 Likes

Amazing! Thanks for the writeup @unman. (even moved this to the “user support” category to mark your post as the solution).

Haha. Will do. Amazing work there, it seems. I had not heard of that project before.

Something like that Kali Linux / Packages / kali-undercover · GitLab would be awesome

3 posts were split to a new topic: How do you Move the Files from a qube to dom0?

I am stuck on this part. The files are in dom0 now, but I don’t have any GUI to unzip them and I’m not sure how to do this at the command line level or how to move them into the proper directory.

There is a GUI filemanager. Run “thunar” from terminal to start it.

1 Like

They are in the right directories now, but I don’t know how to unzip them. I didn’t see a way to do that in Thunar. There’s probably a built in command line way in Qubes that I just don’t know.

Fortunately, there is a handy unzip command, you can use in a terminal.

1 Like
  Windows-10-master/gtk-3.20/assets/checkbox-unchecked-unfocused.png -> checkbox-unchecked.png
  Windows-10-master/gtk-3.20/assets/checkbox-unchecked-unfocused@2.png -> checkbox-unchecked@2.png
  Windows-10-master/gtk-3.20/assets/radio-checked-insensitive-unfocused.png -> radio-checked-insensitive.png
  Windows-10-master/gtk-3.20/assets/radio-checked-insensitive-unfocused@2.png -> radio-checked-insensitive@2.png
  Windows-10-master/gtk-3.20/assets/radio-checked-unfocused.png -> radio-checked.png
  Windows-10-master/gtk-3.20/assets/radio-checked-unfocused@2.png -> radio-checked@2.png
  Windows-10-master/gtk-3.20/assets/radio-mixed-insensitive-unfocused.png -> radio-mixed-insensitive.png
  Windows-10-master/gtk-3.20/assets/radio-mixed-insensitive-unfocused@2.png -> radio-mixed-insensitive@2.png
  Windows-10-master/gtk-3.20/assets/radio-mixed-unfocused.png -> radio-mixed.png
  Windows-10-master/gtk-3.20/assets/radio-mixed-unfocused@2.png -> radio-mixed@2.png
  Windows-10-master/gtk-3.20/assets/radio-unchecked-insensitive-unfocused.png -> radio-unchecked-insensitive.png
  Windows-10-master/gtk-3.20/assets/radio-unchecked-insensitive-unfocused@2.png -> radio-unchecked-insensitive@2.png
  Windows-10-master/gtk-3.20/assets/radio-unchecked-unfocused.png -> radio-unchecked.png
  Windows-10-master/gtk-3.20/assets/radio-unchecked-unfocused@2.png -> radio-unchecked@2.png
[user@dom0 .themes]$ dir
master.zip.1  Windows-10-master

I was able to unzip them, but am not seeing them in the directory. And under appearance, I am not seeing Windows-10 anything

It’s not working.

I used sudo and unzip, but I’m still not seeing the theme. I also don’t see the directory in Thunar. I created it, it’s there, but I can’t see it. I’m not sure why.

Files / folders that start with a . like ./themes are hidden files. They are not shown by default. To view them on the dom0 file manager (thunar) you need to open the: menu » view » show Hidden Files. Alternatively you can press ctrl+h (and do the same to hide them again).