UEFI boot: no Qubes OS option

Looks like you missing boot option.

  • You need qubes os installation, boot from usb and select qubes rescue mode.
  • Type 1 and enter your Encrypted Password.
  • Ignore if there’s a pop up about you don’t have any linux partition.
  • type fdisk -l and find your /boot and /efi partition in my case it’s /dev/sdb1 and /dev/sdb2 then mount under /mnt

example :
mount /dev/sdb2 /mnt
mount /dev/sdb1 /mnt/efi

  • follow this step :

Boot device not recognized after installing

Some firmware will not recognize the default Qubes EFI configuration. As such, it will have to be manually edited to be bootable. This will need to be done after every kernel and Xen update to ensure you use the most recently installed versions.

  1. Copy the /mnt/efi/EFI/qubes/ directory to /mnt/efi/EFI/BOOT/ (the contents of /mnt/efi/EFI/BOOT should be identical to /mnt/efi/EFI/qubes besides what is described in steps 2 and 3):
 cp -r /mnt/efi/EFI/qubes/. /mnt/efi/EFI/BOOT
  1. Rename /mnt/efi/EFI/BOOT/xen.cfg to /mnt/efi/EFI/BOOT/BOOTX64.cfg :
 mv /mnt/efi/EFI/BOOT/xen.cfg /mnt/efi/EFI/BOOT/BOOTX64.cfg
  1. Copy /mnt/efi/EFI/qubes/xen-*.efi to /mnt/efi/EFI/qubes/xen.efi and /mnt/efi/EFI/BOOT/BOOTX64.efi . For example, with Xen 4.8.3 (you may need to confirm file overwrite):
 cp /mnt/efi/EFI/qubes/xen-4.8.3.efi /mnt/efi/EFI/qubes/xen.efi
 cp /mnt/efi/EFI/qubes/xen-4.8.3.efi /mnt/efi/EFI/BOOT/BOOTX64.efi
  • finally umount your /boot and /efi partition and shutdown ( I prefer shutdown than restart, sometimes restarting took really long time, i don’t know why )
    umount /dev/sdb1
    umount /dev/sdb2
    shutdown now

Hey guys,
I just spend 2k to buy a dell laptop and a SSD removable to start working with cubes, but I faced the same problem.
I installed qubes successfully and played around with it but after restarting my system, it didn’t show up on the UEFI boot option, I can see my SSD, but it’s not recognized as a bootable device.
I have reinstalled it 3 times now to make sure I’ve done it right, and I have verified the signature and authenticity of it
I tried the suggested routes on here but when I mount the sdb2, it replies with, it is either already mounted or it’s busy
when I try to mount the sdb1, it replies with the directory doesn’t exist
and it’s right because in the mnt directory the is just a directory called install and there is no efi directory inside it
ill be grateful if you can shed some light on this matter for me please
I can’t wait to start using qubes and I can’t

thanks a lot in advance

simply add uefi entry menu by booting into your qubes os installation medium, rescue qubes os, wait and type 3 to skip shell, lsblk to examine your external ssd, if it’s /dev/sdc then run

efibootmgr -v -c -u -L "TheEnemy" -l /EFI/qubes/grubx64.efi -d /dev/sdc -p 1

-p 1 is stand for partition 1, as default in most os, partition 1 is your efi partition.

Thanks a lot, ill give it a go

This was the result

there is no sdc directory

the UEFI option disappears when I remove the SSD and plug it back in again
thanks again

sdc is just an example, you should change it to your actual drive.

^, then from your ss, your external SSD seems to be /dev/sda,

you should run
efibootmgr -v -c -u -L "TheEnemy" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1


A new UEFI option was created and after choosing it, it went through OS recovery and repair, it was trying to repair my windows and said no issue found obviously
this is so strange, why is this happening?
Do you mind video calling me or something, please? So I can fix this issue
I am prepared to pay for your time you spend in helping me
thanks a lot

boot like before, and make sure your external ssd is /dev/sda (it could change, run lsblk first, if it’s still /dev/sda then no need to change command below, if it was /dev/sdb or /dev/sdc, change the /dev/sda below to /dev/sdb or /dev/sdc).

mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/efi
cp /mnt/efi/EFI/qubes/grubx64.efi /mnt/efi/EFI/boot/bootx64.efi
cp /mnt/efi/EFI/qubes/grub.cfg /mnt/efi/EFI/boot/bootx64.cfg
efibootmgr -v -c -u -L "TheEnemy1" -l /EFI/boot/bootx64.efi -d /dev/sda -p 1

boot into your uefi settings, change the uefi order, TheEnemy is your first order, TheEnemy1 is second.


That did it
thanks a lot :smiley:

Please consider to flag the post as solution, for the sake of other users with the same issue, at least.

how do i do that please?

There should be an icon somewhere beside the “heart” icon, below @51lieal’ resolving post.

he’s not the thread starter, so can’t.

Oh I terribly apologize to both of you. I obviously overlooked who the OP was while focused on a solution itself.


Your replies have been very helpful so far.

efibootmgr -v -c -u -L “TheEnemy1” -l /EFI/boot/bootx64.efi -d /dev/sda -p 1

Unfortunately results in EFI variables are not supported on this system.
Any idea how to fix this? Thanks.

looks like you didn’t boot the recovery using uefi, check again.
or if you using debian based to recovery you need to load efivars modules.

Your commands have been very helpful, all tho I think they dont work for me, can you take a look at what commands I should do instead?

Photos: 425.8 KB folder on MEGA

When I was doing the installation I kept everyting on automatic and only put my passphrase.

I was stuck with it for a while, tried almost everything that people suggested. But none of them work.

Thanks to you for the method worked well, you are an incredible person. :fist_left:

Worked like a charm! Thanks for the help👍

I needed to create an account just to congratulate this one… Very nice. I was months trying to install qubes, this was my last attempt… Now I am logged in.


1 Like