Can't boot into Qubes


I’ve been trying to install Qubes 4.1.2 but I’ve been having some issues. I have a separate SSD for the sole purpose of having Qubes on it. I go through the installation process fine saying I have to reboot but after I hit the blue reboot button, I can’t find a way to boot into Qubes. On Windows 11 in disk management, I can see that there are files installed on my other SSD, but I can’t find it anywhere in my UEFI settings. My motherboard is the MAG B660 TOMAHAWK WIFI DDR4. I’ve tried following the instructions in UEFI troubleshooting | Qubes OS under the “Installation finished but “Qubes” boot option is missing and xen.cfg is empty / Installation fails with “failed to set new efi boot target”” section, but the directories /boot/efi/EFI/qubes and /mnt/sysimage/boot/efi/EFI/qubes do not exist. I’ve tried going into both option 1 where it tries to mount /mnt/sysimage and option 3 (in rescue mode) to skip straight to the shell, both did not show me the directories mentioned previously. What are some ways I can try booting into my Qubes SSD? I’m not sure where to go from here.

I don’t have the answer to this exact problem, but here are some general troubleshooting steps:

  • First, back up all of your important data from the Windows drive.
  • If secure boot is enabled for Windows, try disabling it. Secure boot may be keeping another operating system from loading. (Disabling secure boot may also prevent Windows from booting now if it was enabled before, so be careful.)
  • Try checking the Legacy/UEFI boot options in your BIOS/UEFI and changing that to see if that works.
  • Is the Qubes SSD an external SSD or an internal SSD? If it’s an external SSD, try moving it inside the computer to see if that works.
  • Try reinstalling Qubes.

I hope this helps.


I really appreciate your response. I don’t think the first option is a possibility since I don’t have a 2TB external SSD or HDD, plus it won’t be that bad if I lose all my data in my windows drive since it’s mainly video games that take up most of the storage. For the second option, you are right, and I have had secure boot disabled. For the third option I’d have to check my UEFI settings again to check for a Legacy feature. For the fourth option, to clarify it is an internal SATA 240GB SSD. And for the last option I might try again, but I’ve already tried with rufus and balena etcher. Thanks again for all the tips! :slight_smile:

This topic might help:

try first the 5th post:

If that doesn’t work, try the 3rd post:

Thank you!

What helped me is this post UEFI boot: no Qubes OS option - #4 by TheEnemy where i had to run efibootmgr -v -c -u -L "TheEnemy" -l /EFI/qubes/grubx64.efi -d /dev/sdc -p 1 where /dev/sdc is the new SSD i wanted Qubes to be installed on, and “TheEnemy” is the name i see in my UEFI settings. I got Qubes to work.