UEFI boot: no Qubes OS option

Worked like a charm! Thanks for the help👍

I needed to create an account just to congratulate this one… Very nice. I was months trying to install qubes, this was my last attempt… Now I am logged in.

THANK YOU!!!

1 Like

This issue explains more about UEFI boot entries missing. There are also instructions there for fixing UEFI

  1. Mount the bootloader partition
  2. Copy the contents of /mnt/EFI/qubes/ to /mnt/EFI/BOOT/
  3. Rename grubx64.efi to bootx64.efi
  4. Rename grub.cfg to bootx64.cfg
  5. efibootmgr -v -c -u -L Qubes2 -l /EFI/BOOT/bootx64.efi -d /dev/sda -p 1

You can use such an option where you don’t have to copy grubx64.efi again every time after kernel update or changes in configuration files.

mount /dev/sda2 /mnt
mount /dev/sda1 /mnt/efi
cp /mnt/efi/EFI/qubes/grubx64.efi /mnt/efi/EFI/boot/bootx64.efi
efibootmgr -v -c -u -L "Default" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1
efibootmgr -v -c -u -L "Recovery" -l /EFI/boot/bootx64.efi -d /dev/sda -p 1
efibootmgr -o 0000 (instead of 0000, you must specify the number of the created boot record named Default so that it will be loaded first)
reboot

It’s better to use postinst kernel hook:

@Timm I’ve makred @51lieal post as the solution because a few folks pointed to it, and highlighting it seems like it could help more people finding a solution to their issues.

Of course, you asked the initial question, so please feel free to correct that if you think I made a mistake!