Troubles with installing QubesOS (not enough memory it claims)

So, I’ve recently tried installing QubesOS on my manjaro
linux system. I wanted to replace my operating system
for something more secure and more privacy oriented.
We’ll, I ran into an issue upon booting the live USB
image, when 1 go to the partition settings on installation
it is saying I only have 6.03MB free DESPITE the fact
I literally have 476GB in my SSD available. So l’m not
even able to proceed with installation because it isn’t
detecting how much storage I have, I have plenty
however it’s only saying I have 6MB like what?? I’m
confused and I hope someone here can assist me
as to what the issue is, I’ll give whatever information
necessary. I also attempted to “reclaim space” however It says Im only able to even have 300MB which is no where even CLOSE to what I need, nothing happens even if I do try to reclaim. I would greatly appreciate it so much if someone helped me figure out what is wrong :slight_smile:

My hardware information: (PC: Dell Latitude 5430
CPU: 11th gen Intel i7-1185G7 (8) @ 4.8GHz GPU: Intel
Tigerlake-LP GT2 (Iris Xe Graphics) Memory: 16GB RAM
Kernel: 6.1.55-1-MANJARO

That’s because you have an existing manjaro install which has claimed the most space of your SSD. I think you’ll need to use “Custom” storage configuration, and proceed to deleting the existing partitions, then auto create the partitions for Qubes.

1 Like

Hmmm, I see. Would you kindly walk me through it? I dont fully trust myself in custom configuring and Im not fully sure what Im doing in it either.

I’d love to, but I’m currently lacking access to an installation media and a laptop to confidently reproduce the steps for you. It’s better to wait another person to step in, then use personal messages for the detailed walk through. ( in order to keep this thread organized)

1 Like

Ohh okay, I see. Well I appreciate your help none the less! Thank you.

1 Like

Select Custom, press Done button, then on Manual partitioning screen remove all partitions with - button then press Click here to create them automatically for installer to create default partitions.
You can find more info and images here:

If I did this, would it break my manjaro linux operating system and there would be no way to recover it?

If you want to keep your manjaro and install Qubes OS alongside it then you need to free up the space on your drive.
For example, you can shrink the manjaro partition with gparted and install Qubes OS in this freed up space.
You need to download and write gparted ISO on your USB and boot from it:
Then resize the partition:

No I dont want manjaro anymore, but Im just nervous if something goes wrong during the installation then I have nothing to fall back on, thats why I asked that. But, it wont actually apply any changes until I click begin installation correct? And if there is an issue with automatically creating the partitions it will let me know? And it wont wipe the disc yet?

Yes, as stated in the Fedora docs link:

No changes to any disks will be made until you press Begin Installation in Installation Summary. The Reclaim Space dialog only marks partitions for resizing or deletion, but no such action is performed immediately.

Also, you don’t have to press on Custom partitioning and into the Manual partitioning screen. As stated in the docs:

If you selected automatic partitioning and the I would like to make additional space available, or if there is not enough free space on your selected hard drives to install Fedora, the Reclaim Disk Space dialog will appear. This dialog lists all disk devices you have configured and all partitions on those devices. The bottom right corner of the dialog displays information about how much space the system needs for at least a minimal installation and how much space you have reclaimed.


I can't create more replies because of forum policy so I'll update this reply.

An error occurred: We appreciate your enthusiasm, keep it up! That said, for the safety of our community, you’ve reached the maximum number of replies a new user can create on their first day. Please wait 10 hours and you’ll be able to create more replies.

Yes, but try to see if Reclaim Disk Space dialog will appear in the Installation destination first, it’d be easier this way.

There should be button Delete all of Delete there to delete partitions.


Okay, upon pressing “-” it says “nvme0n1p1 may be a system boot partition! Deleting it may break other operating systems. Are you sure you want to delete it?”

And theres a box that I can check that says “delete all file systems which are only used by unknown”

Should I check that box?

Well, when I click reclaim space it says it can only reclaim up to 300MB which seems false to me. So I believe going the manual route is needed.

Okay! Nevermind. I did the manual partition delete and it automatically made the new ones, its now installing! I appreciate your help so much! Have an amazing day :grin:

1 Like

Uhhh an issue though, whenever I try to launch a cube, I get an error “Qube status: sys-net Qube sys-net has failed to start: internal error: unable to reset PCI device 0000:00:1f:6: no FLR, PM reset or bus reset available” what is happening?? Any advice?

Search on this forum helps:

1 Like

Hm, okay. I deleted the offending PCI device but now its saying it doesnt exist. It was an intel ethernet connection, I dont even believe its configured anyways for the internet.

Check the PCI troubleshooting link.

Can you describe in more details when and where do you get this message and its exact content?

Hm okay. Well, I didnt save that deletion of the PCI device to persistent storage so it wasnt a permanent change but It looked like something important since it said ethernet connection.

Okay so, I get this error of “Qube status: sys-net Qube sys-net has failed to start: internal error: unable to reset PCI device 0000:00:1f:6: no FLR, PM reset or bus reset available” ANYTIME I try to launch a qube, for example if I click on the blue cube “work” and try to open firefox internet browser, it wont launch but instead pop up a notification immediately of that error. I suspect there is no internet connection and that might be the cause since I never truly entered any password for any network, but you’d think it would at least still “try” to start. But I may need to manually somehow connect to wifi I wish I had a GUI for it, but that might not be the main issue. But yeah I wanna just open up the web browser and it prompts me with that issue, also if I go to the settings of sys-net and refresh the applications, it gives the same error, another thing is that IF I enter for example “sudo apt update” on the Debian qube, It gives many errors hinting something is going on with the internet connection I’d imagine.

What do you think I should do?

Did you read the PCI troubleshooting doc that I linked?

You can also configure strict reset directly from the Qubes interface by following these steps:

Go to the sys-net VM settings

Go to Devices

Make sure the device is in the right field

Click “Configure strict reset for PCI devices”

Select the device, click OK and apply
1 Like