Installing Qubes - Unable to reset PCI Device

I’m trying to install Qubes 4.1 on a Dell Latitude 5590 which has an ethernet port. The install process goes fine, but after everything has completed (before logging in) I get the following error message:

['/usr/bin/qvm-start', 'sys-firewall'] failed:
stdout: ""
stderr: "Start failed: internal error: Unable to reset PCI device 0000:00:1f:6: no
FLR, PM reset or bus reset available, see /var/log/libvirt/libxl/libxl-driver.log
for details
"

When I get to the desktop I have no ethernet or wifi. The lights on the ethernet port on the laptop are blinking and I confirmed it worked when running Windows. Wifi is not strictly necessary but I do need internet.

Does anybody know what the issue might be?

Is sys-net able to start?

It might be an issue with the devices passed to sys-net.

It looks like your device controller is attached to sys-firewall which is wrong.

@renehoj When I try to start up a disposable VM, Qubes tries to also start both sys-net and sys-firewall. I get 3 error messages saying that none of the VM’s can be started “Unable to reset PCI device”.

@enmus Do you know how to fix it? When setting up Qubes I did check the box to create sys-usb. I did not check the box to use sys-net for both usb and networking.

Is there something I have to change in the BIOS maybe?

First, check that is actually the case:

$ qvm-pci ls sys-firewall

If there is indeed a controller attached to sys-firewall, detach it:

$ qvm-pci detach sys-firewall [BACKEND:DEVICE_ID]

The [BACKEND:DEVICE_ID] looks something like this: dom0:0x_xx.x

Depending on your case, you may want to attach the extra controller to sys-net:

$ qvm-pci attach sys-net dom0:0x_xx.x

You can start with checking the devices tab in sys-net settings, it could be your ethernet or wireless devices that fail to initialize.

When you know the device name/model of 00:1f:6 you can confirm you have the correct driver/firmware.

The dmesg command i dom0 might also give you some useful information.

When I run qvm-pci ls sys-firewall I get the following output:

BACKEND:DEVID DESCRIPTION USED BY

If I run qvm-pci ls sys-net I get:

BACKEND:DEVID DESCRIPTION USED BY
dom0:00_14.3 Network controller: Intel Corporation WIreless-AC 9560 [Jefferson Peak] sys-net
dom0:00_1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM sys-net

Trying to start sys-net from the terminal I get:

Start failed: internal error: Unable to reset PCI device 0000:00:1f.6: no FLR, PM reset or bus reset available, see /var/log/libvirt/libxl/libxl-driver.log for details

Looking at the that log I get this:

libxl: libxl_pci.c:1489:libxl__device_reset: The kernel doesn't support reset from sysfs for PCI device 0000:00:14.0

So I assume it’s a kernel issue? This is laptop is a few years old so I assumed the kernel used in 4.1 would support this hardware. Sorry I’m out of my depth here…

Edit: also ran sudo dmesg in dom0 and I get a wall of text. What am I looking for?

Try to set

qvm-prefs sys-net virt_mode pv

reboot just in case and try to start sys-net.

Also. you can try

qvm-pci attach --persistent sys-net dom0:00_1f.6 -o no-strict-reset=true