Sys-net not starting because it is unable to reset PCI device

Hello qube community,
I am new to qubeOS and tried installing it for around 3 days now. I installed it multiple times from different USB sticks, however whenever I am trying to start a Qube it fails because of the error "Qube sys-net has failed to start: internal error: unable to reset PCI device 0000:00:1f.6 no FLR, PM reset or bus reset available." I already tried the fixes for this error from the QubeOS website without success (PCI troubleshooting | Qubes OS)

I checked what the device with that PCI address is with lspci and it turns out it is the “Ethernet controller: Intel Corporation […]”. I can’t remove the device from the device manager because every device tab including the one from the sys-net is greyed out.

I tried every fix I found on the internet but none have worked and I am kind of lost here. Thanks for any help!

Can you run in dom0:

qvm-pci | grep 1f.6

The third column should report the VMs to which the controller is attached (ie. sys-net).

Let me know what domains it’s attached to.

Hey, I appreciate your time. Failed to list 'pci' devices, this device type either does not exist or you do not have access to it. is what I get. I tried with sudo as well.

Perhaps you’re typing the command wrong. Note that you need to run this in dom0, not a vm like sys-net.

You can also try with:

qvm-pci ls | grep 1f.6

If it doesn’t work, run qvm-pci and check manually. The entries won’t be filtered but you’ll get all the output.

I get the same error whenever I do any qvm-pci command even simply ‘qvm-pci’. The grep is not the culprit here.

What have you tried exactly? Maybe you changed some perms.

Are you able to enter root with sudo -i and then run qvm-pci ?

I turned off intel virtualisation in the bios and now I am able to open qvm-pci.However when I try to start sys-net now the error massage is Qube sys-net has failed to start: Failed to start an HVM qube with PCI devices assiigned - hardware does not support IOMMU/VT-d/AMD-Vi. Are you still interested in what the qvm-pci ls | grep 1f.6 says?


It says sys-net

Alright, try the following:

$ qvm-pci detach -v sys-net dom0:00_1f.6
$ qvm-pci attach -v --persistent --option no-strict-reset=True sys-net dom0:00_1f.6

If you run qvm-pci ls | grep 1f.6 again, you should see sys-net (no-strict-reset=True)

Then go back to bios and enable all virtualization settings.


You really know your stuff! The disabling virtualisation → changing the sys-net options → enabling virtualisation did the trick. Thank you for your time, you really helped someone out here!

1 Like

Glad I could help!