Cannot start any qube


i installed Qubes 4.2.1 with the latest kernel on a Dell Latitude 5431.

However i cannot start any qube. The only one running is sys-usb. When trying to start any qube i get a

“Qube <whatever> failed to start internal error: Unable to reset PCI device <something> no FLR, PM reset or bus reset avaibale” Notification.

The devices Tab in the settings is greyed out for all qubes.

sudo qvm-pci says: Failed to list ‘pci’ devices, this device type either does not exist or you do not have access to it.

lspci however does show the pci devices correctly.

I tried adding iommu_inclusive_mapping=1 as a boot parameter as indicated here but this did not help. Tried disabling virtualization as indicated here without effect.

I also tried this, but it did not work for me.

With journalctl -xe i see the same error from libcirtd as shown in the notification.

How to troubleshoot/solve this?

Are you really unable to start any qube? Even one with no netvm and
no devices allocated?

Do you have Intel Volume Management Device enabled? You should be able
to go in to BIOS and disable it, reboot, and see what happens.

1 Like

Thank you for your help!

You where right, i was able to start vault qubes.

Also, Intel Volume Management Device was indeed enabled. I disabled it and i can see the devices now, but the problem with the reset persists.

What solved it, was doing qvm-pci attach --persistent --option permissive=true --option no-strict-reset=true sys-usb dom0:<BDF_OF_DEVICE> source