Installation problem. No Software/No Templates/No Default System Qubes

So you did get this screen, when you installed Qubes?

– I’ve had installation, where the “INITIAL SETUP” failed to start, so I didn’t get a chance to install Fedora/Debian/Whonix and that would leave me without sys-net/sys-firewall … :-/

Yes I did. But, still software/templates/and default settings/tools was missed :frowning:

Then I’m almost out of suggestion - except to repeat what others have suggested before:

  • download the iso from the homepage
  • verify the signatures
  • write the iso to a USB-stick
  • redo the installation
  • snap an image of the “INITIAL SETUP” screen and the screen that is shown when clicking on “QUBES OS”

Okay, I understand. Thank you for explanation.
I always will see my topic in slightly grey color? Or this is feature for a newbie accounts?

1 Like
Off-topic explanatiom

I’m not sure what you mean by slightly gray color.

If you’re taking about looking at the topic (title) in the list of topics, the gray ones are the one that you’ve read! They become white when they contain posts that you haven’t read, and turn gray again once you read them.

All topics behave like that, not only yours! :slightly_smiling_face:

1 Like

Ok, now I understand, thank you.

Okay, seems this topic still is going. So now just my few lines on that:

I also had exactly this error two years ago, buy installing the 4.1 version on an old P50 laptop. I couldn’t understand, why it didn’t show me the “correct” screen to choose templates, make one of them “the default” and ticking on checkboxes to define sys-qubes and if they should have disposable templates…

Reason simply was: A faulty .iso file I’ve downloaded from the Qubes-OS servers - or let me write this correct: The file possibly was good, but the download destroyed somethings… can’t explain.
Solution was in the end to download the .iso on a diferent device and also burn it elsewhere…

Here some screenshots, what Query probably see:

You are still not providing your bios settings.

You still aren’t saying # of times you tried to burn to USB.

I didn’t ask those questions randomly.

Download the iso again, check the hash, burn it, try to install.

If it doesn’t work, burn to USB again, and try to install again. If that doesn’t work, try a different USB drive.

If that doesn’t work, post your bios settings although you should have done that a while ago.

Can a mod change this so it’s replying to the poster Query and not ChrisA?

Hello again, I’m so sorry for late response.

I verify only qubes-master-signing-key.asc
I don’t get it, why Downloaded Mirrors have no PGP-key?
My 1st thing is, give a chance to try Qubes OS or as I would say, finally!! :grinning:
That’s 1st thing, as I mention in my 1st post my problem now are inside a code, that’s what I’m dealing with rn.
I need working OS

My BIOS setting are like this:

  • UEFI network stack - Enabled
  • UEFI boot path security - Always
  • Sata operation - AHCI
  • UEFI capsule firmware updates - Enabled
  • TPM security - OFF
  • Secure boot - Disabled
  • Secure boot mode - Deployed mode
  • Intel SGX - Disabled
  • USB provision - Disabled
  • Intel Virtualization Technology - Enabled
  • VT for direct I/O - Enabled
  • HyperThread control - Enabled

I tried to burn a usb few times and I install a iso few times either
I never try different usb, but it’s nothing to do with a usb, it’s iso problem or just my hardware, I really think I should try play with a codes.

I will check and try everything again tomorrow

Verify the ISO first to check that it was downloaded correctly and it’s not corrupted:

And then re-verify your installation media after writing:

I don’t think that’s an option.

Is there a reason to have TPM off?

What does “USB provision - Disabled” mean?

There are also hashes of files. You an download a hash program like gtkhash or some Windows version of that and compute the hash. If you are computing a hash in Windows, because it’s not open source it’s harder to know if you have been exploited so the hash value could be modified by an exploit and be incorrect, but this is unlikely. Find a guide for how to do this online if you aren’t sure. They are listed under cryptographic hash values, download that from different Tor exit nodes to make it less likely to be tampered with.

There are hash values posted for the Qubes iso. You want to use Tor to view that, copy the value, then reload the page multiple times with different tor circuits to confirm the value hasn’t changed.

Sometimes a ISO file downloaded by torrent will not have all the parts entirely correct but you can still burn it to a USB and it will even still load. But once you get to the installation, you get errors or things seem off.

Others have had problems installing Qubes and needed to use a different USB drive. Qubes is very fussy. You turn one 0 into a 1 and it won’t run.

Verify the iso, try multiple ways of burning the iso to USB, try different USBs. This is probably a problem with a slightly corrupt ISO file that boots but won’t install.

Hi again
Sorry for late response, but those thing that I could not find a solution pissing me off

I enable-disable TPM, I tried many other options to switch on-off in bios as well

Let me explain again.
Yes I verify my ISO, yes hash-hash it was correctly downloaded and installed at my usb

Yes I do checked web version, download-install at usb- went thru installation process and have same issue, also any time when I checked quality of ISO image (at usb media) inside installation process it tell that it’s bad USB
(I understand why, because it don’t have default system qubes/software/templates, but inside ISO file I can see them, so aaaaaallll this time long I was trying to find a solution how to invoke Default System Qubes/ Software/ Templates )

But, it also kinda weird suggestion from peoples, because official Qubes have only have 2 web-site and 2 torrents from we can downloaded our images which are officially maintained by Qubes project, all other options it’s just mirrors (not-trusted or less trusted), so if we downloaded from official sources it should not have any problem in theory and if they did we also actually have no choice lol :smiley:

pre-last time I downloaded from 1 of official web-source it failed and last time I downloaded 4.2.0 Qubes from torrent file and don’t checked by hash, because torrent itself checking it on a hash and if it downloaded 100% it’s mean that this downloaded are the same that source have hash-to-hash.

It’s my nightmare, I’m so exhausted that I Still could not use Qubes OS :face_with_head_bandage: :sob: :weary:

Qubes team have a remark, to let Qubes work at my laptop: To boot the installer, you need to remove mapbs=1 and noexitboot=1 To get suspend to work, you need to add mem_sleep_default=deep to the kernel= line in /boot/efi/EFI/qubes/xen.cfg.

I also try to use GRUB
/boot/grub/GRUB/qubes/xen.cfg doesn’t work as well, system also can’t find this command :poop:

I think this remark will help in my situation to invoke Default System Qubes/ Software/ Templates , but system couldn’t find and open this command, not when I try efi/EFI or grub/GRUB command.

I also try to put mapbs=1 and noexitboot=1 at GRUB command line, but I don’t know how GRUB work, because it doesn’t show does it safe this command or somehow :confused:

@marmarek I know you are pretty busy, I respect and appreciate your time, but may you look at this topic please, I’m struggling for damn long and try a lot of different things and suggestions and it still could not solve my situation/problem. Appreciate your attention. :hugs:

@apparatus @dispuser

Let’s start here – can you explain (at length) which steps from Installation guide | Qubes OS (The installer Home Screen) - the images are from an older installation, but the steps are similar - works all the way to Installation guide | Qubes OS (Initial Setup). I assume all the steps works - and it’s the “Initial Setup” that is responsible for installing the templates - so can you share an image of which options you have after clicking “QUBES OS” in the Initial Setup?

If you click “Quit” to the Initial Setup, you should be left with an installation without Software/Templates/System Qubes.

Downloading from the official web-source isn’t an guarantee that no adversary has tampered with what you get (both ISO and hash values) – the only way to know, that you have the same ISO as the developers released, is to verify their signing.

Could you share [a link to], where you found that? – I don’t recall seeing /boot/efi/EFI/qubes/xen.cfg in Qubes OS 4.1 or Qubes OS 4.2 - so it sounds like info for an ancient Qubes OS release and might not be relevant for the current Qubes OS 4.2 Release.

Would you be willing to share the make/model of your laptop?


Give me a bit of time and I will try to boot again and text you exactly what I see.

Here are a link where I took this information from.

Dell Latitude 7400

For once a machine I know works with Qubes OS (well - with Qubes OS 4.1 at least) … :smiley:

Edit: Remember to click the “QUBES OS” on the center of the screen, when you get to:

– if you click “QUIT”, you’ll be left with a dom0 with “No Software/No Templates/No Default Qubes” …


1 Like

i hope this is the answer

Last time I download fresh Q4.2.0, completely verify it, everything was good.
Burn it to usb.
Before start installation process, check at some Qubes window quality of USB (don’t remember exactly how it called) and it says “Bad USB and something else like not good idea install from this stick”, was upset because this time I completely check ISO and everything was good and still get this message at “Qubes installation window”, so I just continue do my things, because no other option, right?!

Same as before I doesn’t have any other options except Dom0, decide to continue installation process as well.

So, when installation was finished and laptop was rebooted, this window with “QUBES OS” in a middle of the screen pop out, I press on a icon and kinda similar settings was like before:


Templates Configuration
:black_square_button: Whonix not available
Default: [ here are a blank button/window ] (and I Could not tick on it, probably here should be software options like Fedora or Debian)

Main Configuration (btw I think that now I have this options because I create manual partitions)
:white_check_mark: Create default system qubes (sys-net, sys-firewall, default DispVM)
:white_check_mark: Make sys-firewall and sys-usb disposable
:white_check_mark: Create default application qubes (personal, work, untrusted, vault)

Advanced Configuration
:o: Create ‘vm-pool’ LVM thin pool
:radio_button: Use existing LVM thin pool (I tick on it)
LVM Volume Group: qubes_dom0
LVM Thin Pool: root-pool


After I press continue installation setup
and by ending Installation Progress this window pop out:

                           [Dom0] ERROR (on dom0)

Qubes initial configuration failed. Login to the system and check /var/log/salt/minion for details. You can retry configuration by calling ‘sudo qubesctl --allstate.highstate’ in dom0 (you will get detailed state there).

I checked /var/log/salt/minion by
nano /var/log/salt/minion
[salt.pillar ] [CRITICAL] Specified ext_pillar interface qvm_prefs is unavaible

I also checked ‘sudo qubesctl --allstate.highstate’, but was confused with all that information and again don’t know what to do… :confused: and also for retry the configuration from qubesctl, should I insert Installation Media (ISO usb)?

Qubes team have a remark, to let Qubes work at my laptop: To boot the installer, you need to remove mapbs=1 and noexitboot=1 To get suspend to work, you need to add mem_sleep_default=deep to the kernel= line in /boot/efi/EFI/qubes/xen.cfg.

How to do that?