Installation problem. No Software/No Templates/No Default System Qubes

hum. How did you install Qubes ISO to USB stick. Which OS? Which tool?

I’m fairly sure you’ve copied this text from somewhere – is it possible to share the source/reference?

Note: The reference to /boot/efi/EFI/qubes/xen.cfg makes me suspect, that the source you have, is about Qubes OS R4.0 … and probably different for Qubes OS 4.2.

Btw: I was wrong about knowing the Dell Latitude 7400 – it’s a Dell Latitude 7490 that I know about … :-/

[Edit: I found the text on Hardware compatibility list (HCL) | Qubes OS – notice that it is about R4.0]


I’m Debian user, so I use “DD” command

In past, I was Downloaded Qubes thru Windows and burn ISO thru BalenaEtcher program and there was no issues. I do mean that Qubes was working well.

I also tried to burn ISO thru BalenaEtcher on this laptop, but Etcher was glitching, don’t remember exactly problem, but have some issue.

I have a lot of identification with problems with Qubes install. I read of others who directly downloaded and installed Qubes without problems, but not me. What I did was to use a bit of a checklist of things to be sure were not the problem. And try different options on some of the others.

If you currently use Debian,you are a good recruit to use Qubes.

A friend once told me his method of installing software.
Evaluate what happened.
“Shoot again”

He had decided that reading all the documentation of “how to” with a piece of software was often a big expenditure of time, energy, thinking processes that would not help him to get it installed. So the first time I try software, I, personally, do the same. Just give a whirl.

The Qubes documentation, actually is pretty good, (even where it refers to 4.1, it is close) and can be used as a checklist.

If those directives were not specifically given to you by a Qubes Developer, for your problem. Then I am not sure, I would much try to implement them until I removed some other possible things. Else I think they go into where you interrupt the install at the very first start of the USB.

Lets go back a bit further than that.
As an example of things to try: I, personally have had some odd things happen. I had an X-230 with an Intel Core I5. I went through the BIOS/EFi and made sure that I had the Virtualization and IMMOU turned on. After some strange issues with installs doing strange things. I decided, while it should not be, it must be that the Virtualization was not working. I put Ubuntu on drive, which told me that some things were working. I turned off the Virtualization. Completely went through the Power Down from Ubuntu. and Powered up the computer. Powered down through Ubuntu again. Powered back up.

Then went into BIOS and turned Virtualization On. Went through all that Time wasting Power Down from an OS, and doing a complete Power up.

I Kept checking to see if Install would run. After the second iteration of this. It worked. I have no explanation, except I seem to the unluckiest person in the world. By the way, that was “4.1 Qubes”

The step before that, Are you certain the computer you are trying to install Qubes, that the hardware for that laptop is functional. Some computer manufacturers, on their support site, have hardware tests. On one computer (Alienware 15 R2, I put Windows 10 back on it, and downloaded all the drivers, looking for something that would not install. As it turned out, a huge waste of time.)( But, I was looking for what worked, and what did not work.

It was how I created the bootable ISO I was using.

A lot of folks here have had problems loading Qubes 4.2. I think the developers did something about “4.2 Final” to help keep this from happening. However, some of us, developed our own recipe to creating a USB to use. and Preparing the Computer drive for Install. As I think of it. Seems kinda like Voodoo.

And, since I do not know why what I did worked, I am not sure I should inflict all that time consuming stuff on someone else.

I want to assure you, Others here have had problems installing Qubes 4.2 which relates to -something with the way they put the ISO on the USB stick. But dd in Debian. that should have been pure platinum. I had a strange Issue with trying to copy an ISO I had downloaded, (in Windows 10) onto to USB, to then put into a Linux computer to write to be a bootable drive. Etcher Refused to work for me. I tried ticking a lot of those boxes. Might be working now with 4.2 Final. The version I got to work. I downloaded “Qubes 4.2 Final,” on the Linux Computer I used to create write the bootable USB I successfully installed from.

Should I go on, with different things to try, or is the original Poster bored with all this?

This may be the overstatement of the year, and we are only in February.

I understand the frustration that some feel about Documentation, any documentation.

I have discovered it more useful to read documentation on the issues I have rather than ignoring it. Yes, It is not always for the current Qubes 4.2

But it’s only ONE OFFICIAL and RELIABLE SOURCE for my PC and this situation. It seems like that problem which my laptop “was” dealing with, still in present, right?! Nothing changed, except EFI now use GRUB.
That page wasn’t refreshed for many laptops with 4.1 QOS and definetely none of 4.2.0 QOS issues, so it still my current problem.

  • just don’t understand where to put that characters on:

Qubes team have a remark, to let Qubes work at my laptop (Dell Latitude 7400): To boot the installer, you need to remove mapbs=1 and noexitboot=1 To get suspend to work, you need to add mem_sleep_default=deep to the kernel= line in /boot/grub/GRUB/qubes/xen.cfg.

@marmarek @unman @apparatus @adrelanos @fepitre @marmarta @michael

What do you mean by that?

so you twice switched it off and on after that you again change Virtualization settings in BIOS “ON” again and again try to install Qubes or boot existing Qubes OS (part/broken) USB and put booting ISO usb as well or how? I’m just trying understand you in correct way.

Do you know if I will SWITCH OFF (tick off from bootloader) my Main OS (debian) in BIOS settings, it will work later on? When I will try to switch it on, tick it on in bios boot setting?! I wanna try that, because maybe this thing which happened to a kernel buzzing out of a way, idk…

About hardware, that’s what I been mention on and on in this post, that on the hardware compatibility list there is my laptop and notes how to fix my issue, but no one doesn’t pay attention to this article :rofl: :rofl: :rofl:

btw yes my laptop (Dell Latitude 7400) must be good for qubes, it’s 64gb of ram, 8 cores, turboboost, look like problem with my laptop it just about graphic card, I have “Mesa Intel® UHD Graphics 620 (WHL GT2)”

Nobody does not pay attention to this article: :sweat_smile:

Qubes team have a remark, to let Qubes work at my laptop (Dell Latitude 7400): To boot the installer, you need to remove mapbs=1 and noexitboot=1 To get suspend to work, you need to add mem_sleep_default=deep to the kernel= line in /boot/grub/GRUB/qubes/xen.cfg.

Yes, please, if you ok with that. I just want to solve this ridiculous (fucking) problem and finally start to using Qubes, cheers
And again thank you very much for your effort, really appreciate that and sorry to others, who I forget to mention that I appreciate your time and helping :slightly_smiling_face:

1 Like

forget to mention, that /boot/grub/GRUB/qubes/xen.cfg not opening in my case, this is the issue of this remark.
Yes, I was using sudo and tried to open it at the nano text editor.

and also I did try /boot/efi/EFI/qubes/xen.cfg.

System respond with Could not find files/directories or doesn’t exist, if pronunciation of that message are important, I could check

As I look through what the commands you were given to enter.
I suspect I am all wrong, about all the rest of this page.
If you feel your USB with Qubes 4.2 is correct.
Then either learn how where to install those commands.
Or turn off the UEFI on you laptop, to use Legacy mode (if possible) and it should install everything but the suspend feature commands. I know that when I start a working Qubes 4.2, there is an option, that goes by pretty quick, to change to UEFI mode.

In some of my computers, if I turn off Secure Boot, then the option to choose Legacy mode pops up

I will leave all the rest of this , just in case.

I am not knowledgeable of all the wiser reasons to use UEFI mode.

Yes, I realize I was not clear when I said, “Put Ubuntu on Drive.”

Uh, I am concerned that I might be creating for you more difficulties by not understanding what your situation with this computer is, what your personal situation is. By that, are you trying to use this same laptop for getting online each day. I have been presuming this Dell Latitude is a spare laptop that while this process is going on, you are either just trying to install Qubes, or the Dell Latitude just sits. I am afraid you are constantly switching between different OS’s to use this Dell latitude for daily stuff.

I will likely repeat some things you well know, I have to think someone else, who is more of a raw beginner to Linux will come along and I did not write thoroughly enough for them to follow. Please forgive me for seeming to talking down.

Ubuntu is one of the distros of Linux (different versions of Linux are generically called distributions, distros for short) Ubuntu is one of the distros that has quite a large number of installs, and therefore, has a huge forum where one can get help. so I use the Live version of Ubuntu as like a fixit, and sometimes install it onto the drive of the computer. If one goes to get the download for Ubuntu, I choose the version which is LTS (Long Term Support) presuming it is more stable. and is the Live version which also has an install option. By Live version, when one boots up the USB, it can start the Live Option, and let the user test out the Operating System while not installing it on the hard drive.

Ubuntu install, by design likely, automatically, handles all those things which you mentioned about graphics card, suspect. Or (I think) hesitates at the correct place to let you enter a choice, such as for the graphics card. The nice thing about Ubuntu, is, it mostly just works.

You can install it with either another Operating System, or by itself. In this case I want you to install it all by itself. Having Ubuntu on the drive allows you to, first, get, what I hope, is an accurate copy of the USB install for Qubes 4.2. and then something else.

If you are able, try to hold onto the USB you put Ubuntu on, I used it later in this install. And it can be handy for other things. I put a piece of masking tape on it for a label.

(BTW, think you are having difficulties. I did a bunch of time consuming, and probably useless things when I was working on my situation. I put Windows 10 on computer, to not only test to see if the hardware seemed to be working, but to install the latest firmware for that particular computer. It is pretty easy to update the Firmware with Windows 10 compared to my doing it with Linux, as with Linux it seemed I needed to install software I had never used, spend hours reading through different versions of documentation. I wanted to install TPM 2.

To verify if the computer might be having with some problem with part of Qubes. I installed Fedora on the drive and ran it for a couple of days. Also surely a waste of time.) My problem was that my USB that I had Qubes 4.2 on was not correct.

So hoping you have several USB sticks that you can use for this project for the duration. Back to my weird recipe, Voodoo like, in that I did things that make no sense, and were probably not relevant to getting to work. Still, do it basically this way, and it is more likely to work than not.

This way.
After you install Ubuntu onto the Dell Latitude. Download the latest Qubes 4.2 onto the Dell.

and now I say, don’t trust links given to you by others, search for it yourself. If you are security minded, you know why.
Don’t try to copy Qubes 4.2 iso from a download made on another computer. Windows sabotages the copy. And I am not clear about other problems if using a Linux OS. Remember, part of this procedure is not about making sense to do it this way. I was just trying to avoid additional points that might be interfering with building USB of Qubes 4.2.

Verify the version of Qubes 4.2 you downloaded. This is documented. so I will not write about it. I don’t recall all the steps to do the crypto verify with Ubuntu. Between the documentation on the Qubes site, and the Ubuntu documentation, I hope it is doable. Time consuming detail.

I broke open a new package of a USB stick. I used a new stick, because I wanted to be sure it did not have any debris on the stick from something else.
I put it into a Windows Computer.
I did a long format version of that USB stick to FAT32, because when the program to put Qubes 4.2 onto the stick it would either be OK with the FAT 32, or it would format the stick the way it wanted. The short install of FAT32 seems to only write the top of the USB stick. Not build the walls of the thing all the way through the drive. This longer version of writing FAT 32 to a USB key takes awhile. If it matters, I used a USB 3 something. not USB 2. Someone here suggested a USB 2. Which might be from a limitation of what model computer they were installing onto. So that advice might be valid for some situations.

Ubuntu has a program, “USB Image Writer” Use that.
In my case, I was concerned that if the laptop I was using to write the USB of Qubes 4.2 might go into a hibernation, or . . . While I was writing “Qubes 4.2” to stick. So I had a movie on the drive, and played that, to keep the computer open. it takes awhile.

I have to write about something I do not know about, These commands you were given to type in by a developer.

I have never done that.
I suspect that one does not alter the install USB to enter those commands.
I will try to search this later today. I have a home repair guy coming, and I have to get to Preparing for him. Will post on that later, unless someone else comes along and documents that.

Anyway. After building the install USB of Qubes.

I added another step, that is probably not necessary.
I used the USB with Live Ubuntu, This is not the version one installs onto the hard drive (SSD or spinning, whatever)
I started Live Ubuntu, then used Gparted to format the drive to NTFS.
I want the Qubes installer to feel it necessary to format the drive its own way.
I do know, that if one has more than one drive in the computer, then Qubes 4.2, install, in some circumstances has problems with that. Sometimes not, I have experienced both cases. Formatting the internal hard drive is probably a waste of time. It turned out to be necessary when working with a Librem 13v2.

I wanted to include documentation on several “Trail Signs” for some of the install points on Qubes. Also later.

If you get to this point though.

Look in the BIOS/EFI. and see if the setting is to UEFI, or Secure Boot is enabled. I have only used Legacy support. One fiddles around in there and turns off Secure Boot, and then the option appears (Well, every BIOS/EFI is different) If you want to use UEFI, then, my recommendation is to put that off for another project another day. Reduce the complexities now.

One thing I want you to do, before trying to enter the commands from Qubes Developers. Boot up the USB stick. It can reach a moment where there is a blinking cursor on the upper left of screen, and seem to be doing nothing. Be patient. After awhile it likely will go to the next step.

Someplace in there, the options offered, will be to test the USB and install.
You should test the USB, even if you are not ready to do the install.

I will be back in a few hours. You probably at your daily job. Anyway, this gives you a couple of hours of things to do.

Others, if I missed on something here. Please correct this post.

I am wrong again.

I bet OP already found all this:

If your BIOS/EFI lets you use Legacy Mode, (and sometime the option does not pop up until you change something else in the BIOS/EFI screen. In my case, turning off Secure Boot was needed.

Only covers part of these commands, Guessing fixing Suspend can wait until you get a first install finished. A bit of success can go a long way towards giving tolerance for fixing the other, points.

I added this in an edit to another post. But to make sure OP sees it.

As I look through what the commands you were given to enter.
I suspect I am all wrong, about all the rest of this page.
If you feel your USB with Qubes 4.2 is correct.
Then either learn how where to install those commands.
Or turn off the UEFI on you laptop, to use Legacy mode (if possible) and it should install everything but the suspend feature commands. I know that when I start a working Qubes 4.2, there is an option, that goes by pretty quick, to change to UEFI mode.

In some of my computers, if I turn off Secure Boot, then the option to choose Legacy mode pops up

I don’t know the details of the issue - but your are trying to apply a fix for the kernel/Xen from Qubes OS 4.0 on a Qubes OS 4.2 – and that’s like trying to use a fix for a diesel engine on a Tesla …

I’ve only done a few really quick searches … and from I found, the mapbs=1 and noexitboot=1 should be to get the installer to show up … and not to get templates added at the “INITIAL SETUP”.


So this is just for go to installer work nothing else?!


Ok, thank you. I will try to install templates/software by RPM packages in already existing Qubes 4.2 by dom0 terminal, should I stick ISO usb as well or just try to invoke/install from a existing system?

I’m so sorry then sometimes I make mess here, I just try a lot and sometimes confused in my own head and commands also messed up, when I am wrong please correct me and sorry me for grammar mistakes, thank you. :slightly_smiling_face:

I will try to invoke/install software and templates by using rmp packages, if I will face difficulties with that, I will try what you recommend or vice versa, first will try your option because it’s faster :wink:

Thanks again for your text, it gives me ideas of other options.

Unfortunately I use this laptop for my daily use and also trying install to this laptop, that’s why I’m moving so slow, coze it’s really time wasting, doing this trials and errors, searching some stuff back and forward (tired noises)

I do always do long formatting of usb, because it is only one way to make usb like brand new.

my secure boot was off. but my main os installed at uefi mode and thanks for this tip maybe I really should switch off uefi mode for Qubes will see itself like separate os (no other)
also if I will tick off from “debian” at bios boot loader I will not loss a system/files on debian later on?

@ChrisA I’m sorry, I forgot to mention you in this post

@catacombs Do you know the answer of this question btw?

That’s how I read the posts I found - you could try and locate an old Qubes OS 4.0 ISO and try to install from it, in order compare how it works with and without the mapbs=1 noexitboot=1 … it wouldn’t give you a working Qubes OS 4.2, but you would know what it effects/resolves - and that’s better than my guess.


I found it easier to install with Legacy Mode. Turn off Secure Boot. on my computer (and BIOS/EFI menus are different) it offers the option with the UEFI to choose another option. I see after Qubes is installed, what flickers past quickly is the option. to use UEFI boot. that is, I think to implement.

I have one computer that will not tolerate using more than one drive while installing Qubes. You mention three drives? Do you mean three partitions?

Oh well. Consider Experiment. Some earlier versions of Qubes 4.2 were less difficult to install. I mean, for me.

These are not registered builds of Qubes, but

Perhaps try Qubes 4.2 RC1.

If no easy success, Qubes 4.12 from the usual Qubes OS website.

Most folks do not have the difficulty you are having. The easiest solution, if one had the money, and I don’t, to test Qubes. Buy a laptop that is known to easily run Qubes, and don’t mess with more than one drive, no dual boot stuff. Several renewed computers from Amazon, (I am in US) with 8 GB RAM, Intel Processor. like X230, slightly better T480s with an IPS screen. RAM could be whatever is Soldered in and stick for 32 GB more, which you have to buy.(8th generation processor, never 7th generation processor. $300.00 or so. T-480 can accommodate 64 GB RAM, hard to afford IPS screen for using.

Do you have a geeky Linux friend. They might solve this install problem very easily


In this laptop I tried all versions of Qubes since 4.1 final and up to 4.2 RC 3-4 and final. All have same issue, it is issue with my hardware, even tho laptop hardware are powerful.
Secure boot are off at my laptop. I think I tried both option (legacy and uefi).

  1. Why no dual boot?
  2. Does they have T480 with 8-9 generation processor? I couldn’t find one not at ebay or amazon. Do you mean Intel Core i7 8 Gen? and how to know that ISP screen, or bassicaly 8 gen of i7 all are with ISP screen (they mostly with touch screen, which is not good)
  3. What’s wrong with 7 Generation processor? btw my laptop are 7th gen processor.

I also thinking about get new laptop which will fit in Qubes requirements, tired to deal with this bs, look like I’m developer for my current laptop, I did a lot of trials and errors.
I still need to try to invoke/install rpm packages or maybe try salt package installation (it is kinda difficult and a lot of time consuming), but if either of this options wouldn’t work it is much easier to get laptop which will work well with Qubes OS.
I think I will choose option get a new one, tired waste my energy & time.

I am not the best person to make suggestions.

Once again, I apologize in giving basic details OP already knows. I want to write for a --technically inexperienced, new to Linux, and or Qubes.

I personally resented that I needed a different laptop to run Linux.
I think the questions you should answer first.
What is your threat level?
My answer was: I live in the United States. I am old. No one wants to mess with me that has power. Then again, if my adversary is the US Government: The NSA. then I am not likely to keep the NSA out of my computer use.

The options for top level threat, if I was say a traveling business person, who needs to keep powerful business companies, out of my contracts, efforts to do business. I would first ask myself about how much money I have to spend.

And whether I find it easy to receive a computer through some kind of delivery service. Postal Service, Parcel shipping company. If I was in an at risk country, then I might desire that no one sees where I see a package I receive comes from.

That is the top of the Line answer for.
Spending money is not a problem, (I have little money myself.)
and I don’t mind receiving a parcel from a company known to provide privacy/security devices. Then one of the Qubes “Certified Hardware” on the list at the bottom of the Qubes OS website. There are several companies, who offer Certified Hardware, and they offer different (for more money) several different methods to ensure your getting the computer without it being tampered with in route to purchaser.

If not spending the highest amount of money, then one looks at a variety of different options.

If I worried about being surveilled, I might buy a more common laptop known to work with Qubes. And, whether you need to added the security that occurs with doing a hardware flash. For those who wonder what that is- One physically opens the target laptop, and using a hardware flashing device, and with another computer to change some IC’s in the target computer. There are several well written how-tos for this. Some say doing this process is easy, just follow the instructions.

What one can obtain by doing the hardware Flash of ROM, are to verify the hardware has not been tampered with and neutralizing the bad part of IME (Intel Management Engine). These things are already accomplished on the computers sold as “Qubes Certified Hardware.” Hardware Flashing ROM on your own might be less expensive. Can be accomplished in private at your own home. Very few laptop models allow one to hardware Flash ROM.

Yes, there BIOS/EFI changes to ROM accomplished by software using just the computer to accomplish it. I do that to install Security improvements for BIOS/EFI.

Hardware flashing changes some part of the ROM to things entitled Core Boot, later to Heads, anti-evil maid. If you want to look that stuff up.

Hardware flashing is not required to run Qubes, it is an added security feature, if one also uses it.

So the questions come up,
“If you want to use the options that come with Hardware Flashing ROM. Either spend money on a Certified Machine, or modify one of the few models which allow for being modified on your own.”

Some of those which can be modified are actually quite common, and not very expensive.

And OP is thinking, too much extra detail, not what I asked about.

Qubes prefers lots of RAM to run Qubes simultaneously. I chose a model that was suggested to me on this forum.
T-480 (Thinkpad 14")
Beware, T480 comes with different components inside.
Intel I5, (as I was told, I7 does not give you a lot more of the speed I will use, but uses up more battery) Intel because Intel seems to mesh more easily with Linux (Well, no one used mesh to describe this. AMD is still great, but there is a lot of experience with Intel. For those who like to point out using AMD, because of the IME problem. Some say AMD also had hardware exploits, which are not known. And the IME can be dealt with, completely mitigated. Given that the probability will ever be used against an individual, it is not nearly the security hazard others seem to make it out to be.

8th generation Intel (I5) because the 8th generation is faster than 7th generation.

I knew that I would upgrade the RAM to the maximum of the T480 to 64GB, although, I now feel 32 GB of RAM might have been good enough. I would prefer a really bright lit screen. Or put it another way. I think there are several different screen models for a T480, resolutions, and IPS versus LED. IPS is brighter. The screen type must match the MOBO model. Meaning one can not physically upgrade to an IPS screen (from what I read). So buy the correct screen from the beginning. I don’t see a T480 with an IPS screen, in the lower price range of renewed machines. I do see an T480s (notice the s on the end) renewed, 8th generation, with an IPS screen. that will only accommodate less RAM. The first stick of RAM is soldered in, leaving upgrade to only one stick.

Brings us back to RAM. Qubes requires 8GB to install. Computers like the x-230, or T-430 only allow 16 GB RAM, they are only a third generation processor. One can hardware flash them to Core Boot, which can be upgraded to Heads (verification of not having been tampered with. They are usable for Qubes, are physically pretty sturdy. But we all want/need more speed.

Buying RAM for a T480, or T480s is not cheap. The Lenovo website says that these computers are limited to 32 GB, two 16 GB sticks. However the processor and MOBO will use 64 GB. Someone told me that when the T480 first came out, there were only 16 GB sticks. A lot of folks have successfully upgraded to 64 GB.

The T480 I bought initially came with 16GB of RAM (two 8 GB sticks) and with an internal and external battery. Seems like the battery life is pretty good. Using Qubes with 64 GB maybe not for an all day online session without mains.

Before I opened mine to upgrade RAM (per ifixit website) I upgraded the BIOS/EFI to accommodate installing the TPM 2 while I was still using Windows. As I have never done such using Linux, and it was an unknown task for me in Linux.

Somehow, when I upgraded my RAM, when I put it all back together, it would not not detect the internal battery. I should go back in and reset connection. Cross fingers for luck. Just a warning.

Yes the T480s has a touch screen, which I would not use. T480s is still almost affordable with an 8th generation processor, and an IPS screen.
After all the updates possible,
T480s would have less RAM, than the T480.
I am guessing less battery life the T480.
but the T480s, purchased renewed, might have an IPS (the brighter screen).

In either case, it was recommended to me not to get the worse resolution screen. At least FHD 1920x1080.

I want to acknowledge. There are a lot of excellent, different manufacturers, models of computers on the HCL. Some of the patches that get them to work are not always difficult to get accomplished. I wanted to mention some of the considerations a newcomer would not immediately consider, if he were buying a laptop to give Qubes a try.

As someone said, the number of cores in the processor is not so important, in that Qubes turns them off, for security reasons. Anytime you find something frustrating with Qubes, ask yourself how that change might be necessary for Security reasons.

Developers have made decisions I never considered, and I now realize were quite wise.

T480, renewed, on Amazon. I am in the US, and see several.

I think this is similar to what I bought. Then spent another $150 for 64 GB RAM.

I don’t know why I can install Windows and Qubes onto one machine, and it easily works. And why I spent days trying all kinds of different things on another laptop to use both drives, and it refused to work.


1 Like