Install QUBES on NVMe ! (P15 gen2 - i7.11850 + 4x 32G RAM + 1x 512G NVMe + 2x 2TB NVMe)

Follow up from previous discussion here: Looking to switch to a ThinkPad from a Librem14 Suggestions welcome - #49 by eric.vanh

I received my brand new P15 gen2 with A2000 GPU; 16G RAM and 512G NVMe
Upgraded to 4x 32G RAM and added 2x 2TB NVMe 980pro set o RAID0 (stripes) in bios
GPT bios UEFI only, no bios option to change to MBR

Win10 pre-intalled on original 512G NVMe will stay here up until I’ll be able to run QUBES (and will have a Win10 standalone qube, then)

1 Like

Hi @UnMan and @Confused,
Thks for your posts, both.
The spec for the P15 are in my previous post.
I don’t blame Qubes, I blame the laptop !
When installing Qubes, it goes through material check up and then stops with a ctrl-D option at the end. I’ve tried to save the log, but LS gives me no otpion (no disk to save it to)
For now, I’m following this lead 4.1 Installation Trouble On ThinkPad P15, Gen. 2 but the normal bios update is giving me trouble, so I’m trying off-line … if it works
Cheers,

I’ve updated the bios, and gave it another try, but to no avail, it crashes during pre-test
First, it holds for about 3min (first pix), then it flows tons of lines until giving me the D. (ctrl-D option on 2nd pix)


Hi @Renehoj,
Thks for your input: -“Have you tried without having the drives in raid0 configuration?”
As I am currently installing Suse, I see that the RAID is indeed not recognized, the installer only sees two 2TB NVMe as “empty”.
But these 2 NVMe in RAID.0 should not prevent install as I’m targeting the small 512GB NVMe standalone (not part of the RAID)
Suse install = 1
Qubes install = 0

EDIT: correction, SUSE install = 0,8 … error UEFI

Hi @renehoj
I’ve removed the BIOS RAID0, and started the install with choice “Boot verbose and debug” (or something like that)
Here is where the install hang for 2min
not sure if the lack of EFI variable comes from my USB stick (Via Rufus) or the current disk (Where Win10 and Suse are installed)

renehoj

I assume you disabled secure boot, and OS optimization.
Is booting with CSM or legacy mode possible with the P15?

Assuming right :slight_smile:
Disabled VMD as well. Actually, pretty much every option in the bios are off.
Tomorrow I will remove RAM and remove NVMe 1 by 1 and keep trying.
I bought this machine only for Qubes, I’m not turning back !

test 1:
Removed the upper (under keyboard) slots 2x 32G RAM (Left the bottom ones)
Removed the upper (under keyboard) NVMe 512G (Left the bottom ones)
Same thing, checkup failed.

As for MBR BIOS, unless I flash the chip with CoreBoot, there is no option but the UEFI :frowning:

renehoj

17h

All new Lenovo laptops are shipped with boot guard, isn’t Coreboot impossible on the P15?

Doing the installation is it possible to use alt+ctrl+f2/3/4 to switch to a single user shell?

If you can get access to a shell, maybe there is a log file that tells you which driver fails to load.

Test 2:
Thks to HBCD (Hiren), I’ve managed to change one of the 2x 2TB NVMe into MBR, the other stayed GPT
Removed all remaining 32G RAM, reinstalled original 16G RAM
Install failed.

Test 3:
Removed both 2TB NVMe,
So left with all original, 16G RAM and 512G NVMe (GPT)
Install failed.


I’m not sure it is about neither the RAM nor the NVMe … It seems there is some about the UEFI … dracut initqueue hook …
EFI partition unknown; exiting, EFI varia not set by bootloader

Test 4:
All 4x 32G RAM; only 1x 2TB NVMe in slot 1 (Slot 0 and Slot 2 empty)
Installed SUSE successfully.

Test 5:
All 4x 32G RAM; only 1x 2TB NVMe in slot 1 (Slot 0 and Slot 2 empty)
Install QUBES failed

You can maybe find a guide that explains how to debug the Fedora installation.

Trying the latest build might also be a good idea, if you haven’t already done this.

My guess would be that you are missing a driver or firmware, and swapping in and out ram and nvme drives is probably not going to change anything.

1 Like

Hey @renehoj !
Thks a lot, as always, for your input.
Are you suggesting that install SUSE versus install Fedora would be different ?
I’ll DL a fresh version of Fedora and give it a try !

Dom0 uses Fedora 32, I assume it’s the same installer that is used for installing Qubes.

2 Likes

Test 6:
All 4x 32G RAM; only 2x 2TB NVMe in slot 1 and 2 (Slot 0 empty)
SUSE Leap 15.4 still booting and running
Booting from LIVE FEDORA 37 (running OK). From the live, select “Install on disk” option:

  • Install FEDORA 37 on same disk (sharing /boot by simply mounting the existing one): Failed.
  • Install FEDORA 37 on the other disk, with its own /boot: Failed.
    => Error msg: Failed to set new EFI boot target; This is most likely a Kernel or Firmware bug.
    => Click Yes to ignore and continue, click No to stop install.
    I clicked Yes, to see what happen, error msg popping up another 2times then on and finished install.
    OS running OK !
    restart, obviously Fed37 is not listed anywhere in the boot menu
    Loading Suse to tweak the Grub2, but not familiar with NVMe (struggling)
    Restarted Fed37 using the live version

Test 7:
Installed DEBIAN 11, no major problem.
WiFi not installed (proprietary)
UEFI overwrite the existings ones
At boot, F12 allow me to choose from Suse, Fedora and Debian, all three running well.
now Wiping entire disk and trying Qubes again
nope, no luck.

New try:

2x 2TB wiped, reinstalled the 512GNVMe to transfer Win10 to 1st 2TB NVMe,
Install Suse with re-using Win10 Boot partition (to get a Grub2 with several entries, to see how /etc/grub.d/40_Custom is set while using NVMes (I’m used to sda1; hda1`…)

1 Like

if you still testing, can you use your windows and download these https://qubes.notset.fr/iso/Qubes-20221210-kernel-latest-x86_64.iso then use rufus with dd option to your flashdrive? dont use ventoy

reset your bios settings.
enable vtx vtd.
disable secureboot.
in the bios storage settings use ahci mode.

I now have 4 Grub2 entry in my F12 (Boot list in bios)
Although they are all sharing the same /boot/efi partition

  • Suse entry shows options: Suse and Win10 (Not Debian, not Fedora)
  • Debian entry shows option Debian and Win10 (Not Suse, not Fedora)
  • Fedora entry shows options: Fedora; Win10 and Debian (Not Suse)
  • Win10 entry that shows no other option than itself

Qubes still doesn’t install. So I think it is a bug in Qubes installer, not the machine.
Now I’m gonna need help to gather the logs and whatnot to open a Bug report …

Hey @51lieal
Thks for your suggestion
The bios is set correctly (90% options set to off) and works fine (Not resetting it)
Virtualization is set ON since day one
Secureboot is disabled since day one
No AHCI option in the bios

What is that “qubes.notset.fr” source ? The WhoIs doesn’t give me any