4.1 Installation Trouble On ThinkPad P15, Gen. 2

According to this, my swanky new ThinkPad P15, Gen.2 ought to (mostly work), but I tried three installs yesterday and couldn’t get it to work:

  1. 2 of the three attempts saw the anaconda installer die when reaching the terminal scripting phase - all GUI vanishes and I’m left with a black screen with a blinking black cursor in the top left. No amount of waiting (I was hoping for the scripts to finish in the background) helped and I head to cold boot.

  2. During the one installation attempt that appeared to work sys-usb swtup failed with an uniformative error and the resulting system warned that USB devices remained attached to dom0.

Does anyone have hints as to how to remedy these issues?

Thank you for your time.

Did you have a look here Installation troubleshooting | Qubes OS?

Which one exactly? Do you have a USB keyboard? Did you have a look here? USB qubes | Qubes OS

Hey ballin, i had no problems installing Qubes 4.1 on this machine. I did return it because I could not connect an external monitor :frowning:

To best of my recollection, I updated the bios (important) and then installed Qubes. I don’t think I had to change any settings in Bios but i can not remember now. I think i recall changing graphics from discreet to integrated. i probably disabled other things i did not need like wwan, camera, bluetooth.

Please keep us posted with your progress. I will try and think in meantime any other changes I made.

I am not the only one who tested this machine another user verified on a P1 Gen 4 (which is pretty much exact same specs) and it worked.

1 Like

I finally managed to a) end up with an apparently more functional install (just tried again) and b) update the bios (only the left side USB port worked!?).
The continued troubles go in other posts …

1 Like