USB in dom0 is not restricted

I checked every topic with this problem and still it’s not solved :confused:
Installed qubes 4.2.1 and when it finish installation it wants to reboot. After this reboot it’s loading and wants my password. It loads until half of a loading bar and gives my this error:
Warning: USB in dom0 is not restricted. Consider rd.qubes.hide_all_usb or usbcore.authorized_default=0.
And after 5-10 sec it passes from warning to configuration cubes, but configuration crashes at the end :confused:
It looks like it’s not a problem with configuration, but idk.
I tried install other iso and version 4.1.2 but that version can’t start installation.

It shouldn’t be related to the crash.

At what point does it crash?
Are you able to boot the Qubes OS when you reboot after this crash?
If not then what happens when you try to boot?

Maybe there is a problem with attaching your PCI devices to sys-net and sys-usb qubes that should start at the end of Initial Setup.

Try to boot in your Qubes OS that crashed after Initial Setup with qubes.skip_autostart option:

This option will prevent sys-net/sys-usb autostart and you’ll be able to access dom0 to fix the issue.

When the configuration ends it shows black screen and this warning again.
When i try to boot qubes is loading and stops at the end of the loading bar and nothing happens. I can only enter the password.

I tried to boot with this qubes.skip_autostart. Now after loading to the end it shows a black screen and this warning.

Just to be sure, by configuration do you mean Initial Setup step?

Try to disable qubes autostart as I’ve suggested in my previous post.

If it won;t work then add these kernel and xen debug options in GRUB menu entry:

It’ll enable verbose log output and maybe you’ll be able to see where is it stuck.

Try to add debug output options then.


I added debug options.

Press Ctrl+Alt+F2 at this screen to try and switch to another TTY.
If you’ll be able to see the login prompt then there is an issue with your GPU.
What’s your hardware?

AMD Ryzen 5 5600
RTX 4060

That should be the problem.
nouveau driver doesn’t support it so you’ll need to install proprietary nvidia driver for it.

Or maybe you can try this:

1 Like

I added splash nomodeset and it works so i think thats it. Now i have to reinstall qubes with this option. Thank you my friend