Stuck in a boot loop after entering Luks PW successfully

Long time Linux user.
Tried, Qubes MANY years ago (3.X), was quite impressed, but it was too taxing on my machine back then. Vowed one day to build a killer machine and would use it as my Daily Driver one day. That day have finally come, …and then a strange issue from a fresh install.

No issue, whole install. Even entered Luks PW the initial time to finish the initialisation. Reboot - still no hangup, warnings, nothing. As installs go, one of my best. Even installing Pop-OS on my son’s computer gave me a harder time.

On boot, the Qubes slash screen with “Disk Password” pops up. The first time entered the PW, did not take notice. Next thing I know it is rebooting. I thought I must have entered it wrong. It is 20+ long, it is easy to have a mis-type.

Second time, take my time and same thing reboot. System completely reboot. I say that because all power goes from the machine, even LEDs,

Third time, I purposely get it wrong to see what happens. Nothing, it clears the field, but it does not reboot, It just allows me to try again. So ok, it only reboot when I get it right.

Fourth time: Press Alt 2 to bring up the console.
Everything looks fine, and can confirm it is looking for the Luks PW.
Enter it. Green [ Ok ] all the way down. I say it like that because it scrolls way too fast to see anything of consequence. In any case, it stills Reboots.

I am getting ready to use a LiveCD and see if I can get some from the logs but not sure if it will do me any good.

Did search the forum, and there where a few post about Luks PWs, but nothng that I could find about causing a boot loop.

Was wondering if there something I could enter in GRUB to help diagnose the problem. Or any suggestions as to how to get down to the bottom of this.

Won’t lie, it break my sole to have to use my old machine at this point. To have a Ferrari sitting right there and having to drive your old Honda Civic. As reliable as it is.

1 Like

Try to disable qubes autostart:

Maybe there is a problem with PCI passthrough in sys-net or sys-usb.

You can also enable additional logging but I’m not sure you’ll be able to see the reboot reason before it reboots:
For Xen command line (multiboot2 line): loglvl=all guest_loglvl=all vga=,keep noreboot=1
For kernel command line (first module2 line): console=hvc0 earlyprintk=xen plymouth.enable=0 panic=0
For kernel command line remove plymouth.ignore-serial-consoles rhgb quiet

You can also try to debug it using USB:


I think it’s possible to also add noreboot=1 to the multiboot2 line – then Xen shouldn’t reboot automatically and thus give time to read the last messages (IIRC) :crossed_fingers:



I’ve also added panic=0 kernel option to my previous comment because by default Qubes OS kernel is configured to reboot after panic in 1 second.


Let me start by saying thanks for the replies.

Besides making a typo initially, that kept giving me a “syntax error”, it went smoothly, but did not yield any results.

I had to record it on my phone and play it back at quarter speed. In some case frame by frame. But other than “Fail to initialise… not supported” on something benign no glaring errors.

I also failed to mention in my original post, that for a brief second the mouse courser is visible. So the graphic is initiated, but then at that point it reboots.

Another point I am wondering, because of course I didn’t, and just did what 95% people do and assume; Are all my component supported?

CPU - Ryzen 9 7950X36
MB - Asrock X670E Pro RS
RAM - Corsair Vengeance DDR5 128g (4x32g)
GPU - (Using Integrated ATM)

Not intended for gaming, pure workstation.

Everything else I don’t think would interfere (IMHO). The only place I can see from that list that might be an issue in the use of the Integrated GPU, if it is not supported. But maybe someone knows of other issues. I optimised the BIOS and I made sure the AMD-V was active

I am going to go scrutinise that video a bit more. But I am out of ideas.

1 Like

Did you try to disable qubes autostart with qubes.skip_autostart kernel option?

Did you enable IOMMU in BIOS?
This seems similar:

1 Like

sorry for not getting back soon. IRL always seems to get in the way.

Did you enable IOMMU in BIOS?
No, I left it to auto, did now, seem to have no change other than slowing the system incredibly. Black screen for a solid minute. Afterwards, enter PW, same result.

Now here is something different:

Did you try to disable qubes autostart with qubes.skip_autostart kernel option?
Initially no, after restarting from failed attempt (see above), I did and… not success but something (Might be / might not be, who knows at this point).

It did not reboot, and this time I got presented a interface. The same as the Initialiser after rebooting from fresh install. White screen with blue margin along the left side and Qubes’ logo, with a title “Initial Setup”. In the center “System” with a blue button Qubes OS with exclamation mark!

I know I was excited too. Some kind of feedback.

Click on the button… Nothing much
Under “Templates Configuration → Installation” Only option is “Whonix not available” and it is grayed out. Default is blank, and can’t interact with.

Under “Main Configuration” everything is grayed out and unchecked except “Automatically accept USB keyboards…” make sense since i am using a USB Keyboard and mouse.

Under “Advances Configuration” the radio button for “Create ‘vm-pool’ LVM thin pool” is selected. I can switch to “Use existing LVM thin pool” but I don’t know if that was ever initialised first time round.

To be clear; the only thing I can interact with is the radio buttons.
otherwise i cam sure i selected Whonix, as well as Fedora, and Debian when setting up my initial templates. In truth I left it pretty stock with the defaults the first time round.

1 Like

Did you try “Test media before installing Qubes OS” GRUB menu option in Qubes OS installer to make sure that your installation media is not corrupted?

You can also try to select “Don’t configure anything” in Initial Setup to see what do you have from the first run of Initial Setup. Maybe there are already templates and qubes set up.

1 Like

Ok, with very few option I selected “Create ‘vm-pool’ LVM thin pool”, since I could not do anything else. Hit “Done” at the top. The exclamation mark was removed so with not much else to do I hit “Finish Installation”

Progress bar starts… to shorten a already long entry. Error pops up pool already exists. I hit continue. And then i am presented with login screen.
I login, and i have a desktop.

Won’t lie, nervous, but ecstatic, but still nervous. Not sure what to do first. Try things out, or diagnose the problem more. Because not convince if I reboot, it won’t be more of the same.

I loath when something “works” after not working, with no clear reason or fix.


Ok, I am happy to say, this response is from the new system.

Sure enough, when reboot, same as initial. Entering LUKS password, causes the system to reboot.

Proceeded to systematically add/remove one at a time.

  • loglvl=all (not that I thought these would change anything TBH)
  • guest_loglvl=all (not that I thought these would change anything TBH)
  • vga=,keep
  • noreboot=1
  • console=hvc0
  • earlyprintk=xen
  • plymouth.enable=0
  • panic=0
  • plymouth.ignore-serial-consoles
  • rhgb
  • quiet
  • qubes.skip_autostart

Only entry that made a difference was “qubes.skip_autostart”, resulting in success.

So thank you all for your time and assistance.

Now, time for my lessons to truly start. I am eager to learn, some may even say enthusiastic. :yum: