USB Headphones don't work

I just wanted to create a qube to attach my usb headphones to and I’ve tried all the methods there are in the forum, but they don’t work for me. Sometimes I got my headphones working but just inside the audio qubes, but still it was buggy and when I restarted the PC it worked only sometimes and I don’t know why.

Is there a new method to do so since the others apparently don’t work (at least for me)?

What Qubes OS version are you using? The latest is 4.2, released a few weeks ago.

Are you trying to use an “audio” qube? If so, what steps did you use to create it?
If not an audio qube, did you only attach your usb headsets to a qube?


I’m using the latest version.
I have tried this method but it didn’t work.
Then I tried this and I could only hear audio inside the audio qube, but still it was buggy and sometimes didn’t work even in there.

Any help, please?

Describe in more details what didn’t work.
And describe in more details how did you setup your sys-audio qube step-by-step. Maybe you’ve made an error somewhere.

Thanks for responding. I have described everything in this issue. I followed step-by-step but I couldn’t continue anyway. Someone have tried to help me, but without success.