Thinkpad T16 (Intel Gen 12) Does not suspend (sleep) in Qubes OS R4.1 at all

I have Thinkpad T16 and it has Intel Gen12 CPU.

Currently it does not suspend (sleep) in Qubes OS R4.1 at all, well, at least it never resumes.

When I start suspend - the laptop kind of goes to suspend:

  • the screen goes black as expected,
  • the fan stops as expected.

But after I press power button to resume - it makes fan work for a second, after that is reboots.
Kubuntu suspends and resumes perfectly well, as expected.

Any help or ideas, guys?

Can you please provide information about this `S0ix`` issue? Maybe links on bugtracker and any other sources of hope that it will work at some point. Thank you for the compare table.

@balko As posted above by airelemental:


In short, Intel doesn’t provide S3 sleep in its 12th and 13th gen P/U series CPU, instead it provides S0ix, aka “modern standby”. And Xen currently doesn’t support S0ix sleep.

But Thinkpad has S3 mode in the BIOS. And other GNU/Linux distributions do suspend properly on such 12-Gen CPUs…

We are going off-topic. Maybe you can create a separate user-support topic.

I have moved it now to its own topic.


According to PSREF ThinkPad ThinkPad T16 Gen 1 (Intel) and PSREF ThinkPad ThinkPad T16 Gen 1 (Intel) , all thinkpad T16 laptops are shipped with P/U family processors. None with H/HX processors.

And according to Intel® Core™ Processors Technical Resources , P and U processors don’t have S3.


1 Like

That is completely false. My framework laptop with 12th gen CPU has support for S3 sleep. It is up to the manufacture to implement it into the bios.

1 Like

I feel surprised. Framework indeed supports S3 sleep with 12th gen P-series CPU. I don’t know how was this achievable.

1 Like

I tried to shutdown all qubes expect dom0 before trying to suspend. So, it’s not about other qubes.

Does it suspend and resume correctly in Qubes OS R4.1?

The topic was created out of my message, so I extended it a bit to make it a better support request:


1 Like


Here’s where I thought I’d have major issues, but no, basically I just had to set the mem sleep default to deep. Edit /etc/default/grub and add mem_sleep_default=deep onto the GRUB_CMDLINE_LINUX, then run:
grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg

Have you tried this method?

1 Like

As far as I know it is a issue that some have managed to solve on the same laptop, I didn’t.

1 Like

Well, for now I know only that those are default kernel options (set out of the box).
I am not sure it is safe nor good to copy all kernel options from GNU/Linux distro to Qubes OS, is it actually recommended?

I tried older kernels for Qubes OS by the way, even 5.15 or something that had awful issues with slow redrawing on 11 and 12-Gen Intel CPUs, but suspend behavior was the same.

P.S. Can custom partitions on the same drive somehow affect suspending or resuming?

So, you do not use suspend at all and what happens when you close the lid?
Are you eager to investigate and solve this issue? I think for many people who but not outdated laptops and plan to try Qubes OS the lack of sleep can be a deal-breaker.

Thanks guys, I will try those things and report back.


1 Like

What it happens is that it will boot back from sleep corectly, but the VMs(everything except dom0) will stop responding.

1 Like