Thinkpad T16 (Intel Gen 12) Does not suspend (sleep) in Qubes OS R4.1 at all

Not recommended. Qubes has specific options.


1 Like

It’s different behavior to mine, be the way. So, the reason of issue can also completely different.

I applied this Suspend/resume troubleshooting | Qubes OS to my laptop. Before it behaved almost like yours(it didn’t auto reboot, I had to force it to shut down)

1 Like

Try Kernel 6.0.7 in dom0 (and S3 sleep mode set in the bios, not windows mode which is s0ix)

If it comes back, but your sys-* vms are frozen, they need a late 5.x kernel not a 6.x.

Other info in my posts from a few months ago. Good luck


I made some tests. My situation:

  • S3 selected in BIOS,
  • Kernel 6.1.12-1 in dom0,
  • All qubes except dom0 shutdown,
  • mem_sleep_default=deep in grub.

I press Suspend (this time I tried using XFCE menu as a common user). The keyboard goes dark. The power LED blinks rapidly for a couple of seconds and then goes blinking slowly with a period of of about 5 seconds.

Then I press any key to wake the laptop up and it starts fans, stops and in a couple of seconds starts again like the computer was completely shutdown, screen is black all the time in this process.
So, it does not resume from suspend, but instead starts like there was a hard-reset.

Any ideas what else should I try?

1 Like

Update for today.
On Thinkpad T16 with the same situation in R4.1 but with dom0 kernel version 6.4.7-1 (latest from normal repo) suspend and resume works once. Details:

  • Touchpad is dead after resume. Mouse is not moved by it. I know that Kubuntu have similar issue with this device since some BIOS update (so it can be Lenovo BIOS bug).
  • But TrackPoint works
  • Clicking left and right buttons above touchpad also works.

The second attempt to suspend after the first resume does NOT work: the computer wakes up and shows xscreensaver password prompt in a few seconds after suspend. And touchpad gets fixes after that (funny).

Third and further attempts to suspend do not work, in the same way as the second.

Any ideas, what to try?

You can view the journal logs of that successful suspend, to see if it’s really entering s3 sleep, and what module caused kerel panic.

It seems there are quite a few reports that xorg-x11-drv-intel is failing when trying to resume, even on fc36 and fc37.

1 Like

Maybe I described the current situation not well enough, but I have no kernel panic.

  1. Suspend works on current kernel (at least without running qubes).
  2. Touch pad gets broken, minor issue, maybe related to Lenovo.
  3. Second suspend and all other attempts are not working, but without panic, just like somethings does not allow to sleep or instantly wakes up the PC. I had similar problem with Macbook Pro, when some sensor was waking the laptop up in GNU/Linux.
1 Like

One more update:

Looks reliable, like 10 times out of 10 is worked.
I think it is because I ran sys-usb for tests and device that was waking laptop instantly from suspend got to sys-usb and managed correctly.

Waking up works by using both power button and keyboard buttons.

Negative moments:

  1. After first suspend touchpad is not responsible. Keyboard and trackpoint with mouse buttons work. Second suspend - FIXES touchpad. Further suspends may be flawless or break touchpad again, but next one will fix it.
  2. Sometimes xscreensaver window is not show, but password is accepted. Mouse cursor is visible and is moving only inside small rectangle, so it proves that xscreensaver is running. Entering correct password fixes the problem.

How did you make it function properly ? I have the same issue and it’s not clear to me how you managed this problem.

What issue exactly, I had many in the topic.

I updated kernel in dom0 of R4.1 to the latest version 6.4.7. Mostly that.
And running sys-usb or other usb qube that will take usb devices and prevent laptop from instantly waking up after suspend.