Sys-net General Connection Issues 4.0.3


Having issues connecting to anything through any Qube. Resolved PCI error for sys-net and sys-firewall. Nothing connects now. Not sure what NetVM or IP should be for what “Name” in Qube Manager.

****What appears helping is sys-net Networking option to be chosen and Network Connections to set Ethernet.
Thank you.

Hi @abc,

your hardware is NUC10i5FNHCA.

I think you get the same issue as me on my first install with my NUC10i7FNK.

Your internal ethernet NIC should be I219-V (8086:0d4f).

Get an USB NIC and read this.

Have to buy one? Built-in Ethernet port not work with Qubes? *Also have restricted resolution. Is link a guide to fixing this too?

    • dom0: detect the USB NIC identifier with ‘qvm-usb’ (ex: sys-usb:3.3)
  • dom0: ‘qvm-usb attach sys-net sys-usb:3.3’ (attach the USB NIC to sys-net)

Am lost on steps #3/4. Doing qvm-usb gets “BACKEND:DEVID DESCRIPTION USED BY”.

Hi @abc,

It’s just a 15-30mn usage, for doing a Qubes OS kernel upgrade, find a friend that can lend an USB Ethernet NIC to you.

It works but only with a more recent kernel. sys-net and dom0 come with a 4.19 kernel, you need to update the kernel-latest (5.8 kernel).

You got a 800x600 resolution, higher resolutions will also be available with kernel-latest (for dom0 which is responsable of the GUI).

You should understand my mailing-list post and read the official Qubes-OS documentation:

Ethernet NIC is only for upgrading kernel? Would be easier if can upgrade kernel without NIC, but sounds you cannot do that, right?

I do, yet, steps are little confusing, #3/4.
*Got progress: need to make sys-usb qube and run it for USB detections. Now, on step #6, I have USB attached to sys-usb but no connection.

Hi @abc,

please, tell me what your skills are with Linux (what are your previous Linux usages? Do you use Linux sometimes/daily?). I need it to give you adapted answers. Because I answered a lot about your questions/problems, and the progress in the solves are long.

Also, you should be more verbose in your questions and answers (give the command you tried, the output results of the commands, the log traces), else this ping/pong discussion will be very long.

Finally, I also need your read the Qubes OS documentation, else you will progress with difficulties. The Qubes OS documentation is very well done.

Me, I will also try to give you more detailed answers. Say me if I should improve something else in my answers.

The Qubes OS default kernel (4.9) is too old to recognize the I219-V (8086:0d4f) internal Ethernet PCI NIC. So you should launch the below command [1] in dom0. BUT this command need network access, so you see it seems to be an unsolvable solution…

[1] qubes-dom0-update kernel-latest

So, one solution is using another ethernet NIC which is recognized by the Qubes OS default kernel, configure it, getting network access and so update the Qubes OS kernel with the [1]. Me I used a USB NIC, as described in my mailing-list post. You are right, it should be possible to get the new kernel and transfer it to dom0, but I haven’t try this, you can try it if you know what you do and how to do it properly. Another solution is the internal wifi card, but I can help you with it, I don’t use wifi on Qubes OS. Another solution is a USB wifi adapter. … It depends the hardware you get and your skills.

You don’t say me if you got a USB NIC and plug it. Please explain me more, give me the command outputs, give me traces. Also you should understand the commands.

For example, the traces (in sys-usb) when I plug my USB ethernet NIC:

[user@sys-usb ~]$ sudo dmesg -Tw
[Mon Nov 16 21:06:16 2020] usb 3-3: new SuperSpeed Gen 1 USB device number 2 using xhci_hcd
[Mon Nov 16 21:06:16 2020] usb 3-3: New USB device found, idVendor=0b95, idProduct=1790, bcdDevice= 1.00
[Mon Nov 16 21:06:16 2020] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[Mon Nov 16 21:06:16 2020] usb 3-3: Product: AX88179
[Mon Nov 16 21:06:16 2020] usb 3-3: Manufacturer: ASIX Elec. Corp.
[Mon Nov 16 21:06:16 2020] usb 3-3: SerialNumber: 000000000009FF
[Mon Nov 16 21:06:17 2020] ax88179_178a 3-3:1.0 eth0: register 'ax88179_178a' at usb-0000:00:06.0-3, ASIX AX88179 USB 3.0 Gigabit Ethernet, 00:23:56:11:22:33
[Mon Nov 16 21:06:17 2020] usbcore: registered new interface driver ax88179_178a
[Mon Nov 16 21:06:17 2020] ax88179_178a 3-3:1.0 ens6f0u3: renamed from eth0
[user@sys-usb ~]$ lsusb
Bus 003 Device 002: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet

And then, this device appears in my Qubes device manager.

Edit: I haven’t seen your Edit:

No you should attach it to sys-net, not sys-usb. Re-read steps #4, #5, #6.

1 Like

Hello @ludovic

First, I thought I got NIC attached, real result is “Device attach failed:”.

My usage with Linux is very small, almost nothing. But am getting better with Qubes.

I have when needed and made progress.


Yes, I see. Current issue is connecting device and inserting details for Ethernet.

I have USB NIC and have Qubes detected it. Now, you say I need to attach (qvm-usb attach sys-net sys-usb:X-X) USB NIC. But, result back is “Device attached failed:”. Should I see device in sys-net Qubes settings and move it over to Selected? Would device say name that Qubes detected?* But I do see USB NIC in Qubes Devices on top right.

You are likely right I think, but, I have issue now as my two USB controllers are Selected and if I quit qube, I lose mouse/keyboard function. Yet, I need to quit qube to remove* USB controllers.
*Do I move USB controllers to sys-net and remove from sys-usb somehow?
**As you type, was able to get USB NIC “+” to sys-net through Qubes Devices by right-click. Is that how?

Ok @abc,

All USB devices are connected to sys-usb, then you can say that an USB device should be dedicated to another VM. Here we want to say to sys-usb to dedicate the USB NIC to sys-net.

You can do this with the qvm-usb attach or with the Qubes Device Manager.


  • sys-usb should detect the USB NIC when you plug it, is it OK ? Unplug the USB NIC, in sys-usb terminal launch the sudo dmesg -Tw command then plug the USB NIC. Do you see similar logs as in my previous post? If you are not sure, post the interesting output.
  • the Qubes Device Manager display the USB NIC. Is it OK? Should be like the step 2 on this screenshot
  • sys-usb display the USB NIC. Is it OK? In sys-usb terminal launch the lsusb command, you should see a line with your USB NIC

Now the attach.

Solution 1: attach by Qubes Device Manager

Like in the step 2 of the screenshot, you should select your USB NIC, and in sub-menu choose sys-net.

You should see a Notification : Attaching to sys-net.
In sys-net terminal launch the lsusb command, you should see a line with your USB NIC. And always in sys-net, ip a should list a new network device (ex: eth0 or another name).


So I did this, yes?

Yes, when removed, Qubes says “removed”. When plugged, Qubes says “available”.

When I do unplug NIC and do

and plug in, nothing appears. “Interesting output” is nothing.

Yes, it is!

USB NIC appears.

In terminal of sys-net? In there and normal terminal, result is “1: lo: <LOOPBACK,UP,LOWER_UP>…”

1: lo is loopback, I expect more with another network interface.

Example, this Is my USB NIC (eth 0):

[user@sys-net ~]$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
   valid_lft forever preferred_lft forever
5: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 00:23:56:11:22:3 brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute eth0
   valid_lft 3593sec preferred_lft 3593sec


Add network details by right-click “No Network Connections”, “Edit Connections…”, and add details in [sys-net] Network Connections? Not sure how or what to put in.

  • Ethernet > Create… > Editing Ethernet connection 1

Do we do this now?

You can try.

Don’t know how exactly. Definitions for Device, Cloned Mac Address, etc. are little confusing.

What is available in the Device combo box?

Nothing? It is blank and down grey-arrow. This under Ethernet.

I was expecting eth0 in this list… :frowning:

So back to the terminals.

When you attach the USB NIC to sys-net, what do you see in the sys-net terminal with `sudo dmesg -Tw’ command ?

With USB NIC attached now and before, “+” to sys-net, doing

brings many audit:, usb 1-1:, etc. Cannot see USB NIC easily or at all.
*Using the Search, I do find USB NIC and eth0!
**But eth0 is different from yours. “2-1:1-0 eth0: vX.XX.X”

usb 1-1: are the interesting lines.

1-1 is the identifier on the USB Bus. It’s normal that it’s not the same for you and me.

What is the Search?

Do you see eth0 in the output of ip a ? Do you see an IP in front of it?

In sys-net terminal, there is File, Edit, View, Search, Terminal, Help.

No eth0 doing “ip a”.

The Search item in the menu, search in all the text already displayed in your terminal. So a previous command output displayed the word you searched.

@abc, it’s too difficult to help you by remote, we switched to a chat mode… I stop here :frowning: . Could you find a Linux skilled people near you? Then you show this discussion to the found person. I think it will work much better like this.

Or if another forum user want to try…