Running Qubes on Lenovo X1 Carbon Gen 9th

First: Great Project! Im using Qubes OS now 4 years as main OS (on T440s) and everything worked almost perfect! Finally I can contribute something. HCL follows shortly.

After one week of trying to get Qubes OS running on my shiny new Lenovo Thinkpad X1 Carbon Gen 9th (X1C9) I still face some problems and issues.

I had no luck getting installed the latest stable R4.0.4. It always ended with a black screen (with or without a moveable mouse pointer or blinking cursor) just before the installer gui should come up. (I think) I tried all solutions around the web.

So i tried R4.1-beta. Installer showed up immediately, but artifacts at first boot at the Disk Passwort too: Black little flickering stripes/boxes at the mouse pointer and typed signs, as it would take “long time” to render the change, but only near/over text fields and in qubes when opening/closing (new) windows or changing pointer-symbol. Disabling compositor (GUI troubleshooting | Qubes OS) has no effect. But thats just a minor problem until now, but I havent used the X1 productively yet. Kernel 5.12 “seems” to have a little more artifacts than 5.10. I (first) tried R4.1-alpha and with i915.modeset=0 i could get over the black screen too and install successfully. I mention this because with the default kernel (5.4.* ?) i had no grafics artifacts, only after trying newer Kernels.

A big problem (to me) is that suspend doesnt work! Closing the lid or by clicking suspend turns off the X1 with blinking power led, but will not wake up anymore. All I get is a black screen. Strangely the fan seems to start, in some cases (kernel 5.12) spin up to max speed and back down, keyboad-backlight blinks ones and the power led lights up, but still the system is frozen with a black screen. Only solution: (Long) press on power button. mem_sleep_default=deep doesnt help, removing TB4-devices from sys-usb neither. BIOS is set to Linux S3, TPM on/off doesnt change anything, nor does SecureBoot on/off.

Sound doesnt work at all. Probably this issue? https://bugzilla.kernel.org/show_bug.cgi?id=213159

WiFi works with VM kernel 5.10.* and above.

Ethernet works thru Dock, but … using the Lenovo TB3 Dock (Gen 2) (which provides ethernet) isnt usable in an “convenient” way as sys-usb wont start without the dock attached, because the corresponding device (assigned to sys-usb) gets “unknown” then. I cant (dont want) always remove/add that device manually. Isnt there a feature for only temporary available devices? I couldnt find anything about that. The dock also wont be recognized when attached while running, only if attached before boot. Its should be USB plug and play, right?

It seems that the X1 gets a little warmer then I would expect form what I have worked/done yet. Are there some power management settings I can try to get it cooler?

Newest BIOS (1.42) is installed. Did i forgot something?

I “think” that I have tried all solutions to above problems I could find, but please, dont hesitate if you have an idea what could solve it.

4 Likes

Did you try to disable hyperthreading to fix suspend issue?

Thanks for you answer!

Now I did, but still doesnt wake up :frowning:
I have to check what I have changed (trying to solve other issues) because now it makes a full reboot instead of waking up. I didnt realised that the mentioned fan-spin-up/down and keyboard-backlight were “bios-reboot-behaviour”, but apparently crashing before done (Lenovo Logo didnt showed up).

I did’t touch gen9, but for gen7 as I remember disabling Thunderbolt could helps.

Tried that already, but with the changed behaviour (reboot vs black screen only) Ill try it again…

Check out thinkfan…

sudo qubes-dom0-update thinkfan

… it allows you to define your own fan pattern, basically a trade off
between temperature and noise. Most (including me) use it to throttle
the fan so that in normal / idle use the fan doesn’t run at all and only
turns on when necessary / under load to prevent overheating. This is to
make the ThinkPad more silent in day to day use, but has to be done with
care and understanding of the components and their heat limits.

On the other hand you can use the same tool to define a much more
aggressive fan pattern (I’ve done this too as an experiment) to keep
your ThinkPad as cool as possible. You could go even so far as to run
your fan at full speed all the time. Clearly this will result in fan
noise, so it’s unlikely that you really want this.

Here is my “silent” config:

(0, 0, 66)
(1, 62, 70)
(2, 66, 74)
(3, 70, 78)
(4, 74, 82)
(5, 78, 86)
(6, 82, 90)
(7, 86, 94)
(127, 90, 32767)

… and this is my “cool” config:

(0, 0, 36)
(1, 32, 40)
(2, 36, 44)
(3, 40, 48)
(4, 44, 52)
(5, 48, 56)
(6, 52, 60)
(7, 56, 64)
(127, 60, 32767)

The first number in each row is the controlled fan speed 0 (off) to 7
(max) with the 127 meaning “no control, as fast as the fan can do”. The
second number is the temperature in Celsius at which the fan speed
should step down to the previous line, while the last number is the
temperature in Celsius at which the fan speed should step up to the
following line.

My CPU (i7-3840) has a t_junction of 105 degrees Celsius, which means at
that temperature it will fail and turn off to prevent damage. A good
rule of thumb is that you never want your temperature to go over
t_junction - 15 … so in my case 90 degrees and your idle temperature
t_junction - 45 … so about 65 degrees. Now many will point out that
this is dangerous as your hard drive might already fail at 55 degrees
and if your CPU is always around 65 then the hard drive might reach 55
degrees after a while. I don’t care, because I use an SSD and those are
“comfortable” up to 70 degrees or more. I write this mostly for others
reading this after the fact, fully aware that you want to actually cool
down.

This is fairly straight forward, but if you want to try and still have
questions after reading the documentation don’t hesitate to ask.

1 Like

Hi BigQ,

I would ask that posts in this category especially if they have “HCL” in
the title are actual HCL reports including YML file.

If it’s still an ongoing affair like this thread, it is better posted in
the support category. Once the install was successful a HCL report can
then be posted here and the support thread linked.

Thank you for understanding!

Thank you very much for your detailed answer! Back to the roots, its more then 10 years a had to fiddle around with fan speed, temps, voltage, clocks, etc. when overclocking the sh** out of my PCs :smile: I were not aware how good my T440s was/is …

Hi Sven!
Oh, my apologies! Seeing other threads, I thought that is the way it should be done, sorry! For me it would be all fine if this gets moved (to support) and Ill make a HCL later separately, hopefully with solutions to at least some of those issues.

Thanks to @Tie-fighter s hint (HCL - Lenovo Thinkpad X13 Yoga Gen2 (20W80013GE) - #5 by Tie-fighter) sound output works, internal mic doesnt. External mic has to be tested but is recognised when plugged in and vu-meter in audio mixer shows input.

I had installed alsa-sof-firmware from current-testing earlier, but did not check if it works without too.

Im puzzled because that hasnt been mentioned once in this forum, but according to this issue (Support for Intel Tiger Lake Processors · Issue #6411 · QubesOS/qubes-issues · GitHub) suspend is currently and for the near future just not possible with Tiger Lake CPUs because of S0ix and no support by Xen?

It’s been mentioned a couple of times.

Suspend is really not a good idea from a security perspective: if your
device gets stolen while suspended it is possible for a skilled attacker
to extract the decryption keys from memory.

1 Like

Moved to #user-support

Are you referring to suspend problems in general or this special case/issue with Tiger Lake + Xen and not supported S0ix? In latter case, would you please link one or two examples? Even by search I didnt find anything. Please dont get me wrong, I just want to read more about it and eventually participate the discussion.
Plus, knowing that, I can stop searching for solutions and fiddle around with different approaches.

Im fully aware of this “security problem”, and when applicable I shutdown, but in my daily work, this aspect is negligible and the advantages (saving battery, open lid and continue work immediately) outbalance them by far. Beside that, I cant put a running laptop in my bag, it would overheat.

1 Like

@BigQ asked:

would you please link one or two examples?

@turkja mentioned it in a discussion about
restarting

and again when talking about the
4.1.0-beta1

@fiftyfourthparallel reported that his i7-1065G7 “Ice Lake” doesn’t
wake from
suspend.

Ok, the first I have maybe overseen (unrelated topic) but hey, the second was posted after I have searched and the third is unrelated (Ice Lake does support S3?!) :wink:
I thought you mean it was discussed or mentioned at affected devices.

Anyway, it’s a fact and I have to come to terms with it.

3 posts were split to a new topic: Sound Does Not Work on Lenovo X1 Carbon Gen 9th

Hi, you referenced wifi working but I cannot get sys-net to pickup, I keep getting rkill enabled. Did you do something special?

Edit:
kernel is 5.10.61-1
manager: rfkill: WiFi enabled by radio killswitch; enabled by state file
manager: rfkill: WWAN enabled by radio killswitch; enabled by state file

Tried blacklisting ideapad_laptop but no luck.

Enabling and specifically installing firmware-iwlwifi from back-ports worked as described here: AX200/201 iwlwifi.