Sound Does Not Work on Lenovo X1 Carbon Gen 9th

Continuing the discussion from Running Qubes on Lenovo X1 Carbon Gen 9th:

Hey, would you mind telling me the exact steps you took to get sound output to work on the X1C9? I have the same hardware and am having some trouble here. Thank you

Disregard. I got it.

try this

sudo qubes-dom0-update alsa-sof-firmware

and reboot then.

What ended up solving it @davemyfree? (this helps other users in the same situation as you) :slight_smile:

sudo echo “options snd-intel-dspcfg dsp_driver=1” > /etc/modprobe.d/alsa.conf
2 Likes

Thats my solution, right!

Sorry, was busy this days. I “referred” the solution but should had clearer. Next time I will, promised;-)

1 Like

Perfect. Thank you for sharing. Marked that as the solution

Do you have working microphone with your solution?.. With sof-firmware you could have it.

All I need is one mic.

Do I need to “reverse” the command I called earlier in order to have both working? If so, how might I go about it?

I guess you could try install package with sof-firmware and remove string with option from

/etc/modprobe.d/alsa.conf

If sof-firmware package is enough you will see internal microphone device in pavucontrol after reboot.
I don’t have X1C9 to test it, but it works with previous X1C7-8