Requirements for software e.g. firefox in fedora minimal template

Hi,
just out of curiosity I tried to get firefox running in a fedora minimal qube. It will install successfully in the template but will not start in the qube.
I have assumed that upon installing programs using “sudo dnf install …” all required dependencies are also installed. This seems not to be the case. How can I find out what is missing systematically without using trial and error?

Another question, which might be related but might not be. I see the standard desktop environment of qubes is xfce. Why do templates like fedora-xx (gnome) and fedora-xx-xfce (xfce) come with their own desktop environment? Isn’t it dead weight? What sense is there to have a certain desktop environment within a template? All I have on my desktop is programs which fill their window completely and these windows live in the qubes desktop environment which I assume is xfce? It is not that I am opening little independent desktops when using different qubes (and I am glad it is the way it is). Am I thinking something fundamentally wrong?

Thanks for Your help
M.

Open a terminal in a vm based on that template (not in the template itself!) and run firefox. Then see what the messages are.

I’d say it’s probably better to split different questions into different topics.

3 Likes

done so: made a qube based on the fedora minimal template and installed firefox (and nothing else) in this template without problems, made a qube from the template and added the application firefox in the settings of my qube (using the qube manager), started a terminal in the qube, typed “firefox” and it says "bash: firefox: command not found"

doing the same in the terminal of the minimal template firefox started just fine …

After starting it in template, I’d delete this template and install new one. You were told not to do that with exclamation mark.

Did you just repeat twice that you create one qube based on a template in which template you started firefox and it worked in that template?

1 Like

Run echo $PATH and verify that /usr/bin is included.

Also, try launching it with the absolute path: /usr/bin/firefox

1 Like

Sorry for that. Was a bit overnighted.
I plan to delete the template once I know my way around a little better. This was just for testing for now.

Sorry for that also. Was a bit overnighted. Will edit it.

1 Like

Maybe asking an obvious question, but did you shut down the template after installing firefox and before launching the qube?

1 Like

…shame on me…
Thanks…
it is running now but without internet access although the qube has the default Net qube “sys-firewall”.
Any suggestions, what might be missing?

You have to install qubes-core-agent-networking package. You might also want to consider to install

qubes-split-browser-disp mozilla-ublock-origin mozilla-https-everywhere mozilla-noscript

as well

1 Like

Network in the minimal template (firefox) is working now thanks to enmus hint. Also helpful resources are these in case anybody else wants to switch to minimal:

I wanted to switch to minimal templates for two reasons: to see if it is possible and to improve my video (browser & dvd) playback, which is a bit jerky especially in horizontal moving scenes…

two things I have not made working so far:

  1. I am not able to install rpmfusion-free-release-tainted so I am unable to install vlc and libdvdcss. Xterm says Curl error (37): couldnt read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-36
  2. Video playback in firefox is even more jerky and slow as before (unusuable), sometimes videos do not load at all and youtube recommends to restart the machine, something I have not seen before. When switching back to normal fedora (not minimal) it works as good as before.

Any ideas?

1 Like

In order to get better visibility, please open separate topics for each issue.

will do