Removable Media sys-USB GUI icons view

So I thought adding the “Open File Manager” would allow an auto-popup open GUI window to open with the USB media showing its file structure; but that didn’t happen

As seen in the notifications, this qube template seems to be “recognizing the plugable USB media” just fine since I did enable sys-USB upon cloning the “Vault” template.

What are the key terms / phrases used for searching this issue as I am unable to find what I am looking for given that I lack in QubesOS and various Linux terminology specific encyclopedic dictionary words as a newbie. So I don’t even know how to search for this issue.

I will describe what I am searching for:

I want to plug in my external hard drive into this sys-USB enabled qube template and upon plugging it in I want a little window to appear showing the internal contents of what is stored on this USB removable media. I do not want to be able to actually open files like LibreOffice or PDFs, I just want to see the file icons as this will be a bridge to move various file types created on Qubes’ qubes off onto an external storage space so to leave storage free for all the qube iso templates I have planned for the future. Again, I don’t need the file contents read themselves but I do need to see their little icons in a file structure directory GUI window; either when plugged in or at least tell me what “app” I have to included so to have it appear within the drop down menu to click to gain the same result of a GUI based visual window with little folder and file icons showing inside it from within this USB external hard drive.

This is as best as I can describe it

I don’t know what this would be termed nor what the phrase would be so I am unable to query it within the Forum search, let alone search the web for a solution as my search term doesn’t appear to be accurate enough to be specific

So please help, either by telling me the words I need to use and/or by just telling me the answer of how to accomplish this

Thank you

These are all the little apps I finally figured out how to load into my newly cloned VM

• Bulk Rename
• Clipboard Manager
• Clipboard Manager Settings
• File Manager
• Open File Manager
• qvm-open-in-dvm
• Removable Drives and Media
• Settings Manager
• Task Manager
• Thunar File Manager
• Xfce Terminal

I am unsure if I missed adding something I needed to accomplish what I am after as I am not even sure what the difference is between some of these like “File Manager” and “Open File Manager” but I added everything that looked like it might help make my USB as well as make it appear window of the File directory with the folder and file icons.

But then nothing still worked so I eventually found this source:

That I followed to input the various commands in hopes to solve the problem of not knowing how to mount and view an external drive in Qubes as I am a fresh newbie

It mounts and reads that it exists just fine, see:

As I ran,


Just fine

… and eventually saw I needed to mount it to the specific qube running, okay so I did that here:

qvm-usb attach work sys-usb:4-5

I assumed doing all this worked so I went back to the Q drop down into the qfile-bk VM I created to click on all the “apps” to see where the external drive GUI view of its drive and directory could be seen in icon form but kept only seeing the folders and files for the VM system without an external drive mount showing at all

So then I proceeded punching in whatever further down that document but then got errors as if the drive couldn’t be found doing the proxy command thing, see:

So I have no idea, all other modern Linux OS I have used just work without CLI such as Ubuntu, Tails, and PureOS; I am having trouble understanding why if I added it to the VM and told the media Manger to mount it why it just doesn’t work now? I am not complaining about the security, I am complaining that even when I do stuff in the GUI to alter the secure settings so to open the USB port why it just doesn’t suffice and I still have to mount and unmount from CLI. But really I just want this to fully work as in I need to SEE with my eyeballs icons of a drive itself folder and directory. Please tell me this is possible without needing to ALWAYS use CLI (command line). Like why hasn’t this worked as implied, here:

(image is of my qfile-bk qube VM in blue of the “Removable Drives and Media” app
where I checked the following boxes:
• Mount removable drives when hot-plugged
• Mount removable media when inserted
• Browse removable media when inserted)

I have even tried running the same CLI command in the VM terminal to no avail

qfile-bk qube VM Terminal returned,
“bash: qvm-usb: command not found”

I have no idea what I just did but I finally found in the GUI the “Qubes Devices” top bar icon.

As seen here,

I proceeded to randomly unmount and remount and that is where I lost track.
But apparently when mounting it under its name to my “qfile-bk” VM then finally
when I click the
“Open File Manager”/“File Manager”
I see the Transcend External Hard Drive as a secondary storage with folder and file icons in the VM little blue window how I made it

now if only I can remember what I did exactly to get here …

You need to:

  1. start your sys-usb qube

  2. plug in your usb drive into any usb port (assuming you have one usb controller)

  3. click on the “Qubes Devices” gui applet in the system tray

  4. attach your usb drive to the qube where you want to access files (you might want to attach whole usb devices, and not just block devices, as the latter won’t be automatically detected by your file manager)

  5. unmount your usb drive in the file manager when you’re done

1 Like

I didn’t figure that out until around 3am lol

Okay I was unaware of this, thanks

Aw that means even though I unmounted it from the VM it wasn’t unmounted, ah I been ruining my drive all day then. Well now I know how to properly disconnect it, thank you for saving the life of my drive