Qubuntu issues i really appreciate some help.. When you have time. :)

Hello. I tried this: https://www.reddit.com/r/Qubes/comments/a242q2/step_by_step_guide_on_how_to_install_these_pre/

And i have the focal template installed, but how do i even add a terminal and what’s the next steps? If i add focal in personal appVM and click start the appvm message shows it has started but nothing more. Now what? I remember i had a message with a timeout also the first time i tried to start it.
(domain focal failed to start qrexec-damon startup failed: connection to the vm failed)
How do i even add terminal and make an appVM and so on? A step by step guide would be great.
It says domain is starting. and domain has started, so it might work, but what’s the next steps? I need a terminal as a start. :slight_smile: And a browser… How do i even add a terminal when nothing is showing in Qubes settings?

P.s: You guys rock with knowing computer software and code as you do. It’s impressive. Qubes is way beyond my knowledge level, but i still love the OS, and the design of it! Compartmentalization is clever, and i have not used any other OS like it before. So thanks to everyone sharing it, and making it even better and this support forum, so people like me having a hard time understanding software, code and stuff can still use it and understand some. This OS is mostly for powerusers i bet who knows how to customize the OS, and i’m none of those.

Anyhow… I need ubuntu because some software ONLY RUNS ON UBUNTU, and will not even start if it’s linux mint or kubuntu. That’s why i’m trying to do this i would not use ubuntu otherwise. Thanks!

Welcome @bn2qteewnl! I’ve installed ubuntu focal for android stuff with this method:

You should already have several AppVMs pre-installed by Qubes, such as work and personal. If you don’t, click the Qubes menu (top left of the screen in dom0) and click “Qubes Tools” (IIRC) and then “Create Qubes VM”. The defaults in that menu should be fine (fedora Template, sys-firewall for network).

Whichever VM you’d like to download your rpm file in, start that VM by clicking the Qubes menu again, selecting the VM, and then clicking the browser. The browser should launch in that AppVM. Navigate to whichever ubuntu download page and download your file. I’d recommend using an ubuntu template that’s signed by a Qubes dev, and then verify the integrity of the download with a signed hash file, if available.

Note the absolute path, in your download VM, of your focal.rpm download (i.e. /home/user/Downloads/focal.rpm.

Then open a terminal in dom0 by right clicking the desktop and clicking “Open terminal here” or using the Qubes menu again. In the terminal in dom0, run qvm-run -p <download_vm_name> 'cat /home/user/Downloads/focal.rpm' > ~/focal.rpm. This copies focal.rpm to dom0 from the VM you downloaded it in.

Then, again in a terminal in dom0, run sudo dnf install ~/focal.rpm or perhaps sudo rum install ~/focal.rpm.

Thanks, it’s installed. What are the next steps? How do i add terminal and a browser and so on?

1 Like

Please help me getting ubuntu up and running in Qubes… Otherwise i might use it as an single OS, but i don’t really want that… Thanks!

Once your Ubuntu template is installed, you should be able to select it as the TemplateVM when creating new ubuntu-based AppVMs (persistent home directory, root filesystem based on read-only Template), or StandaloneVMs (separate, complete, VM with persistent, writable root filesystem and home directory). Depending on what software you will be running on Ubuntu, you may prefer to use a StandaloneVM instead of an AppVM.

To create an ubuntu-based qube, open the “Create qube” menu, and select “focal” from the template drop-down menu, and click create. Since ubuntu comes pre-installed with terminal emulators (i.e. xterm, gnome-terminal), these should already appear in the Qubes menu, which gives shortcuts to applications in each VM.

Open the Qubes menu and select your focal AppVM (or Standalone). There should be a pop-out menu with “Terminal” or “xterm” in the list, as well as a browser (probably Firefox). Click on any of these items to launch that application in your VM.

If you need to install additional terminals or browsers, or other applications, there should be clear info in the docs.

Hope this helps

Thanks… Yes it does help. But i still just have the “start qubes” option. If i try to start the template before creating the appvm i get this, it’s some of the log:

[.[0;32m OK .[0m] Started .[0;1;39mLogin Service.[0m.
[.[0;32m OK .[0m] Finished .[0;1;39mRotate log files.[0m.
[.[0;32m OK .[0m] Started .[0;1;39mNetwork Name Resolution.[0m.
[.[0;32m OK .[0m] Reached target .[0;1;39mNetwork.[0m.
[.[0;32m OK .[0m] Reached target .[0;1;39mHost and Network Name Lookups.[0m.
Starting .[0;1;39mPermit User Sessions.[0m…
[.[0;32m OK .[0m] Finished .[0;1;39mPermit User Sessions.[0m.
Starting .[0;1;39mQubes GUI Agent.[0m…
Starting .[0;1;39mQubes remote exec agent.[0m…
[.[0;32m OK .[0m] Started .[0;1;39mSerial Getty on hvc0.[0m.
Starting .[0;1;39mSet console scheme.[0m…
[.[0;32m OK .[0m] Finished .[0;1;39mSet console scheme.[0m.
[.[0;32m OK .[0m] Created slice .[0;1;39msystem-getty.slice.[0m.
[.[0;32m OK .[0m] Started .[0;1;39mGetty on tty1.[0m.
[.[0;32m OK .[0m] Reached target .[0;1;39mLogin Prompts.[0m.
[.[0;1;31mFAILED.[0m] Failed to start .[0;1;39mQubes remote exec agent.[0m.
See ‘systemctl status qubes-qrexec-agent.service’ for details.
[.[0;32m OK .[0m] Started .[0;1;39mUpdate time from ClockVM.[0m.

Ubuntu 20.04.2 LTS focal hvc0

[press ENTER to login]

And this:
Incompatible agent protocol version (remote 3, local 2)
Unable to init server: Could not connect: Connection refused

(zenity:5034): Gtk-WARNING **: cannot open display:
Connection to the VM failed

What do i do? I used a created one as in the first link… The popups shows that the vm, has started, but nothings shows up. How can i troubleshoot this? I used this one:


Is it the wrong template? My fedora template is outdated but that should not matter right…
I don’t see what i did wrong, i installed the rpm in dom0… A step-by-step guide would be nice if i “failed” with this install… How to install ubuntu in qubes… maybe i should have used the 4.0 version of the template… Index of /Templates_4.0

I’m assuming you are running Qubes4.1 - if so, that’s the right
template - the error message makes me think you are not.
If you are using Qubes4.0 grab the template from
Get a copy of my signing-key, and install as per

Once the template is installed, you can use it just like any other
template - install packages as you will, change the template for existing
qubes to use focal, or create new qubes.

It looks as if you’ve done the right thing generally - I’m not sure this
warrants any sort of detailed guide tbh.
If you need more help, ask.

1 Like

Thanks! I just get:
]# sudo dnf install ubuntu41.rpm -y
Qubes OS Repository for Dom0 15 MB/s | 80 kB 00:00
Dependencies resolved.

Package Arch Version Repository Size

qubes-template-focal noarch 4.0.6-202107271430 @commandline 864 M

Transaction Summary

Install 1 Package

Total size: 864 M
Installed size: 3.5 G
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Installing : qubes-template-focal-4.0.6-202107271430.noarch 1/1
focal: Importing data
Verifying : qubes-template-focal-4.0.6-202107271430.noarch 1/1

qubes-template-focal.noarch 4.0.6-202107271430


And the error i posted above the timeout, can’t connect to the VM. Do i re-install qubes and try again? The error is something like this and pops up: domain focal failed to start qrexec-damon startup failed: connection to the vm failed. What is the issue? Might not be the wrong template, or is that usually the cause of the message?
P.s: I hope i have not messed up my qubes installation somehow…

I might just install ubuntu… Hmm. I don’t even want that. But i did not get usb to work in vmware on another machine even, and i usually have no issues with that…

You haven’t confirmed that you are using 4.1

How do i check that in the terminal? In dom0 0r other? I can’t remember right now… Thanks

It should be Qubes 4.1

How much memory have you allocated to the HVM?

How do i find that out, and how much should it be set to? I have 16gb ram total on the laptop.

Can someone give me a quicker answer on how to install qubuntu? Do i need a new install with qubes and try it again? Whats up with the timeout error i got, and why? How do i fix it? I might uninstall qubes and install ubuntu temporarily… It seems like a bad solution, but a quick fix… And a solution when i need ubuntu temporarily

HVM was a typo - in any case, if you havent changed the defaults, all
should be fine.

You should be able to switch one of your existing qubes to use the focal
template, (as you say you have done), and start programs from the menu
or the command line.
Alternatively, create a new qube from the Qube Manager using the focal

No one else has reported issues with that template.
I don’t think I can help you. If you have downloaded the template from
Index of /Templates_4.1, and installed it on 4.1, it just

If you want more help, try to create a new qube using the template.
Then in dom0, run qvm-run NEW_QUBE_NAME uxterm
If NEW_QUBE starts run qvm-console-dispvm NEW_QUBE_NAME - which will
open a console window.

1 Like

Thanks! I will try some more… I really appreciate the info. I’m sure it just works. I need to do this right, gonna try again. :slight_smile:

Thanks again… i re-installed qubes and saw the latest stable version of qubes is 4.0, and not 4.1. And i installed the right version and it just works! So yes, you did give the right answers. I had issues with the timeout in my earlier install a few times apart from the focal, but now everything is fine and a fresh install… i need to update fedora 32, though… some other day. But the personal appvm is working and the terminal is showing. A fresh install was a good choice for me. thanks!

1 Like

Good news.

1 Like

I installed ubuntu in qubes 4.1 just now. I get this:
Updating focal

Error on updating focal: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=focal’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.
Failed to return clean data
Traceback (most recent call last):
File “/var/tmp/.root_dd8a91_salt/salt-call”, line 15, in
File “/var/tmp/.root_dd8a91_salt/py3/salt/scripts.py”, line 405, in salt_call
import salt.cli.call
File “/var/tmp/.root_dd8a91_salt/py3/salt/cli/call.py”, line 5, in
import salt.utils.parsers
File “/var/tmp/.root_dd8a91_salt/py3/salt/utils/parsers.py”, line 27, in
import salt.config as config
File “/var/tmp/.root_dd8a91_salt/py3/salt/config/init.py”, line 101, in
_DFLT_IPC_WBUFFER = _gather_buffer_space() * .5
File “/var/tmp/.root_dd8a91_salt/py3/salt/config/init.py”, line 90, in _gather_buffer_space
import salt.grains.core
File “/var/tmp/.root_dd8a91_salt/py3/salt/grains/core.py”, line 32, in
from platform import _supported_dists
ImportError: cannot import name ‘_supported_dists’ from ‘platform’ (/usr/lib/python3.8/platform.py)

What do i do? Cant update ubuntu focal… Thanks