Qubes doesn’t boot after creating sys-usb

I have installed Qubes 4.1.0 on my external hdd, connected to laptop. During installation option ‘create sys-usb’ was disabled. Then I decided to create sys-usb with command

sudo qubesctl state.sls qvm.sys-usb

But in the process of rebooting system crashes with such text:

I tried to follow [qubes-users] Creating a sys-usb for my desktop?
But I can’t get access to /boot/efi/EFI/qubes/xen.cfg and have no ideas how can I change kernel options.

Thanks for every attempt to help

Edit your boot entry in GRUB menu during boot and remove rd.qubes.hide_all_usb string in the line starting with module /vmlinuz:

I tried to do this, but boot process took too much time. After I removed also ‘quiet’ option, boot process also took too much time. Here the photo of text on the display:

These lines are uninformative. Get a photo of the messages when only 1 or 2 of these lines appear.

Without ‘rd.qubes.hide_all_usb’

And nothing new on the screen for more than 10 minutes

I edited kernel options. Now system can boot, but I can’t start any qube - after attempt taskbar and qube manager disappear. I tried to start some qube from terminal qvm-start and got such message: ‘VM directory does not exist: /var/lib/qubes/appvms/‘

Once you boot in dom0 then you need to remove the USB controller from sys-usb Devices tab in it’s Qube Settings and add this controller to dom0. You can read how to find the right USB controller and add it to dom0 here:
USB qubes | Qubes OS
Follow the steps in this link but don’t add usbcore.authorized_default=0 option in GRUB_CMDLINE_LINUX.
After you’ve done this you can boot Qubes without qubes.skip_autostart kernel option.

Devices tab in sys-usb’s settings is grey and doesn’t react on clicks.

Is the sys-usb running?
If yes then shutdown it first and try again.
If it’s not running but still grayed out then just disable sys-usb “Start qube automatically on boot” in Qube Settings.
After you add USB controller to dom0 and reboot without qubes.skip_autostart kernel option then you can remove the USB controller from sys-usb and start sys-usb. Then if there is no problem with sys-usb you can enable sys-usb “Start qube automatically on boot”.

I disabled sys-usb “Start qube automatically on boot” and restarted system. But devices tab is still grey. Is it a good idea to reinstall Qubes?

After you disabled sys-usb autostart at boot continue with:

1 Like

Thanks a lot, sys-usb starts and works.
Only one question: is it okey that built-in microphone and my built-in SSD are still attached to dom0? All other devices are attached to sys-usb

Yes, it’s normal, all devices are attached to dom0 by default.
You can attach your USB controllers to sys-usb to use USB devices securely, attach PCI network controllers to your sys-net to use network securely, attach microphone to some of your qubes to use microphone there or attach your SSD to some qube to use it there.
But there are security consideration with devices handling: