Qubes 4.1 on Legion 5 pro R7 5800H RTX3060

Hello, I love QubesOS using it for two years now. Decided to buy more cpu cores and replace my old XPS15 with Legion 5 pro.
I can boot installer to GRUB menu, but the screen goes blank after selecting install. I guess its GPU problem. Or that there is no legacy boot mode. I tried to set nomodeset, nouveau.modeset, other flag to disable nouveau. Tried smaller flash. Used lates kernel weekly build of 4.1. Switched hybrid and dGPU modes in BIOS but nothing worked.

Has anyone tried this hardware configuration?
How can I debug the issue to get more info on what happened?

1 Like

Have similar issue. Xiaomi Mi Notebook Pro 15.6 with 4K OLED display.
Processor Ryzen 5800H, video card Radeon (VEN_1002&DEV_1638, seems like 1638 is its official number).

Tried to install Qubes 4.0.4. Boots to the moment when GUI should start:

(XEN) Xen is relinquishing VGA console.

but the screen stays black.
Compared to another (working) Qubes installation, the only unusual thing is the line

(XEN) setup 0000:00:00.2 for d0 failed (-19)

Otherwise everything looks perfect.

Any ideas how to deal with it? May be there is a command line mode?

What I tried was guest logging when boots i guess dom0 kernel, that was image posted. And comparing to live USB of Fedora 34 there was the same error with BAR6, but when i ran find /sys | grep iommu I did not find much so I guess Fedora does not use iommu the same way as xen which I supposed could be the problem with NVIDIA card. Similar problems were with XPS15, where nouveau.modeset=0 was enough to stop CPU deadlocks. Anyway iommu=0 did not help to run the installer and it will be needed to connect the devices to qubes.

You can try debug with params to kernel similar to this to see what happened after xen relinquishes console: ```
options=console=vga vga=current,keep guest_loglvl=all
kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-20190628-x86_64 console=hvc0 acpi=off

Source: https://www.gitmemory.com/issue/QubesOS/qubes-issues/5165/511175580

Seemed like a good solution, but no luck. First, I could not edit the BOOTX64.cfg file because it said that the filesystem is Read-Only. I’ve dismounted sda drive and mounted sda2. Then I was able to edit the file.

Second, I booted installer and the system went into loop.

watchdog: BUG: soft lockup -  CPU#0 stuck for 26s! (swapper/0:11

Wow, it seems that you have the same bug message and the same code. So, the bug effects all AMD Ryzen 5800H laptops.

Hi there. Same issue with a Legion 5 pro (only difference is I have a RTX3070).

I got some help from the libera IRC qubes channel, the core team hangs there. Ended up where you at, with the soft lockup.

Apparently we would only have luck with Xen 4.15, currently even with Qubes 4.1 the version used is 4.14. I have not had the time to build a version with Xen 4.15, but there’s a build repo (i’m on the go now will link later) that can be used (albeit challenging).

1 Like

I tried every method from [UEFI troubleshooting | Qubes OS](https://uefi troubleshooting). I used

vga=current,keep guest_loglvl=all

parameter in Qubes Verbose section and got generally the same messages

watchdog: BUG: soft lockup -  CPU#0 stuck for 26s! (swapper/0:1)

after using following settings

options=console=vga efi=attr=uc loglvl=all vga=current,keep guest_loglvl=all
kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-R4.0.4-x86_64 i915.alpha_support=1

I saw more bug information:

It is sad that the best processor on the market does not work with Qubes.

Hello! Bad news for me. I do not know whether I need to bring the laptop back to the seller, or there will be an update soon. There is an option to buy a Ryzen 4700U, but I am not sure that Qubes will work either.

Can you provide link to docs on how to build 4.1 ISO with newer xen?

for everyone try this :

Newer official image.

  • Use UEFI and Hybrid dgpu it’ll be okay, or change to discrete only if it’s doesn’t work.
  • Boot into Installation and choose edit Install qubes* entry.
  • Add i915.force_probe=* after .......plymouth.ignore-serial-consoles quiet so the line look like this ...... quiet i915.force_probe=*
  • F10 to boot with this config.

I was already using this version of iso. What helped me to run the installer was dom0_max_vcpus=1 dom0_vcpus_pin xen parameters.

1 Like

Unfortunately none of these methods worked for me. Still have not had the time to try and build with xen 14.15. @kokoska69 so you did manage to run the install, and you have a legion 5 pro with a 5800h and a RTX card? What options did you use exactly if I may ask, and once installed is it running ok?


I have legion 5 pro with 5800H and RTX3060. When you get to grub menu hit e edit and change line with xen like picture F10 to boot. I managed to install it.

You have to add the same params after install

1 Like

Thanks for replying!

What iso are you using? And any particular bios settings? Like are you using discrete mode for the graphics card?

Using this ISO https://qubes.notset.fr/iso/Qubes-20210814-x86_64.iso but the one you suggested worked well too. I wanted to have latest kernel, but that was probably only for the installer, my qubes have 5.10.54. In BIOS turn off secure boot. Graphics mode doesnt matter, try “dynamic” option.

1 Like

I managed to boot to the installer using beta1 (with your suggested options). I did have to use dynamic graphics, otherwise the installer wouldn’t boot.

Meanwhile after installation I can’t boot qubes, even using the same settings. Did you have any special settings at boot once installed?

Maybe the kernel version actually makes a difference?

1 Like

Some qubes wont start immediately, network vm and firewall had timeout when mounting /rw. But after starting them from manager it worked. I guess this could be related to beta. You have to add options to grub config in dom0 to boot it after install if you dont want to change them every boot. Now i dont have cable connection and cannot install WiFi driver GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device which i hoped will be in kernel 5.13. One downside to this legion is that it has USB keyboard. Its preventing me from having USB qube.

1 Like

I was able to install Qubes without any modifications using Qubes-20210814-kernel-latest-x86_64.iso 14-Aug-2021 05:54 5795479552

The most recent releases of Qubes OS are here: Index of /qubes/iso/

But I was unable to start OS though.
I know, there are some newer builds, but since 4.1 Qubes installs before HW checks and it takes the hell more time to test. Moreover, it does not update during installation like linuxes generally do. And that could help a little.

So, I’ve decided to install Kubuntu 20.04.2 LTS to try. It was interesting because I’ve got two errors that may explain the problem.

First try The latest stable build of Kubuntu did not start.
Error1: AMD-Vi - IOMMU
Error2: certificate X.509

Second try The same installer, but with update in the installer.
Error: certificate X.509

System did not boot. I tried [recovery mode] and the system started with the same
Error: certificate X.509

So, after logged to the system in recovery mode I started updater and there was endless list of updates, including kernel-firmware, and my laptop now works almost perfectly.

The only issue that it does not go to sleep with display closed, I have to choose the option from menu and only then I close it. Not a huge problem to activate sleep through menu, but you should know this.

The most working OS for 5800H is Fedora. People report that it installs without any issues. But I prefer Debian, and today I fell in love with KDE :grin: It’s so amazing that I want to leave my laptop and will install Qubes after it goes stable with 5800H support.

PS: I dream of having KDE as default in Qubes setup. It looks professional and runs almost perfectly (had to tune it for 4K display).

In order to boot installed qubes os you have to edit the grub config and add the same params as for the installer dom0_max_cpu…Different distros have live usbs which you can try before installing. My two choices if qubes fails were fedora or arch Linux. Arch could run xen in latest version. Qubes works for me now, but i will see more when i import my work qube and try it for daliy work.

1 Like

So, I decided to try to install Qubes once again using official Beta
Qubes-R4.1.0-beta1-x86_64.iso 11-Jul-2021 01:07 5485101056
It was installed without any issues. After installation I entered dom0_max_vcpus=1 dom0_vcpus_pin parameters in grub and booted.

The default Qubes and templates were chosen, then installation continued.
I saw that templates were installed, then it wrote something like “configuring system”…
and rebooted to empty grub command line. I see nothing except grub>

This time it seems like unrelated to AMD issue.