No boot screen for installation


I’ve just tried to install Qubes OS on a new HP Pavilion 15-ec1096nf laptop. My USB drive works (already installed Qubes 4.0.3 onto a desktop with it), and boots in the Pavilion, I can see Xen booting and logging for 3 seconds. Then the screen goes black.
Forever. (at least > 15 min)
I’ve tried other usb drives (I’ve also tried with a more recent Qubes 4.0.4 usb drive, same result), I can install OSes on the laptop, nothing wrong (currently a temporary standard ubuntu).
I’ve gone through the “Installation Troubleshooting”, I assume it’s not an UEFI problem, as the usb stick loads correctly. I was thinking about the Nvidia card.
As I previously gave up due to Nvidia gpu one year ago, though it does not seem to be insurmountable, I would really try to fix this to achieve installation.
I could not find in the Nvidia Troubleshooting guide what I should change (I found it deals with already installed systems, except maybe for “Lack of video output during Nvidia driver installation”, but it’s not exactly the case, I anyhow I don’t know where the “kernel command line” is).
Can somebody help me fix the installation, please?

I take it you disabled secure boot ? Qubes won’t work with it enabled.

Did you try a external monitor or tv using hdmi out or dp out ?

Hi Smudge,

Thank you to have me remember this first prerequisite : it was disabled (I guess I confused this and the TPM settings …).
So after enabling secure boot … I can’t get the qubes USB drive booting anymore. I checked the boot order settings, and checked the previous ubuntu installing usb drive : I was able to launch the “UEFI Firmware settings” from the ubuntu usb drive, then choose Boot Menu, and finally try to launch the qubes usb drive, but ended with “Selected boot image did not Authenticate”. I assume it is a question of certificate regarding secure boot ?

I was saying that Qubes WILL NOT work if secure boot is enabled.

Qubes only works with secure boot disabled.

Ok … :-s … sorry, thank you @Smudge , I am really troubled with that new machine :expressionless:

So, back in previous configuration : secure boot disabled, qubes usb drive is booting, Xen is logging for 2 seconds and then black screen (as long as the pc stays switched on).
I’ve tried with an external hdmi plugged in (which works when booting current ubuntu), the monitor does not light up during the boot with the qubes usb drive.

Just before the screen becomes black I can read a few info (as in snapshot), same as @NPS7102 in this post :

Is there some parameter I can pass to xen ? Is it related to nvidia troubleshooting ?

try add kernel option when boot :
nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

Hi @51lieal ,

Thank you for the hint. Where am I supposed to write these options ?
I’ve read at some places that such options may be written in the /EFI/BOOT/BOOTX64.cfg file (where there are 5 labels, default being [qubes-verbose]), is it there ?

Follow this guide :

Ok, in this guide there are 3 points :

  • System freezes during boot
  • Boot failure after GRUB menu (the one pointed out)
  • Lack of video output during Nvidia driver installation
    and all of them deal with an installed qubes os (mine is still not installed).
    But I don’t have a grub menu yet, how could I tell the system in the USB drive to follow these parameters ?

How about qubes 4.1 installation, have you try?

I’ve faced blackscreen too, but as far i remember : If its happen before installation then, try using hybrid graphic and bios mode.


@51lieal Great ! Thank you for the R4.1.0-alpha hint (I was trying in reverse, R3.1 & R3.2, unsuccessfully, and was thinking about replacing the BIOS with another one -CoreBoot ? to disable the graphic card) :slight_smile:
(Ho, btw, as you’re speaking about bios and graphic card, it’s the slimest bios I’ve ever seen, nearly no options, and none for graphic card disabling -the Ryzen 5 cpu has an integrated radeon gpu I thought I could rely on).

I eventually have a grub menu, and a shell.
I’ve tested the media, nothing wrong.
The first install attempt ended with “X startup failed, aborting installation”.
I tried the verbose option in grub menu, but it ended the same.
I’ve came back to grub menu, pressed ‘e’, added the nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off options at the bottom, then hit Ctrl+x, but still the same.

So now I can have logs and a shell, I’m searching in the community how I can bypass the X (or nouveau driver or nvidia gpu) troubleshooting : should I close this post (I’ve got a boot screen, though I cannot install for the moment) ?

I don’t think you need replace bios.

There’s no way to disable discrete graphics card in default bios, but in my laptop there’s just hybrid mode / discrete only mode.

So now you can enter installation? that’s great, once again as far i remember, i’ve facing problem too in the middle of installation, but in my thought. you need to do it fast, i mean set up disk, username, time zone and etc, then perform installation as fast as possibble. I don’t know what the exact reason, but it always succesfull if i do it fast.

you don’t need to configure kernel option / anything before installing os, oh and something to clarify :

  1. if you go through with uefi and mbr, use hybrid mode on graphic card
  2. discrete only will only work at bios and mbr.

Well, currently I’m still stuck without installation (but now I’ve got a grub menu at boot and a shell on TTY2 at abortion :slight_smile:).

In the hp bios setup utility (manufacturer AMI, revision F.11), I can update time and date, language, password, TPM, VT, wake on lan, usb boot, network boot, secure boot and boot order.
That’s all ! For a 2021 machine, that’s pretty incredible. So I cannot choose “Legacy mode”, nor disable the graphic card, or use an hybrid mode. I can not manage the storage (nvme ssd) neither ?!! It seems there is no menu to manage the north bridge functions (as it is integrated in the 4600H apu).

What’s why I’m stuck with the current bios.

So here I am :

hmm it’s weird even with modern hardware, it should support legacy mode, have you seen usb with legacy mode ? if yes then choose that in bios, then in boot menu choose usb flashdrive using legacy mode, do not choose that start with UEFI.

after that follow this guide :

1 Like

Yes, it’s definitely weird.

But 100% sure there’s no legacy mode (except usb charging, nothing more for usb, and with “power options” - i.e. fan, action keys, battery remaining time, adaptative battery and keyboard backlight : I’ve listed ALL this “bios” options), I find it a bit insane. I will register the machine to hp, to ask (if any ?) for a more “classical” bios (I guess this machine is regarded as a low cost machine, shipped with FreeDOS, so maybe did they cut costs also with the bios version).

I guess I have to cope with UEFI, sadly.

I have an old asus laptop ( 2015 ) and it used to have an option for legacy boot but after a bios update in around 2018 / 2019 asus removed the option.

I was annoyed about this because i could no longer boot any linux OS that didn’t support UEFI (which was most OS’s at the time) I contacted them about it, but obviously I got nowhere, “sorry you cannot downgrade the bios, blah blah …”

It seems most companies are doing this now. Microsoft orders maybe ??? :roll_eyes:

Anyway in the end I “unlocked” the bios myself and I now have legacy boot back aswell as millions of other options, most of which i have no idea what they do lol.

Unlocking a bios is pretty easy if you take your time and do your research.

There a pretty good guide below which is for an asus laptop but it is also a “AMI bios” so I imagine the procedure is the same for your HP laptop (don’t trust me though, do some research)
BTW the unlocking procedure is all done in software (no need to dismantle your laptop)

I also quite recently used me_cleaner on my bios to cripple Intel Management Engine, this required taking the laptop apart though and using a chip clip and a raspberry pi.
Guides below if your interested. ( I used the official guide and also the user contributed guides at the bottom)

p.s If you do do it make sure to buy a “pomona” clip. The cheap black ones on ebay and amazon are RUBBISH ! I spent literally a whole day trying to get it to clip on and in about 50 attempts the raspberry pi recognized it once for a few seconds and then lost it.
I gave up in the end and ordered a pomona 5250 and on literally the 1st attempt it clamped down on the bios chip perfectly and didn’t move a mm. The Raspberry pi recognized it straight away and 20 mins later i was done.

@Smudge exactly, I wonder if the bios isn’t simply locked (maybe for business purpose). I’ve seen people able to unlock some hp bios functionnalities with Ctlr + F1 when in Boot order option (F9), but it did not work for me.

The AMI tools you mentionned would certainly work for me, as they probably are the same (rebranded ?) that in the dedicated hp page.

Great, I didn’t fancy IME could be crippled, this is very impressive. So as the links you provided, the work of these guys is very impressive too (maybe will such a workaround for AMD PSP come soon).

Thx for your feedback about the components : I have an old dell laptop (and a raspberry pi of course :slight_smile:) that I’m willing to use to test a complete control, I’m keen on testing such a direct IME workaround.

For the current hp 15-ec1000, I must first ensure I’ll be able to recover to a stable state as I cannot afford to loose the laptop. But I wasn’t able to find the download of the current bios, I have to find a backup copy of the bios first … and maybe isn’t there any update nor more detailed bios yet ?

X not starting with AMD APU seems a common problem, I haven’t looked through all the workarounds yet, it may be quicker is somebody has already found a solution, so I’m reading these issues (there are many).

I just come across something which may be useful to you ? maybe ?

Something to do with " iommu=no-igfx "

have a read through all the comments on this page

Thx, I’ve read it and it gives me hints. Though this one seems to deal mainly with Intel based platform, this is probably the same kind of issue, I have to go deeper with the hardware options.

Btw, I’ve tested the machine I gave up with last year due to nvidia driver … and it boots to the grub menu with R4.1.0-alpha !!

So I have a workaround : exchanging the SSDs (both M2 connectors I guess), installing Qubes OS on the old machine, and then reverting SSD back in place.

I’m trying :grinning:

Well, the exchange of SSD’s worked … almost.

First time, I could install Qubes on the SSD, put it back in place in the new pc, but UEFI did not recognize the SSD any more "boot device not found 3f0 " :unamused:. So I tried to rescue the installation with the usb drive, I felt it could work as I’ve been asked for the luks password -and checked it was verified-, but I ended with a “You don’t have any linux partitions. Rebooting” message and a shell. I assumed it was because I let Qubes reclaim all the disk space (deleting the EFI partition previously known by the UEFI), so I tried anew (exchanging SSDs, installing Qubes), without deleting the EFI partition (that I had previously restored with an ubuntu reinstallation) and ended (once the SSD back in the new pc) with … a grub prompt :unamused:.

Tried again Qubes rescue with the usb drive, but ended with the same message :frowning:

So I’m looking at UEFI Troubleshooting | Qubes OS now, hope I can manage to boot Qubes.