No boot screen for installation

why don’t you post the specs for your machine

is your machine on the hardware compatibility list?

are you trying to do an uefi or non-uefi install ?

I have an HP laptop too and faced a similar issue earlier. I have a hybrid nvidia+intel card. I solved it as follows:

  1. dd the iso to a usb drive
  2. mount the EFI partition (second partition available on the disk)
  3. edit the file EFI/BOOT/BOOTX64.cfg using root privilages by commenting out the “noexitboot” and “mapbs” lines in the [qubes-verbose] section
    after that the [qubes-verbose] section should look something like this
options=console=vga efi=attr=uc
# noexitboot=1
# mapbs=1
kernel=vmlinuz inst.stage2=hd:LABEL=Qubes-R4.0-x86_64 i915.alpha_support=1
  1. save and exit
  2. unmount the EFI partition

now your installer should work
after installing qubes OS go to tty2 using Ctrl+Alt+F2
open the file /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg and verify that it doesnt have the noexitboot and mapbs lines
go back to tty6 (Ctrl+Alt+F6)

I found the above instructions here:



My machine is an HP Pavilion ec-1096nf (specs are here) so it has a FP6 socket Renoir zen2 Ryzen 4600h apu -with radeon RX Vega 6 integrated graphics-, an nvme SSD and a supplementary nvidia gtx 1650 gpu. I can’t find the specs of the integrated chipset. What other spec could be interesting ?

It is not listed on the HCL, I will add it (and a desktop machine that runs Qubes 4.0.1) … with the specs, but all in red :frowning: .

The bios is an AMI F.11 without legacy mode, so uefi is the only possibility.


I can’t find any /EFI/BOOT/BOOTX64.cfg when I mount the second partition (named ANACONDA)of the usb drive (or looking inside the downloaded iso as well), there is only have a /EFI directory, which has a /EFI/BOOT/BOOTX64.efi file (the same as in first partition).

That’s great you share your experience with such a hardware : provided I can install Qubes, I will be able to go to tty2 :smiley:

I’ve been away for a while, and I’m now back with the machine. I’ve just tried two different usb keys and iso 4.0.4 and 4.1.alpha, to try to go through the Rescue mode, but could never have a working rescue.
I’m accessing the installed Qubes with a linux live usb drive to edit the EFI and the ext4 partitions (the last contains /efi, /grub2 and /loader, I don’t know its name).
I guess Grub does not find the menu. I’m not skilled with Grub, I’m searching tutos, but if this case is known from anybody, any help would be appreciated :slight_smile:

On your Live USB find and application for disk manager. If there is no such software, you can install it through Software Center. My favorite is Disks. There you can find your USB Drive. Unmount your USB drive and mount ONLY second partition of the same USB drive (you should see Partition Type: EFI).

Go to your EFI partition and change /EFI/BOOT/BOOTX64.cfg file by any text editor of your choice.


Thank you @tvori-dobro :+1: it is not clear to me where are the files to modify in grub (and on which partition they are).

In the end I haven’t closed the topic before, though I’ve found a solution a few weeks ago : I tried a very new image (Qubes-20210821-x86_64), and it did work (though I have some troubleshooting to do).

So I’m currently using it to become familiar with Qubes OS, and will migrate from Ubuntu with the next official 4.1 release.

I’m closing this topic, thx everybody for your help