KDE - changing the way you use Qubes

Hi all,

I have tried KDE in Qubes 4.1 (Thinkpad L390) and works very well. Regarding the small glitches about the icons, I have been doing some tests. What I have seen is that from Qube Manager > System > Global Settings > Window defaults > Tray icon mode… there are different options to display the icons associated with AppVMs (such as sys-net). I have tried them all:

  • default (thin border)
  • full background
  • thin border
  • thick border
  • tinted icon
  • tinted icon with modified white
  • tinted icon with 50% saturation

Full background

  • Network Manager icon: appears completely white.
  • Whonix icon: white background and the two circles in gray.

Thin border

  • Network Manager icon: appears completely red (the color of the AppVM).
  • Whonix icon: white background, the two circles in gray, and with a thin black border (the color of the AppVM).

Thick border

  • Network Manager icon: appears completely red (the color of the AppVM).
  • Whonix icon: white background, the two circles in gray, and with a thick black border (the color of the AppVM).

Tinted icon (with modified white or 50% saturation)

  • Network Manager icon: fully transparent.
  • Whonix icon: the two circles in gray, without a colored border, and the outer white is transparent. However, the pixels around the circles must not be pure white and no transparency is applied. Consequently, white dots are seen around the circles.

Default (thin border)

  • The result is the same a tinted icon.

I think the default option is not doing what it should (thin border).

And about the icon of the applications menu… in the configuration of the application launcher you can select a new icon. In System Icons > Applications there is “qubes-logo-icon” and “qubes-manager” and in the Places category there is the icon used in Xfce and available in four colors.

Personally, considering the problem with the NM icon, for the notification area icons I prefer the Thin border option. At least I can see the color of the NM icon. In any case, the KDE experience in Qubes has been very pleasant.


A slightly different experience with the Network Manager applet:

Configuration exactly the same as HirschQ so I’ll paste theirs

Qubes R.4.0
plasma-breeze-qubes 5.5.8-1.fc25
qubes-kde-dom0.noarch 5.12.3.-3.fc25

dnf list *plasma
kde-settings-plasma.noarch 2000:25-6.fc25.2
kf5-plsma 5.38…0-1.fc25

The network manager applets for any net vm are invisible since I installed KDE. It’s a pain, but I know where they are on the system tray so can find them blindly.

Unusually, after suspending and restarting the pc a few times over the course of a few days (without rebooting), maybe plugging in an external monitor, all the network manager applet icons appear in the system tray, colored red.

I can’t reproduce this behavior, it happens randomly. Maybe there’s a log file to check?

The fix suggested by h110w above, to replace the kde system tray widget with Stalonetray from the fedora repository seemed like too much of a risk of breaking my stock install.

KDE has been great otherwise and it seems like the issue is kind of resolved in 4.1

The same for my Q R 4.0 I’m missing the network applet, in any case KDE is a nice visible thing for new users.

After recent updates, I now have a coloured square for nm-applet in 4.0
(not the colour of sys-net), and a white square in 4.1.

1 Like

Did you update with the Qubes Updater program or another way?

Still have invisible nm-applet in 4.0, until after a couple of suspend cycles, when it usually appears.

With the updater - I have all testing repositories enabled in dom0 and

1 Like