KDE - changing the way you use Qubes

Nice! I’m also going to try it.
While using xfce I also like to use one domain per workspace, but I think KDE is going to be better for this.

Well it’s time to say “shut up and take my request” for the Qubes repositories.

Ah, btw, how do you put the personal-Firefox and personal-Files on the desktop? This is going to be great for organizing my VMs.

1 Like

some icons and configurations are broken see:

on this first image you can see that the “networkmanager” icon from systemtraysettings are invisible but when we put the mousecursor it shows the label information, another problem is the sys-whonix icon a little bit weird, like noquality.

on the “APPLICATION MENU” using the “alternative” application Menu(a launcher based on cascading popup menus) we see that the icons that was suppposed to appear before the submenu text disappeared.

but when we setup the application menu with the “application menu launcher” alternative(right click on Q → alternative) the icons appears again.

noicon5
All the lockicons from q-domains menu is missed too

The absence of the Network Manager icon is a long standing issue - I’ve
tried to get some KDE developers onboard, but as yet with no success.
After a while, you just know where the icon should be from its absence.
(There are horrible hacks to make the icon appear - I think that the
screenshots I posted showed this: I don’t use them.)

I don’t use Whonix and cant see that image. If it’s weird I suspect that
the icons are not provided in scalable format. It’s an issue for Whonix.

The cascading menu doesn’t have icons - nothing is broken,that’s the
way it is.

I rarely use the q-domains menu, but nor has anyone reported this to me,
so I suspect in use it isn’t that important. I’ll see if there is an
obvious explanation.

There’s another KDE artefact - Top Right is a control field, but it gets
overlaid with a black square for each of the icons in the control
panel - disk, clipboard, devices etc. Use them once, and the square goes.

2 Likes

I should have said, that Menu doesn’t have icons at the top level -
submenus do have icons, for qubes, folders, and applications.

1 Like

I had previously followed these instructions to install and subsequently uninstall KDE using these commands:

sudo qubes-dom0-update @kde-desktop-qubes
&
sudo dnf remove kdelibs plasma-workspace

In which case if one tries to install KDE again, it will fail with the message that the ‘KDE’ group is already installed. Simply reinstalling kdelibs and plasma-workspace leaves KDE in a weird and incomplete state (e.g. no taskbar).

There might be an elegant way to solve this that I do not know. However, here is how I solved it in R4.0.4 with success based on this post:

sudo qubes-dom0-update apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

…followed by the exact same command using the --action=reinstall parameter. Funny enough, this did not only reinstall KDE but also made features (like HiDPI in SSDM) work that I previously failed to get working.

5 Likes

This is exactly what I’ve been in need of, thank you very much! Adding this to the list of to-do’s. I love boxes inside boxes inside boxes, and I had truly started to go about this in a much more difficult way. Such fun awaits!

3 Likes

i wish i could do all of it to run kde on my qubes but im a newb on linux and i learn fast but i cant do it, i tried, could some one please make a guide here since from the beginning… i know that qubes is for advanced but in my opinion i think the lack of “easy guides” make many newb users like me give up on using qubes, thats sad… :frowning:

It would really help if you told us exactly what you tried to do, and
exactly what failed.
You need to give us enough information for us to be able to help you.

It is a common misperception that Qubes is for advanced users. That
simply isn’t true.
I tried to be clear in setting out the steps needed to get KDE working.
The documentation is user generated, so if you want an “easy guide” you
can help by writing one, or being clear about what should be in one.

5 Likes

@unman I think I got this one for ya :smiley:

@smlt unman made a typo, and as you become a darker shade of green you’ll correct for the error via familiarity, :green_heart:

ERROR:

sudo qubes-dom-update @kde-desktop-qubes

STEPS:

  1. Open [Dom0] Terminal

  2. Type this:
    sudo qubes-dom0-update @kde-desktop-qubes

  3. Press enter

  4. Type ”y” then press enter

  5. Reboot when finished

How to Install Software in Dom0 | Qubes OS has additional educational material

1 Like

So what should be in a User Guide are commands that actually work? Who
would have guessed?

Thanks to @UncleBob for the keen eyes, and apologies to @smlt and all
the other potential KDE users, confused by my error.

@deeplow - can you edit the post please?

Incidentally, this is a great example of how a clear statement of a
problem, and the community working together, makes things better.

8 Likes

I tried to install KDE in Qubes R4.1, and I used sudo qubes-dom0-update @kde-desktop-qubes

After downloading everything, it failed with “Nothing to be installed in group kde-desktop-qubes” (or something similar, I forgot to keep a record of it. Sorry)

So I tried Sven’s method and typed in that long, long command. This time it worked perfectly. KDE is really far more beautiful than xfce.

edit: However, the “Q” icon of the start menu (shown in screenshots) isn’t there. I can still click that area and get things working, but I can’t see that “Q”.

3 Likes

Done. I’ve changed it to the full instructions: (as given by @UncleBob)

2 Likes

Thanks for clarifying that, and thanks unman for the OP.

I’ve installed it on 4.0 and everything is fine so far. I never got the hype surrounding KDE, but it might be ideal for an OS like qubes.

Really missing the Network Manager icon, and a VPN indicator icon that’s now also invisible. Are the hacks to enable it that horrible, or is there some other way to get similar functionality?

1 Like

I’ve been using KDE with Qubes for slightly over two years now, and I must say that I find the kind of setup Unman mentions very useful for me, as well. I have multiple virtual desktops set up, though without knowing about how the activities work to auto-group, to always open certain apps to specific Desktops and locations. (This is especially useful with my dual 4k monitor setup.)

I really prefer XFCE, but am struggling to get a comfortable desktop experience on a R4.1 machine with HiDPI display.
I hope this is the appropriate place to ask some KDE users:

  • Do you run HiDPI settings in KDE?
  • Do you think that HiDPI is more comfortable in KDE (compared to XFCE)?
  • How well does KDE behave in R4.1?

I didn’t know there was hype over KDE. I hadn’t used it before Qubes, and
the features it provided made it natural for me to continue using it.

Both environments allow you to set the DPI in their respective settings
and obey that value perfectly. You might struggle with getting HiDPI
working in your qubes, in which case the desktop environment running in
dom0 or sys-gui has no impact.

Personally I have found that the easiest and most robust way is this:

  1. make sure there is NO xsettings daemon running in your qubes (e.g.
    gnome-settings-daemon or xsettingsd)

  2. add Xft.dpi: 138 or whatever your DPI value is in /etc/X11/Xresources
    (Fedora) or /etc/X11/Xresources/x11-common (Debian)

  3. for some QT apps it will be necessary to set QT_SCALE_FACTOR=1 which
    I expected it to be by default, but it somehow isn’t.

I spent months struggling with HiDPI until I found the above solution,
which still makes me angry because it’s so easy and obvious once you
know it.

/Sven

1 Like

hello @unman . sorry for the lack of clarity in the previous post, I got confused, I thought @sven previous post would be the solution to the “icons” problem. by the instructions of this topic I managed to install kde-plasma and the only thing missing were the systemtray icons. but last night i was on the computer and suddenly all the icons from the systrem traydissapeared and then appeared on the desktop…I don’t know if this can help the kde-plasma developers but even so I decided to post it here on the forum. then i reboot the qubes and all the icons backed to systremtray…

The applets are isolated from systemtray in one taskmanager:

so i decided to find what was causing it and i found… i have a qbittorrent installed on a standalone debian-10 and the icon for it doesnt appear on systemtray but when i try to close qbittorrent right clicking on the invisible icon that what makes the icons appears on a separted taskmanager and visible on desktop.

i don’t know if this can help kde-plasma developers and i don’t know if it has any connection with the fact that the icons are invisible in the systemtray but i decided to share it with you.

the qbittorrent version is 4.1.5 installed via debian repository

see the video here

1 Like

I’ve probably been listening to too many linux pods, there’s one where one of the hosts volunteers with KDE and the co-hosts tease him about KDE evangelists and hype.

This wasn’t the first time I installed KDE, I’ve tried plasma on a tablet and am keen to try their project optimized for large TVs. This is the first time that the level of conifiguration available in KDE made sense to me. XCFE was fine before, but because of your OP, I’ll continue using KDE too.