Installing and running KDE as Desktop Environment

the network manager icon in the tray is here ,if u switch from xfce to kde session ,but if u boot in kde directly then it is missing but if u know where the symbol is then u can click at the taskbar and it will open. But with some other widgets (nearly all) I am not able to place any in the taskbar or whereever. There are some dependencies missing but I don’t know which one. But that should be get fixed anyway:)

1 Like

Absence of nm appplet is a known bug , features (or doesn’t) in 4.0 too

finally, I get the plasma 5 extension virutal desktop bar running fine. U have to install all the dependencies of our own and not like described via the script. That is not working and now with these dependecies a few more icons and things are working. u have to run sudo qubes-dom0-update for each of this packages.
qt5-qtbase-devel
qt5-qtdeclarative-devel
qt5-qtx11extras-devel
kf5-plasma-devel
kf5-kglobalaccel-devel
kf5-kxmlgui-devel

then u can use a widget like this. Just download the .zip -copy it to dom0 run ./scripts/install-applet.sh
and then install the .plasmoid file via add local widgets and u will find the widget and can place it in a bar. maybe there are more dependencies to get it fully working

update: installing these packages makes kde much more working and shows icon like the pager, showing the desktop and else in the task bar or where u prefer. installing sudo qubes-dom0-update latte-dock makes it even more flexible if u like to work with docks and u can choose a good selection of ur bars ,enable autohide and else to have a “big desktop”

4 Likes

Hello to everybody,
I have got a “problem” with the icons, too. In the deskop pannel (standart and latte-dock pannel) it is not using the icons I have set and selected. At the desktop there are the right icons but as I start it then there will be the standart colored icons of the xfce vm’s. I tried to change a icon in xfce and in kde for the same app, but then it even shows the standard icon. How can I change the path in latte config or whereever I need to edit, that it will select the icons from kde everywhere, not only at my desktop? Of course it will be nice tio have them in the pannel ,too. I think I need to change some link to the right folder or sth. like that?
Can u tell me where the standart icons are located? maybe I can copy the other one in the folder and overwrite it and then it will use the icon I prefer for the app.
And it would be nice to know in general how to change an icon for example for firefox in a vm, because then I think it will be on all my desktops the same.

much blesses and thank you very much for your help.

Ps: accoring to the problem with the pager icon, u have to enable on time a second desktop for example in the virtual desktop bar or with a shortcut and then ur are able to put it in the pannel of your chose. And as a tipp ; using the pannel of latte dock is better for customizing if u lake to change ur startmenu or whatever.

1 Like

Can we fix that anyway?! For example : when starting teams or libreoffice there should not be only the colored vm qube- There should be the icon in the color u prefer. Just selecting the icon in properties doesn*t change anything. maybe I have to modify the .desktop file to use an other png. I got an other .png in the qubes appmenus but not in the pannel. Everywhere I have got the right icon, but as soon I start the app it will be the qube. That will be very good to know how to get that working. Then I would post a new kde-customization thread for qubes 4.1 and we can say that KDE is fully working. I will update later a few dependencies I installed later. Atm the icon is the only problem I noticed with KDE. And an other advantage is that you can change the language of ur system to german, arabian or what u need :slight_smile:

The problem with the icon should be sth. with the breeze and oxygen theme and need to copy in one of this folder anywhere:D. It uses .svg files as pictures and the other one .png from the hi-color folder. I think we need to copy the icon in one of those folder and maybe change the .png to .svg or sth like that ,but I don’t know how to get it working and my main problem is the correct path. And some apps like teams did not tell dom0 that the app is installed and did not have a link to the high color icon folder. But too much folders for me to get the structure how and where to place the icon. But we are getting closer. Anytime we can fix it;)
Btw I try to update how to install Kde with its main and useful dependencies at a github page and summarize all our results their, so it wil be easier for new people to get it working. The icon problem is one of the last things I cannot fix and like to tell everybody how that is working. But I sometimes I have no time and need some to update the page and I do not garanty for any problems and it should just be a help for new users:)

The problem with icons is that a app like teams don’t have the step: processing trigger for hi-color-icon-theme and most apps do this at installing. But how to do it for these apps , unfortunately I don’t know …

1 Like

When I did sudo-qubes-dom0-update @kde-desktop-qubes, it gave me a list of the core packages it was attempting to install in the sys-firewall popup terminal. I copied and pasted the core list from there, used dnf to install:

sudo dnf install apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

Then switched per instructions here KDE | Qubes OS

Everything works except, missing icons on the dock (start icon, + vm nm icons). All other icons are there (including virtual desktops). Yay, finally runing KDE in 4.1.

One other issue: The window manager has locked up twice in the few hours since I swiched…not sure why yet. I restart it via a console: ctrl-alt-F2 to get a console, then log in, then sudo systemctl restart sddm

edit: vm color on window borders is nto working :frowning:

2 Likes

@face
I didn’t run into package group issues when installing KDE in dom0, but that was probably >6mo ago. KDE was experiencing random startup problems until I used dylangerdaly’s workaround for the bad hpet timer on my system. Now KDE is very solid. However, the system still does lock up if I use the built-in Wifi (Intel AX200) which causes IOMMU errors to be reported in the hypervisor.log. When using a USB Wifi adapter instead, the system is rock solid for weeks.

The KDE colors actually do work, but they have no default setting. You can create the settings with a small script which I added to my KDE startup.

1 Like

Nice, thanks @tasket , using your script and I have window colors. I did open a small PR as my system needed the directory created.

KDE has been more stable for me too…I removed the native Nvidia driver that wasn’t working anyway and that seems to have helped.

1 Like

ah, the official script for color borders works too and has some more intense selected vs not selected colors: qubes-desktop-linux-kde/qubes-generate-color-palette at master · QubesOS/qubes-desktop-linux-kde · GitHub

2 Likes

sudo dnf install apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

Thank you for writing those lines @face I was too lazy and busy the last weeks. Of course I installed this, too, after running sudo qubes-dom0-update @kde-desktop-qubes, I run sudo dnf install plasma-workspace and took a screenshot of the packages that are usually in the kde group and installed it after that step. But now it is much easier, just to copy these lines to dom0. Thank you very much again :slight_smile:
My lines are just some more to add the addon to the bar if you like such things and then kde should be completely. But you don’t need it. And you can install it in one step ,not like i told u up.
just in dom0:
sudo qubes dom0-update qt5-qtbase-devel qt5-qtdeclarative-devel qt5-qtx11extras-devel kf5-plasma-devel kf5-kglobalaccel-devel kf5-kxmlgui-devel :slight_smile:
I like KDE and Qubes. And I am running this setting since 2-3 month without much problems and can prefer it to everybody, especially new users should have it a bit easier to work with kde .

Ps; A few icons are missing for me two and I don*t know how to fix it, because the folder structure in qubes, kde and all those vm’s is difficult for me, but maybe anytime I know the place where to copy a .png file and to have icon available for those missing apps. Or maybe anybody can help here and know the right place. Then we can use a custom icon for those apps, with a missing one.

@face can you please tell me how to use the color script? I have to download it as a .sh and install it in dom0 or what is the easiest way? sorry for that nooby question, but sometimes I hang at easy things and more difficult things works …:smiley:

2 Likes

@rasta yes, just install it in dom0 and run it. tasket’s script is a .sh, the official one is a .py. Tasket suggested putting the script in autostart for kde, but you really only need to run it once and it creates some color configurations under $HOME/.local/share/qubes-kde/…

In a nutshell:
dom personal:

cd /tmp
wget https://raw.githubusercontent.com/QubesOS/qubes-desktop-linux-kde/master/qubes-generate-color-palette

now manually inspect qubes-generate-color-palette, make sure it is not nefarious

dom0 as your regular user:

mkdir -p  ~/bin
qvm-run --pass-io personal  'cat /tmp/qubes-generate-color-palette' > ~/bin/qubes-generate-color-palette
chmod +x ~/bin/qubes-generate-color-palette
~/bin/qubes-generate-color-palette

and magic, borders should work without even restarting kde :smiley:

1 Like

I decided to do a completely clean install with the new 4.1 beta and have kde up and running great. using all the methods before all mentioned above. I was wondering if anyone knows what to do with this: GitHub - QubesOS/qubes-desktop-linux-kde: Qubes component: desktop-linux-kde

It makes a lot of fixes (journalctl is full of non-critical errors), but i haven’t a clue how to use or install it. I’ve searched for a great deal of time on how to do it. But the closest I’ve got is to create an RPM which isn’t really the route i’d like to take. I’m sure I managed to run it in the alpha but can’t remember for the life of me how I did.

Many thanks!

How to install KDE in QubesOS 4.1 beta1. The whole process in one post with some minor corrections.

Everything is done in dom0 terminal. Run Terminal Emulator in Main menu.

You DO NOT need to enter

sudo qubes-dom0-update @kde-desktop-qubes

Just write the following command:

sudo dnf install apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

That’s all!

Optionally you can install KDE default login manager sddm:

sudo dnf install sddm

Set sddm according to Qubes needs

sudo nano /etc/sddm.conf

add the following lines to the file:

[XDisplay]
ServerArguments=-nolisten tcp -background none

Press Ctrl+x, y and hit Enter

Then we need to activate it by:

sudo systemctl disable lightdm
sudo systemctl enable sddm

I did not install coloring script because colored icons were good enough to distinguish qubes windows.

I tried different methods to add different Qubes OS input methods, but the only one worked. The best way is to add all of the settings during install, otherwise follow instructions below.

So, to add new input language in Qubes do the following:

  1. Log Out of KDE session
  2. On a login screen choose Xfce desktop environment
  3. Login
  4. Open Main Menu -> System Tools -> Keyboard, choose Layout tab
  5. Unselect Use system defaults and change input layout settings as needed.

If you added new layouts in KDE settings first, there could be some bugs. Try to delete and add everything.

If easy way of doing it did not work for you, then follow the official manual.

Is the hope of full KDE reworked support now completely dead? Is XFCE, going forward, literally the only DE Qubes will support (i know XFCE is the only official, I am referring to community support). I have KDE running on full testing enabled 4.1 qubes, but it seems that the reworking of KDE has come to a stop and there are endless errors in journalctl, which i think fepitre’s reworking was resolving. It would be a shame to ‘strictly’ only support XFCE when it seems a good number of people, myself included, hate/very much dislike the XFCE desktop…

Don’t do this. (Besides the fact that dnf wont do anything in dom0,
so it just wont work.)
Because of the refactoring in 4.1, you get KDE with Qubes support
by issuing sudo qubes-dom0-update kde-settings-qubes in dom0.
Some rough edges, but all the benefits of KDE and decent coloring.

1 Like

No - there are rough edges that need polishing.
It’s a mistake to think that Xfce is “the only official DE” - it’s the
default, but Qubes provides official packages to support KDE and i3.
With a small team, it’s necessary to prioritise, and KDE support isn’t a
priority.

Despite the log errors, (and the perennial icon bug in the panel), I
find it as good as ever.
I think the move to Xfce was a huge mistake, and KDE far better suited
to Qubes workflow.

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

2 Likes

As always @unman , your reply is very much appreciated, and although you do not speak for the Qubes team, your input on various things all things Qubes, I’m sure, many are grateful for. The network icon bug doens’t really bother me at all, and I agree that move from KDE to XFCE was a mistake - but I’m obvioulsy speaking with compete bias. I’ll just hope the people who have the capabilities to support KDE well, can, hopefully, bring it on track. As a side note/question…Would you be able to tell me how to impliment the spec.in in fepritre’s reworking? I’m not a novice, but I am certainly not a developer of any kind, nor someone who has any history of compiling rpm packages…Quite literally anything you can tell me with respect to this, I would be grateful to hear.

sorry that im crashing this thread and asking a bit different question here but as i read this i was wondering is there anywhere a list what the qubes-dom0-update package manager brings for us? i got the feeling there are some interesting packages in here

I found KDE and latte dock was important for me when I used Ubuntu-studio but I don’t like it in Qubes due to the lack to functionality to customize things like the theme. Also latte dock doesn’t pin AppVM and the menu structure requires one additional click to get to the same point.