Dark Theme for [Qubes Manager] Not Working in 4.1

Following both the instructions here (which work fine on 4.0) - Contents/dark-theme.md at master · Qubes-Community/Contents · GitHub (setting a dark theme in Appearance Manager)

And also adding settings.ini to .config/gtk-3.0 && .config/gtk-4.0 with gtk-application-prefer-dark-theme=1 (which also works in 4.0 fine) - MOST things in dom0 go dark with these steps, the taskbar, most of the app windows, nautilus/thunar windows, etc.

Most things but Qube Manager. Anyone know why this might be? Does manager require a special separate setting somewhere? Does it not use GTK?

I think you just go to Qubes-menu > Appearence and choose adwaita-dark.

That’s what you do in Qubes 4.0, yes. But in 4.1 - this does not make the Qube Manager dark. Makes “most” things dark, but a few things not and Qube Manager being one.


I saw this too in 4.1 in xfce. I switched to KDE…and it fixed Qube Manager in dark mode. So if it helps the issue is only in Xfce for me.

1 Like

Any news on this issue please ? Just installed the latest release (4.1 RC2) and still get this issue… No dark theme (only minor black “artifact”). Thanks.

I haven’t seen a fix for it. I opted to install KDE using this guide: KDE - changing the way you use Qubes - #8 by Sven

From there, the dark theme is trivial to implement. I also use debian as my default template for my appVMs. That requires a template install of gnome-tweak-tool and a few simple changes to ~/.config in corresponding appVMs to have dark themes both system wide and in your VMs.

1 Like

In dom0:

$ sudo qubes-dom0-update qt5ct qt5-qtstyleplugins

Then, run:



$ qt5ct

Here you select Style: gtk2 (to match your current XFCE settings) and you can select also Fonts and Icon Theme.

Only QT_QPA_PLATFORMTHEME=qt5ct needs to be made persistent.

1 Like

Thank you for your answers @necker @fepitre
Unfortunately, using qt5ct didn’t solved the issue. No difference even after a reboot, the gtk2 style seems to be applied only on the “Qt5 Configuration Tool” window.

I think that I will move forward with KDE for now and hope that there is no big issue with this alternative desktop environment.

@nimp Be sure to use the guide I posted above. Official documentation is broken.

1 Like

Have you tried in the same console to run qubes-qube-manager after the export? Because it works on R4.1 as explained to you. To have it persistent, you need to add the export inside e.g. in a /etc/profile.d/.

Thank you for your help, so I created a new file startup.sh in /etc/profile.d/startup.sh with the export line, and it does work only if I launch it from the terminal (by running qubes-qube-manager for example) but my “desktop” theme is still the same and any app launched from it also.
Am I missing something in your instructions ?

export QT_QPA_PLATFORMTHEME=gtk2 in /etc/environment equally does the trick, if the respective dependencies are installed. Not so important in dom0 but if you want to push it into all your templates, it’s nicer to do it this way instead of having to run qt5ct.


A great solution here @nimp :slight_smile: .

in dom0, in terminal, if i go to
~/.config/‘The Qubes Project’/
there’s a
file inside. I wonder if that config file could have a dark theme setting. there isn’t any now…

I use a dark theme in dom0 and my Qube Manager is dark. This might be an issue with your particular theme.

For me, I have Adwaita-dark selected as the theme. All vms and applications have been told to use dark theme. The Qubes programs are the only ones ignoring the setting, in dom0 or anywhere. Maybe I’m missing something?

How is this done exactly?


bash: qt5ct: command not found

This is insane. Starting Qube Manager from terminal, Qui-domains and applications menu give 3 different Qube Manager styles?!

  1. sudo qubes-dom0-update qt5-qtstyleplugins
  2. add QT_QPA_PLATFORMTHEME=gtk2 into /etc/environment
  3. remove all other defines of QT_QPA_PLATFORMTHEME you might have added in other places
  4. Reboot. Done.