4.1 dark mode issue SOLVED

Good afternoon guys,
So I have set xfce dusk and while most things are now dark, things like qubes setting manager and a few other things are still normal “white”.

Upon researching I find this and it goes back to R4.1 rc2…

Now fepitre list a few terminal cmds to run but does not really elaborate on what needs to be changed or setup for a “universal” dark mode for Qubes OS.

Can someone…
-fill in what is missing
-are these terminal cmds still valid for qubes os 4.1 stable with latest updates

Also in this thread user (face) speaks of going with kde and this fixed his s issue.

Can someone…
-Explain what is the big difference between KDE vs XFCE
-What are the tradeoffs if I chose to go with KDE
-how much hard is it to transition to KDE from XFCE
-also I have read that KDE does come with some issue when installed on qubes…

Again using qubes os stable 4.1 latest updates as well…

As for my templates I know how and what to do for them like debian,fedora…etc for dark mode

I just want qubes now to be dark, as looking at “birght white” does present some eye strain and glare…

Thank you for your time and efforts

1 Like

I second this. Switching to KDE environment from xfce seems like a major change to accomplish something as basic as dark mode. It would be great to have it incorporated directly into qubes in the future (eg during installation process include an option where you can choose between global light/dark mode in qubes)

regarding switching to KDE from xfce I personally found that KDE has some nice advantages in the form of dark mode and great night light integration but usage wise it feels slower and more clunky to operate compared to xfce even though I’m new to both. (have used gnome in ubuntu 20.04 lts for around a year, and prior to that win 10)

Most of the Qubes OS UI in dom0 is now Qt5 based and doesn’t by default adhere to the selected theme, which is especially annoying when using a dark theme. Luckily this can easily be remedied by installing qt5-qtstyleplugins and exporting QT_QPA_PLATFORMTHEME=gtk2 (e.g. in /etc/environment ).

From my post in another thread.

1 Like

@Sven
Am I correct in this process???

sudo qubes-dom0-update xfce4-whiskermenu-plugin

sudo qubes-dom0-update qt5ct qt5-qtstyleplugins

Then you state…and I get lost (how to do that,if I may ask?(

export QT_QPA_PLATFORMTHEME=gtk2 in /etc/environment equally does the trick

if the respective dependencies are installed. Not so important in dom0 but if you want to push it into all your templates…

@B_ryr:

Am I correct in this process???

No

sudo qubes-dom0-update xfce4-whiskermenu-plugin

That is for a different purpose. If you want to use Whiskermenu, then yes you can install it this way. However this has nothing to do with the theming of Qt apps.

sudo qubes-dom0-update qt5ct qt5-qtstyleplugins

qt5ct is not necessary for my method. I do not see the point in installing qt5ct, setting QT_QPA_PLATFORMTHEME=qt5ct and then running that program to select the gtk2 style. It makes it more complicated, error prone and installs unnecessary packages in dom0.

Instead:

  1. sudo qubes-dom0-update qt5-qtstyleplugins
  2. add QT_QPA_PLATFORMTHEME=gtk2 into /etc/environment
  3. Reboot. Done.

What do you exactly mean / execute by this?

@Sven
Ok, yes I like xfce,so I want to install Whiskermenu…

Ahh…I see now what you are saying…

  1. add QT_QPA_PLATFORMTHEME=gtk2 into /etc/environment

user@dom0] sudo nano /etc/environment

Add it anyway in file??

The statement of…
if the respective dependencies are installed. Not so important in dom0 but if you want to push it into all your templates…

if the respective dependencies are installed…
What other dependencies are needed then?

Means “dark mode” will now also be applied to all templates and domains,correct?

That would be awesome!!!

None in dom0. It already has everything that is needed.

What I meant is that if you’d use e.g. debian-minimal the packages gtk2-engines-murrine and gnome-themes-standard would be needed.

No it does not. What you do in dom0 only affect dom0. Qubes are affected by their templates and you have to make the changes there.

2 Likes

@user128 awesome!

I will add to other templates (debian & fedora) as well following this…

sudo apt-get install qt5-qtstyleplugins

sudo apt-get install gtk2-engines-murrine

sudo apt-get install gnome-themes-standard

Then edit /etc/environment and add line

QT_QPA_PLATFORMTHEME=gtk2

sudo dnf install qt5-qtstyleplugins

sudo dnf install gtk2-engines-murrine

sudo dnf install gnome-themes-standard

Then edit /etc/environment and add line

QT_QPA_PLATFORMTHEME=gtk2

Once I do this to my templates, I assume it will go over to my domains, right?

I mean dark mode can now be set and nothing should be install now in domains as it is in the templates…

sudo dnf install gtk2-engines-murrine

That one is called gtk-murrine-engine on Fedora, however both are likely already present. I do not have a Fedora qube at hand, so you need to find this out yourself. dnf search is your friend.

Once I do this to my templates, I assume it will go over to my domains, right?

Yes

I mean dark mode can now be set and nothing should be install now in domains as it is in the templates…

More precisely the theme used in your QT5 applications will match whatever GTK2 theme is selected. If that happens to be a dark theme, then stuff will be dark in the same way it is in all your GTK2 applications.

2 Likes

@Sven
Again my friend, thank you for your time and scholarship!