KDE - changing the way you use Qubes

hello @unman . sorry for the lack of clarity in the previous post, I got confused, I thought @sven previous post would be the solution to the “icons” problem. by the instructions of this topic I managed to install kde-plasma and the only thing missing were the systemtray icons. but last night i was on the computer and suddenly all the icons from the systrem traydissapeared and then appeared on the desktop…I don’t know if this can help the kde-plasma developers but even so I decided to post it here on the forum. then i reboot the qubes and all the icons backed to systremtray…

The applets are isolated from systemtray in one taskmanager:

so i decided to find what was causing it and i found… i have a qbittorrent installed on a standalone debian-10 and the icon for it doesnt appear on systemtray but when i try to close qbittorrent right clicking on the invisible icon that what makes the icons appears on a separted taskmanager and visible on desktop.

i don’t know if this can help kde-plasma developers and i don’t know if it has any connection with the fact that the icons are invisible in the systemtray but i decided to share it with you.

the qbittorrent version is 4.1.5 installed via debian repository

see the video here

I’ve probably been listening to too many linux pods, there’s one where one of the hosts volunteers with KDE and the co-hosts tease him about KDE evangelists and hype.

This wasn’t the first time I installed KDE, I’ve tried plasma on a tablet and am keen to try their project optimized for large TVs. This is the first time that the level of conifiguration available in KDE made sense to me. XCFE was fine before, but because of your OP, I’ll continue using KDE too.

@unman it would also be helpful to say how to switch back from KDE to XFCE.
I understand that to “remove” KDE one needs to be careful and should consult this page:
qubes-os.org/doc/kde.

Is there a way to switch back to XFCE without removing KDE?

When we did this:

sudo qubes-dom0-update @kde-desktop-qubes

It installed KDE, but I don’t remember it uninstalling XFCE, and It looks like XFCE still exists on my machine.

I think I should:

sudo qubes-dom0-update @xfce-desktop-qubes

edit: I intend to tinker with KDE in the future and continue to learn over time, for now it’s complicating matters and I would like to be able to switch between them at my own pace.

Hi @UncleBob no installing/uninstalling is required.

You can simply log out of KDE and get back to your login screen.
Depending on which login you are using (lightdm is the default, sddm the
one mentioned in the KDE instructions) the list to change the DM is
either behind a button on the top right (lightdm) or bottom left (sddm).

There you will find “KDE” and “XFCE” listed. Simply choose “XFCE” and
then enter your password to login.

You can switch between your installed environments any time you want.

2 Likes

That is super convenient and thanks for explaining Sven. You pulled me out of a tunnel vision rabbit hole stuck in terminal land, and I feel a mix of silly, grateful, awkward, embarrassed, and tired lol.

4 Likes

I love KDE. It allows me to commit to Qubes as my main OS.

On KDE, I can easily add custom shortcuts for changing between virtual desktops, moving the active application to another desktop or for pretty much anything I can think of. I press Ctrl + Alt + W to move to my work desktop (where I launch apps from my work qube), Ctrl + Alt + M to move to my messaging desktop etc.

Press Alt + Space and you can use krunner to launch your apps by searching for them or command-line style. For instance, press alt + space, then type qvm-run personal firefox. This will run firefox on a qube called “personal”. It’s a gentle way to get used to qubes commands without needing to keep a terminal open. Need to kill a qube quickly? Press Alt + Space, then type qvm-kill name-of-qube-to-kill. And with KDE dependencies already installed, why not install yakuake in dom0? Then you can press F12 (or whatever you set the shortcut to) and you have a drop-down dom0 terminal wherever you are. Then say you want to change the brightness or amount of blue light coming out of your monitor, just hit F12 and type your required redshift command, F12 again and the terminal disappears until you next need it. Maybe this is a bad example as KDE has a night light feature but you get the idea.

I personally have eye problems and use dark themes and larger fonts. I find this much easier to configure and more consistent in KDE. This is especially true for tools like Qubes Manager that were written when KDE was Qubes’ default desktop environment. And KDE has many more features that make things more accessible for people like me or just easier for others. For example, when a window appears and is blindingly white, you can enable the “Invert Colours” desktop effect. Then it’s Ctrl + Meta (windows key) + i to invert the whole screen or, even more usefully, Ctrl + Meta + u to invert colours only on the active window (whatever application/popup you are on). This is a godsend for reading pdfs. See a font that’s too small to easily read? Enable the “Zoom” desktop effect and then press Ctrl + Meta + = as in Ctrl and Meta and the equals key, et voila, you’re zoomed in on any app. Ctrl + Meta + - to zoom back out.

I think KDE is a great fit for Qubes and I could list a bunch more features if I wasn’t already worried about the chances of TLDR thinking creeping in :slight_smile:

p.s. unman, I found your salt examples on github super useful so thank you for those as well as for promoting KDE!

3 Likes

Thanks @unman for this!! I thought I would give kde a go with 4.1 over the weekend after using i3 and 4.0 for 12 months with qubes. I absolutely love it and think it is definitely the way forward for qubes. I did miss the tiling window manager functions though. But today I am so excited to share that I discovered the krohnkite script that adds auto tiling window functionality to kde (even better then i3) via a kwin script. This for me cements kde as a key contender for qubes os moving forward. Instructions for the krohnkite script can be found here:

I packaged it in a disposable vm first and copied it to dom0.

Disclaimer: As always if you don’t know how to review a script then don’t copy to dom0!

But this script has changed my whole experience / life with qubes!

Enjoy!!!

Much love to you all

Hayden

1 Like

Hi unman, can you please share some of the hacks you have found to get the nm-applet icon to display? Do you think it’s possible to get the plasma-nm applet running on sys-net as a better alternative or does qubes os have a dependency on the nm-applet?

Thanks
H

Hello there! I’m new to Qubes OS and I really fell in love with it. Before Qubes I had to use up to four different devices for my daily work. I’m happy to get it all in one now and after a few weeks ‘productive working’ I tried to organize my windows and workspaces to get more focus. That’s why I’m using KDE now. Beneath the fact that it looks much more attractive to me I’m facing some issues. I’m also missing system tray icons. I found a closed issue on github https://github.com/QubesOS/updates-status/issues/330 but for my shame I don’t know how to use it :frowning: but it seems to fix the problem? If yes I would be happy to get some tips :slight_smile:

Another important problem for me is the missing device widget. How do you experience the qvm device widget in KDE? I was surprised to find all storage devices (that I usually attach to my vm’s through the qvm device widget) are directly attached to dom0 in dolphin :open_mouth:
Who faced the same issue and is there a fix?
Thanks for some advices :slight_smile:
vanessa

edit: I should mention my current configuration :smiley:
Qubes Manager > About > Version Information
Qubes R.4.0
plasma-breeze-qubes 5.5.8-1.fc25
qubes-kde-dom0.noarch 5.12.3.-3.fc25

dnf list *plasma
kde-settings-plasma.noarch 2000:25-6.fc25.2
kf5-plsma 5.38…0-1.fc25

Hi @hirschQ, welcome to the community! I’m glad you like Qubes OS!

This looks like a consequence of having a USB keyboard. Do you have a USB keyboard? If yes, read this: USB qubes | Qubes OS.

Hey @fsflover, thanks for your answer. The storage devices are sata connected… Do you use KDE too? Can you use the qvm device widget within KDE environment? I used to connect my headset through this widget aswell (cinch)… I think its for xfce purpose only :frowning:

I don’t use KDE currently, so I can’t help you here, sorry. I hope someone can give more suggestions.

Unless you have taken steps to isolate them, those storage devices will be
attached to dom0.
You could only change this if you have multiple SATA controllers -
check withlspci but not all that likely.

The device widget works fine for me - is it actually missing completely
for you? Check with ps aux|grep qui-devices for output in dom0

Unless you have taken steps to isolate them, those storage devices will be
attached to dom0.

Ok, I don’t know why but I thought they are attached to nothing unless I attach them to a running vm :sweat_smile:

I have only one sata controller… I think I have to dive much deeper to be sure its working the way I think it is… obviously^^

ps aux|grep qui-devices prints:

8642 0.0. 0.0 9680 1112 ? Ss /bin/bash /usr/bin/widget-wrapper qui-devices
8643 0.0 2.0 552408 71756 ? S1 /usr/bin/python3 /usr/bin/qui-devices

and a 3rd one about color=auto^^

looks like the widget is running right? I can still use qvm-devices via terminal

thanks for your support!

Unless you have taken steps to isolate them, those storage devices will be
attached to dom0.

Ok, I don’t know why but I thought they are attached to nothing unless I attach them to a running vm :sweat_smile:

I have only one sata controller… I think I have to dive much deeper to be sure its working the way I think it is… obviously^^

ps aux|grep qui-devices prints:

8642 0.0. 0.0 9680 1112 ? Ss /bin/bash /usr/bin/widget-wrapper qui-devices
8643 0.0 2.0 552408 71756 ? S1 /usr/bin/python3 /usr/bin/qui-devices

and a 3rd one about color=auto^^

looks like the widget is running right? I can still use qvm-devices via terminal

thanks for your support!

Yes, that suggests the widget is running.
I haven’t seen this issue with it not appearing.
Can you kill that process (sudo kill -9 8642 - check the pid again
before doing this). The widget should automatically restart.
Check the logs for references to qubes-widget

I have not had this problem (the widget not appearing in the panel).
I do have a problem where a second widget appears in the top LH corner
of the screen as a black square. Clicking on it produces the appropriate
menu - using the widgets makes it disappear. That doesn’t seem to be your
issue.

Hi unman, have you had any luck with getting the network icon to display in kde?

Thanks
H

I’m sorry - I thought i had made it clear that I am not making any
effort to do this.

Hi unman, my apologies, I thought you used it as a daily driver yourself. I wasn’t expecting you to put in anymore effort, I have just started to look at this myself and was going to put in the effort to try get it working. So if you are happy to share what you already know about the issue that would be great otherwise that’s fine and I will proceed with the info I have already gathered.
Cheers
H

I experienced this when I first setup KDE. I’d followed instructions in comments on the github page on installing KDE in qubes.

I’m not sure if it was a result of using some bits of KDE 4 and some of KDE 5, that I’d changed the icon theme to something other than hicolor, or both.

Try installing kde-settings-qubes in dom0 if you haven’t already. You could also have luck changing the icon theme and/or changing the Icon= line in /etc/xdg/autostart/qui-devices.desktop

Hi unman just to give you an update and for your information, to get around this issue of the blank icon I removed the kde system tray widget from the panel, and installed the Stalonetray from the fedora repository. using the Stalone system tray the network icons now appear. Unfortunately until the kde developers make the required fixes, this appears to be the only option.

If your interested the github details are here:

Thanks
H