I3 not working properly video/graphic issues

On xfce I don’t have that time of issue but I’m having it on i3

Is it there a way to improve this ?
I’m having that issue on file manager as well [when clicking folders,videos,…] … I can say on everything

I’m having that problem even on luks password

1 Like

i3 user here.

I’ve had this problem with my LUKS password (no typing cursor displayed, password dots pixelate-fade in and out) since before using i3. I am on R4.1 and used the default, XFCE4, before i3. It didn’t bother me since the delayed password dot appearances could even be construed as security feature (— not a bug!).

I did not have this problem once I’d logged in to XFCE, though, and nor on my previous OS. This problem did immediately occur, however, after logging into i3. It stuck out then, but I don’t notice it as much now, as I’ve gotten used to it. In my brief and still preliminary experimentation with xmonad on Qubes, I can say that I haven’t seen this problem yet.

Regardless, it looks like whatever is handling the GUI is rendering the VMs’s GUIs line by line, block by block. I don’t know how the GUI renderer works, but it might be having issues with i3, since XFCE worked fine. Maybe i3 has a different process for treating windows? The Qube Manager and my Firefox bookmarks have a lot of this weird effect. My laptop is recent and has enough RAM and CPU (hardware, maybe not software-allocated?) to not be a bottleneck.

Maybe someone who knows about how the VMs’s GUIs are rendered and how that information is passed to the window manager could comment?

Yes … inside XFCE I didn’t noticed that problem as well … but I don’t like XFCE :slight_smile:
For the moment I switched back to 4.0 because this is very annoying and hard to use i3 in that way.
I’m having that problem not only inside Qube Manager as I said, that problem is everywhere [browsers, folders, when I need to click on something new I’ll have that “effect”]

1 Like

Found a fix if you happen to be using intel iGPU.
Create the following file (dom0) /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
        Identifier "Intel Graphics"
        Driver "Intel"
EndSection

I also happened to change GRUB2 Linux kernel option
i915.alpha_support=1 to i915.force_probe=* but that by itself didn’t have any visible effects.

As suggested here

3 Likes

Update: this worked for me!

All I did was add the 20-intel.conf as specified above. Then rebooted. It didn’t work after the first reboot, but after the second reboot I don’t seem to have this problem anymore. I’ll report back if the problem comes back.

I’m not using anymore 4.1 [I’m with 4.0] but maybe I’ll try again with that fix. Thanks

del

I installed again 4.1 and tried it with KDE but it seems I don’t like it compared with i3.
So I installed it and tried your method @bungali and it worked

But the new problem that I founded on 4.1 is that when I’m opening new qubes, I don’t see any messages about them that the qube is opening, or shutdown [for example after I’ll close a dvm qube] … is it there a reason/fix for it?

1 Like

Founded the problem … i didn’t had a notification daemon.
After installing dunst in dom0 that problem has been solved.
The problem is that the notifications are one line only on the top i3 bar and I can’t find a solution to position it to top-right

Today I upgraded to 4.1 from 4.0 and ran into that issue. Slow graphics update and thus sporadic distortions. Configuring xorg to use the intel driver, fixed the issue.

I did not mess with the boot options.

1 Like

Man, I have been getting this visual bug, too. I will try this next time. Thanks for making the thread.

How to do this? How do I install dunst in dom0?

It was some good time ago but I think it is in the repo so just

 sudo qubes-dom0-update dunst
1 Like