How to search for an installed package in dom0?

I want to check whether a specific fedora package is present in dom0.

Normally, in Debian, I would run
$ apt search <package-name>
and then
$ apt policy <package-name>
to read about the package and see if it’s installed in the Debian system.

How can I do the same in dom0?

$ dnf
usage: dnf [options] COMMAND

List of Main Commands:

info                      display details about a package or group of packages
list                      list a package or groups of packages
search                    search package details for the given string

When I use dnf search, I get:

$ sudo dnf search xorg-xrdb
No matches found.

Even though I seem to have xorg-xrdb installed in dom0:

$ xrdb -version
xrdb 1.1.1

So, is sudo dnf search working as expected really?

$ dnf provides xrdb
xorg-x11-server-utils-7.7-35.fc32.x86_64 : X.Org X11 X server utilities
Repo        : @System
Matched from:
Provide    : xrdb = 1.1.1
1 Like

you can also run:
rpm -qa |grep qubes

Man, sorry for resurrecting this thread but I am still not able to search for packages in dom0, using dnf.

This time, I have been trying to get info on the package dunst and I tried the command:

$ sudo dnf search dunst
which returned
No matches found.

I don’t understand, there has to be a package called dunst within fedora repositories but I can’t query that from within dom0. What am I missing?

It’s not in Fedora 32 repo. It was added in Fedora repo starting with Fedora 35.

I see. However, this guy seems to have installed dunst in dom0 back in 2021.

You can install the package that is not in repo. Just download rpm with browser and transfer it to dom0 then you can install it with:
sudo dnf install /path/to/package.rpm
Or you can add their repo for Fedora 32 if they have it.

1 Like

Alright. Thanks. Though, that should be voiding the qubesos security guarantees.

That’s true, but this applies to any software that you install in dom0 even if it comes from Fedora repo. If you can find the signed dunst rpm for Fedora 32 and check that it’s valid then it won’t be any different from installing directly from Fedora repo.

1 Like