How to connect to Wi-Fi?

I’ve looked all over the internet on how to do this, but I still can’t figure it out; I am trying to connect to the internet through Qubes OS. Even if I have to connect through a Qube, I still cannot find out how to connect to the internet. I installed Qubes OS on a Surface Pro 4, and the Internet worked before when I ran windows and then ubuntu on it.

I’ve also tried playing around with all of the options and I could not connect to wifi. I reinstalled Qubes OS, and I still failed to connect to the internet.

Does anyone know how to connect to Wi-Fi in Qubes OS?

Do you have your WiFi Network controller attached to sys-net?
Check the Devices tab in sys-net Qube Settings.

I do have an ethernet controller, which is currently selected, but no sort of “Wi-Fi Network Controller”…

Is it this one?
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac Wireless
Do you have NetworkManager icon in tray?
If not then show the output of this command in sys-net terminal:
lspci -k -s 02:00.0

Also if you’re using debian template then check if you have firmware-libertas package installed:
Debian -- Details of package firmware-libertas in bullseye

And yes I believe it is 02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac Wireless

Although I am trying to connect to Wi-Fi wirelessly, not by ethernet (sorry I’m a bit confused…)

The Network icon only displays “VPN Connections” when I click on it. Is that what you mean by NetworkManager icon in the tray?

Yes.
It’s most probably that you don’t have the required Wireless controller firmware installed in your template.
What template are you using for sys-net?

In the Qube Manager it says that sys-net has the debian-11 template…

Open debian-11 template terminal and install the firmware-libertas package there by running this command:
sudo apt install firmware-libertas
Then shutdown debian-11 template and restart sys-net to see if it’ll make your wireless controller work.

But how would I do that if I don’t have an internet connection?
The apt package manager requires an internet connection to work.

And I’m using a surface pro 4, meaning that I cannot simply connect to wifi using an ethernet cable…

Sorry, forgot that you don’t have the internet working.
In that case you’ll need to download the package from another computer and transfer it in Qubes with USB drive.
Download firmware-libertas_20210315-3_all.deb from any mirror here:
Debian -- Package Download Selection -- firmware-libertas_20210315-3_all.deb
Copy it on your USB flash.
Plug in this USB in Qubes PC.
Open a new disposable VM terminal or some untrusted qube terminal and attach the USB flash partition to this qube:
How to use USB devices | Qubes OS
Then mount the attached USB drive partition in your qube terminal:
sudo mount /dev/xvdi /mnt
Then transfer the downloaded firmware package from your USB drive to debian-11 template by running this command in disposable/untrusted qube terminal:
sudo qvm-copy /mnt/firmware-libertas_20210315-3_all.deb
After it’ll finish the transfer open debian-11 template terminal and copy the downloaded package to the apt cache directory:
sudo cp ~/QubesIncoming/<replace this text with the name of disposable/untrusted qube>/firmware-libertas_20210315-3_all.deb /var/cache/apt/archives/.
Then try to install firmware again:
sudo apt install firmware-libertas

1 Like

Alright, thanks! It worked.