HCL - LG Gram 17 (2023, i7-1360p, 32GB)

LG Gram 17
2023 model

Qubes 4.1.2

Based on singlerider’s post about the Framework Laptop with the same i7-1360p CPU and brainchild059’s post about the 2021 version of the same laptop, I did the following to get things set up:

-Disabled Secure Boot in BIOS (needed to install Qubes)

-Set BIOS date and clock to UTC time (fixes any SSL/connectivity issues)

-Installed Qubes 4.1.2 using install with kernel-latest option. Despite this, the graphical installer suffered from terrible screen tearing and it took a while to click through all the install options.

-Post-install, Qubes still suffered from screen-tearing. It is necessary to run (in Dom0):

sudo qubes-dom0-updates kernel-latest

to get an even newer kernel in order for the screen tearing to go away. Once using the latest kernel (6.5.8-1 at this time), the Qubes install becomes usable.

-Sound does not work out of the box, no devices are even detected. One needs to follow the instructions linked in brainchild059’s 2021 LG Gram 17 HCL post to even get Qubes to detect any sound devices:

  1. Add the following parameters to GRUB_CMDLINE_LINUX=… in /etc/default/grub: snd-intel-dspcfg.dsp_driver=1
  2. Run sudo grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg
  3. Reboot, and you should have sound.

Unfortunately, while this does allow Qubes to detect sound devices and things to appear as expected, there is still no sound from the laptop’s built-in speakers. Sound works with any headphones or earphones plugged into the laptop, but the built-in speakers do not work. I think it might be a general kernel bug rather than a Qubes-specific issue, because I had this same problem when installing Ubuntu before trying Qubes.

Otherwise, networking works fine, the laptop runs quite hot and battery drains quite quickly (but I expect that to be the case with Qubes). I have not tried using sleep/suspend as I rarely use the function, so cannot comment on this.

BONUS that should interest many here:
Pressing CTRL+SHIFT+ALT+F7 in BIOS will reveal many advanced hidden BIOS options.
Go to Intel Advanced menu and find INTEL-FW
There is an option to “Temporarily Disable” Intel ME. Set the selection of ME Operation Mode to Temporarily Disabled.
From my reading, it seems to disable ME using the HECI (soft disable) method, not by flipping the HAP bit or by neutering any part of the ME.
No notable affect in-OS, but it does make the initial BIOS splash and load much longer (~20-30 seconds) on each boot.
The “temporarily disabled” mode seems to persist across reboots, but it will reset itself to “Enabled” on every hard reset (holding power button to force shutdown the laptop).



brand: |
LG Electronics
model: |
bios: |
R1ZH0330 X64
cpu: |
13th Gen Intel(R) Core™ i7-1360P
cpu-short: |
chipset: |
Intel Corporation Device [8086:a707]
chipset-short: |
gpu: |
Intel Corporation Device [8086:a7a0] (rev 04) (prog-if 00 [VGA controller])
gpu-short: |
network: |
Intel Corporation Device 51f1 (rev 01)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

Thank you for HCL and valuable additional information.

Can you, please, also provide details on this questions step by step:

Example of user providing the answers is here.
The more information the better, it may be helpful to other users, thank you.


  • See above original post

Basic Input

  • Keyboard - works
  • External USB mouse [if possible to check] - works
  • Touch-pad - works
  • Touch-pad supports “tap as click” and scrolling with 2 fingers works - works
  • Display brightness change shortcuts - works
  • Sound volume shortcuts - works after fixing audio (see original post) but no sound from built-in speakers, must use wired earphones
  • Keyboard led and keyboard brightness change shortcuts - works

Internet and bluetooth

  • Ethernet cable connection - works out of the box or actions were required? - not tested
  • Ethernet cable connection - speed - not tested
  • Wifi connection - works out of the box or actions were required? - works
  • Wifi connection - speed, is reliable over the time? - reliable
  • Bluetooth - works out of the box or actions were required? - not tested
  • Bluetooth - shows devices, connection process works, sound output or copying works.- not tested


  • Suspend/Resume works - works out of the box or actions were required? - not tested
  • Does resume breaks WiFi, if it does, how to recover it? - not tested
  • Does resume breaks Bluetooth, if it does, how to recover it? - not tested

Video [increase VCPU to the qube before test]

  • Fullscreen and windowed video playback of youtube - 720p/1080p/2K/4K in Firefox. Does it drop frames? - 720p/1080p works, higher res untested
  • Video file playback of file using mpv/mplayer/smplayer - 1080p? Higher resolutions and bitrates? untested
  • Multiple displays configuration works (using available DP/Thunderbolt, HDMI or other video ports - untested, HDMI out to single external monitor works


  • Speakers (sound playback) (was sys-audio used?) - NOT working, not tried with sys-audio, assume it is kernel bug and not Qubes related
  • Head-phones via 3.5" jack (works, automatically turns off speakers?) - works
  • Sound output via HDMI - untested
  • Audio-optical (S/PDIF) output - untested


  • Are fans silent on idle? - no
  • Are fans noisier than on Windows/Linux?. If they are, was thankfan or similar software tried? - yes, fans run on high while on Qubes idle, whereas silent at idle with Linux baremetal install


  • Have you tried running Windows 10 HVM qubes? - works
  • Does CPU boost seem to be working properly? - unknown
1 Like

Thank you. Does it support S3 sleep (the only suspend mode Qubes OS currently support) in BIOS/EFI?

You can try thinkfan software to adjust noise and try to make it silent on idle. It can work not only with Thinkpads, but any laptops that provide suitable temperature data and support fan rotation adjustments from GNU/Linux.