HCL - Dell Precision 5510 i7-6820HQ

-Disabled SecureBoot in order to install
-Using UEFI unlike the similar HCL (i5) on file which specified Legacy
-Machine has Discrete NVIDIA Quadro M1000M which doesn’t show up on the HCL report and isn’t being used in any way
-Everything functions, but the microphone and webcam attachments to VM are sometimes unreliable/erratic

Qubes-HCL-Dell_Inc_-Precision_5510-20230930-074418.yml (792 Bytes)

Edit: I had forgotten that I also had to manually add the Qubes .efi in BIOS as for some reason the install was not being detected automatically.

1 Like

Thanks you! Can you please run some additional tests and answer some questions about the list of what WORKS or DOES NOT work that is available here: Proposal for re-organizing the HCL - #32 by balko


  • Disable SecureBoot

Basic Input

  • Keyboard - works
  • External USB mouse [if possible to check] - works
  • Touch-pad - works
  • Touch-pad supports “tap as click” and scrolling with 2 fingers works - works
  • Display brightness change shortcuts - brings up icon but does not appear to be functional
  • Sound volume shortcuts - works
  • Keyboard led and keyboard brightness change shortcuts - works

Internet and bluetooth

  • Ethernet cable connection - works out of the box or actions were required? - N/A
  • Ethernet cable connection - speed - N/A
  • Wifi connection - works out of the box or actions were required? - works
  • Wifi connection - speed, is reliable over the time? - reliable
  • Bluetooth - works out of the box or actions were required? - unknown
  • Bluetooth - shows devices, connection process works, sound output or copying works.- unknown


  • Suspend/Resume works - works out of the box or actions were required? - just works
  • Does resume breaks WiFi, if it does, how to recover it? - works (<5% of the time WiFi breaks and have to re-suspend
  • Does resume breaks Bluetooth, if it does, how to recover it? - untested

Video [increase VCPU to the qube before test]

  • Fullscreen and windowed video playback of youtube - 720p/1080p/2K/4K in Firefox. Does it drop frames? - 720p/1080p works, unable to test others
  • Video file playback of file using mpv/mplayer/smplayer - 1080p? Higher resolutions and bitrates? untested
  • Multiple displays configuration works (using available DP/Thunderbolt, HDMI or other video ports - untested


  • Speakers (sound playback) (was sys-audio used?) - works, no sys-audio used
  • Head-phones via 3.5" jack (works, automatically turns off speakers?) - works/works
  • Sound output via HDMI - untested
  • Audio-optical (S/PDIF) output - untested


  • Are fans silent on idle? - yes
  • Are fans noisier than on Windows/Linux?. If they are, was thankfan or similar software tried? - untested


  • Have you tried running Windows 10 HVM qubes? - yes, works but suspend requires W10 reboot
  • Does CPU boost seem to be working properly? - unknown



Thanks a lot!
Now we see, that forum users are be able to fill even such detailed testing list.

@Qubesthrowaway can you please also paste here the output of these 2 commands from dom0:

# xinput --list


$ cat /proc/bus/input/devices
(this one may be big, you can use the spoiler).

It may allow to understand if this laptop has some kind of internal PS/2 keyboard/touchpad or USB one.
You may strip serial numbers from the output if any. Thank you.

And alternative way to check it is to run this command and check in several seconds (beware, it can require hard-reset, in case the input breaks and do not restore):

1 Like
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DLL06E5:01 06CB:7A13 Mouse id=11 [slave pointer (2)]
⎜ ↳ DLL06E5:01 06CB:7A13 Touchpad id=12 [slave pointer (2)]
⎜ ↳ sys-usb: Logitech Wireless Mouse id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Video Bus id=8 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ Sleep Button id=10 [slave keyboard (3)]
↳ Intel HID events id=13 [slave keyboard (3)]
↳ Dell WMI hotkeys id=14 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]

I’ll post the other once I go through to check serial numbers to strip.

1 Like

Nice, it seems you have PS/2 internal keyboard, which is good! It is an advantage for laptop to have it on Qubes OS.

Can you please run the last test for me in dom0 terminal:

qvm-pause sys-usb && echo 'Paused' && sleep 10 && qvm-unpause sys-usb

It should pause sys-usb and unpause in 10 seconds. During this 10 seconds can you please switch to some qube with alt+tab and enter some key to check keyboard working, and move cursor with touchpad to check it is working,
If keyboard and/or touchpad input does not work, it should start working again after 10 seconds,

BE AWARE: do not have any important programs with unsaved changes running during this test, because there is a low chance of situation that input will stop working and will not continue to work after 10 seconds. In this case you should reboot laptop with reset/power button (long press it to turn the laptop off), and everything will work again after the boot as usual.

Happy to report both keyboard and touchpad continued working during the sys-usb pause.

1 Like