HCL - Lenovo X1 Carbon gen 10

Qubes is working for me on Lenovo X1 Carbon gen 10.

To fix graphical glitches Dom0 needs to use kernel 5.18.16-1.fc32.qubes.x86_64 and create file with “sudo nano /etc/X11/xorg.conf.d/99-intel.conf” and add;

Section “OutputClass”
Identifier “intel”
MatchDriver “i915”
Driver “intel”
Option “AccelMethod” “sna”
Option “TearFree” “true”
Option “DRI” “3”
EndSection

There will still be a graphical glitch when entering the LUKS password but everything else works fine.

To fix WiFi network you need to use kernel 5.15.64-1.fc32 on sys-net. Most of the time the network adapter works, sometimes it doesn’t work on boot but restarting sys-net gets it working. Once I have had to reboot the whole computer to get it working.

Hi @Azz19, I’m currently trying to decide between the X1 Carbon Gen 10 and the T14s Gen 3 AMD.
Could you tell me if you had any issues in the last two weeks with your installation? And did you use the official 4.1.1 ISO for the installation or something else?

The 2 issues that I’ve been experiencing is a slight graphical glitch on the LUKS password screen and when booting the laptop between 20 and 40 percent of the time sys-net doesn’t connect to the WiFi (you can tell when this happens because the network icon will be completely missing from the top right corner) which requires sys-net to be restarted.

The most frustrating part is during installation and setup the framerate is very low, like 1 frame per second. After kernel 5.18.16-1.fc32.qubes.x86_64 is installed there will be a lot of graphical glitches until you edit “/etc/X11/xorg.conf.d/99-intel.conf”. You can either edit it before rebooting with the new kernel and have to deal with the low framerate while editing or reboot with the new kernel and deal with the graphical glitches during editing.

I used a USB to ethernet adapter to download 5.18.16-1.fc32.qubes.x86_64 as WiFi initially doesn’t work.
After the graphical issues are fixed you need to download kernel 5.15.64-1.fc32 and set sys-net to use it. I’m not exactly sure where or how I managed to find 5.15.64-1.fc32.

Edit: I used “sudo qubes-dom0-update kernel-latest” to get 5.18.16-1.fc32.qubes.x86_64 but this user said he wasn’t able to get it via that command. https://groups.google.com/g/qubes-users/c/01sauU58TsI/m/HEVOBvOxBQAJ
He was only able to get 5.19.9-1.fc32 and both him and I can confirm that that kernel doesn’t work.

How did you create your installation USB stick? I tried both dd and livecd-iso-to-disk, but I always get a kernel panic before even getting to the installer. Did you change any kernel parameters or EFI configuration?

Looks like the issue was a broken USB stick. I used a different one with sudo dd if=Qubes-R4.1.1-x86_64.iso of=/dev/xvdj status=progress bs=1048576 conv=fsync and that just worked.
I managed to install 5.18.16-1.fc32.qubes.x86_64 in dom0 through USB tethering with an Android phone, and after rebooting I ran the Qubes updater which gave me 5.15.64-1.fc32 for sys-net.

After that, everything seems to work without any additional tweaking: audio, suspend, even the touchscreen. Overall, I’m very pleasantly surprised! :slight_smile:

Thanks for your help!

1 Like