No match for argument: kernel-latest

I have successfully installed Q4.1.1 on a new laptop and I have researched the forum which says to resolve glitchy graphics to run this command in dom0

sudo qubes-dom0-update kernel-latest

which loads sys-firewall as UpdateVM to download updates for Dom0 and then returns this message:

No match for argument: kernel-latest
Error: Unable to find a match: kernel-latest

What am i doing wrong?

According to a lot of threads the latest dom0 kernel should be at least 5.19 but mine is still 5.15 and according to the threads that say updating the kernel resolves glitchy graphics when using Intel UHD 770 on 12th Gen Intel they reference kernel 5.18.16-1.fc32.qubes.x86_64


Despite running the GUI Qubes Update and force updating Dom0 via that GUI tool multiple times what worked was running this command in dom0

sudo qubes-dom0-update

I am confused. You first wrote that cli command didn’t work only in your second post to wrote that gui command didn’t work and cli command did?
Please explain so it could help other users too.

1 Like

Thanks for asking because it is indeed very confusing. I executed the command “sudo qubes-dom0-update kernel-latest” multiple times on a fresh 4.1.1 install and rebooted between each attempt. I then would run uname -r and see it is not updating to the latest kernel. I would also use the GUI Qubes Update Tool to force update dom0 and try to install the latest kernel with no luck.

I then executed the command qubes-dom0-update by itself and then followed by qubes-dom0-update kernel latest which then downloaded and installed the latest kernel.

I hope this helps someone in the future!

Thanks for clarification.
Does this

mean that you tried gui tool to update and then ran

$ sudo qubes-dom0-update kernel-latest

with no luck, but running

$ sudo qubes-dom0-update

and then

$ sudo qubes-dom0-update kernel-latest

If so, I seriously doubt.

the first thing i did once i installed Q4.1.1 was launch the GUI Update Tool and force update dom0 and all the templates and rebooted. I then attempted the “sudo qubes-dom0-update kernel-latest” command which resulted in the error i described in my first post. Let me know if you need anymore clarification thanks

No thanks. It’s just strange, as I wrote, that updating via gui tool didn’t help (and running it actually triggers sudo qubesctl --show-output state.sls update.qubes-dom0 salt command), while the other, less safe command helped.