External USB can't make folders/files

I’m thinking this needs ots own post so it doesn’t het losted or maybe someone can help me…

So I understand sys-usb now, connecting external USB either stick or SSD. I Can format them once connected to the domian I want, run gpatted to format “ext4” domain now not only see the external USB device I can access it BUT I can not make folders, files move from one domian to this domain that has usb device and copy/paste. It’s all grayed out, why?
When I go to permissions on the usb devices it’s “read only” and I can’t change the access level to read/right, all grayed out as will. But I see “root” up to. So do I have to use terminal to do what I want within the usb device?
Am I missing something or is this a security feature?

I’m not sure if I follow what you are trying to say, but are the permissions set in such a way that the regular user (named user in Qubes) has write access to your newly formatted USB?

Try this:

  • If your USB is mounted in /home/user/somewhere/, go there in the terminal (i.e., cd /home/user/somewhere/).
  • Now run sudo chmod 777 . (note the dot at the end!).

Did things improve? Can you create a file now (by running for instance touch a.txt)?

thank you, it worked. I will just have to use terminal cmds to make, move, copy to external USB sticks/ssd

No, you only had to use the terminal to change file permissions. You should now be able to use a GUI file manager as normal.

Please note that the general topic here is just the standard Linux file permission system and is not at all Qubes-specific.

OK, so I will have too lookup on how to change this permission “the cmd in terminal” to type…
is this right???

sudo mkdir -m777

NVM… I figured it out, thanks

What solved it in the end, if I may ask?

1 Like

I was sent a video link that explaines everything very well…

I now can make folders, save and edit files to my extetnal usb devices now and everything stays, no deletion.

and also this explanation…

2 Likes