Can't add gpg keys to template

Hi
I just started using it and I’m having trouble, please tell me how to get around this.
I open the terminal of the template to add the vivaldi or wine key gpg repository. But I always get an error.


Resolving repo.vivaldi.com (repo.vivaldi.com)... failed: Tempory failure in name resolution. wget: unable to resolve host address 'repo.vivaldi.com'

Thanks

Why don’t templates have network access?

See current discussion about it: Installing Software in Qubes (all methods) - #19 by Insurgo and Curl-proxy / wget-proxy scripts in Templates so users can add GPG distro keys linked to added external repositories - #11 by Insurgo.

As a noob I’ll try to add my two cents too.

To get online, we are doing it over TCP/IP protocol - via networking. Since this is not secure by any means, Qubes devs disabled networking for dom0 and templates and invented new, secure protocol - qrexec primarily for templates (and dom0).

Think of it as a proxy, which it actually is. So you are getting stuff from online and not being online out of the box. Great, isn’t it?

Well, there’s a catch. Access to online stuff out of the box is limited only to default official distro repositories - for obvious security reasons. So, no signal, vivavldi, chromium packages if they can’t be found in official repositories.

But, the devs didn’t leave us alone on this. Since qrexec is a proxy, it is actually possible to get other stuff online once you learn that this proxy actually runs on 127.0.0.1 via port 8082 (you’ll later learn where)!

So, if you are sure and you trust third-party repositories, the only thing you should do is to add this proxy address to the download link and voila!

So, your commands should start with:

wget --proxy http://127.0.0.1:8082/ address-of-a-key-to-import or whatever

Or, if you are experienced enough, and aware enough of the risks, then you probably already got the picture that you can create a simple file ~/.wgetrc in a template:

use_proxy = on
http_proxy = 127.0.0.1:8082
https_proxy = 127.0.0.1:8082

and everything should work now out of a box.

Remember, qrexec is powerful tool, and using it carelessly could lead you to unimaginable consequences you probably wanted to avoid by starting to use Qubes, actually.

For me, key word for Qubes became qrexec.

Does anything of this make sense?

2 Likes

Inconsistencies and wrong terminology are intentional, hopefully new users to find them and correct me. None of them affect the functionality explained and accuracy of use.

1 Like

One of two things - either I’m stupid even dumber or they gave me an incorrect or incomplete scenario of actions.
This does not work. Couldn’t this be done in some way? I’m new to cubes, there are a lot of desires, but wherever you step - a rake or dancing with a tambourine. It is necessary to climb the forums to read all the problems and try. I killed more than 20 hours and did not solve the problem. Probably, developers need to think somehow to simplify this process, or write a normal manual.
sudo wget --proxy http://127.0.0.1:8082 https://repo.vivaldi.com/archive/linux_signing_key.pub | gpg --dearmor
Connecting to 127.0.0.1:8082 … connected.
HTTP request sent, awaiting response … 403 Filtered
2022-04-21 04:22:23 ERROR 403: Filtered

–2022-04021 04:22:23-- https://repo.vivaldi.com/archive/linuux_signing_key.pub
Resolving repo.vivaldi.com (repo.vivaldi.com) … failed: Tempory failure in name resolution.
wget: unable to resolve host address ‘repo.vivaldi.com
gpg: no valid OpenPGP data found

Thank

$ sudo curl --proxy 127.0.0.1:8082 https://repo.vivaldi.com/archive/linux_signing_key.pub | gpg --dearmor > vivaldi-browser.gpg

$ sudo su

cat vivaldi-browser.gpg | sudo tee -a /usr/share/keyrings/vivaldi-browser.gpg > /dev/nul

exit

$ echo “deb [signed-by=/usr/share/keyrings/vivaldi-browser.gpg arch=$(dpkg --print-architecture)] https://repo.vivaldi.com/archive/deb/ stable main” | sudo tee -a /etc/apt/sources.list.d/vivaldi-archive.list

$ sudo apt update && sudo apt install vivaldi-stable

2 Likes

So, we learned 2 things here:

  1. How to successfully connect to proxy over qrexec, which @simonflex succeeded.
  2. Vivaldi manual doesn’t work, so its maintainers and developers should update their manual.
2 Likes

Thank you very much. You are a magician)) To be honest, I have a lot of experience with Linux, in particular with Debian, since the word Linux means a zoo. Everything seems to be fine with the Debian ecosystem. But here the developers blundered a little. The idea is great, but not properly brought to mind. I really liked Qubis, this is what I have long wanted. But I don’t want to guess how and what is implemented. I am already 50 years old, and with age, thinking also begins to work differently. Developers should think about how to simplify this moment. And there are quite a few of them, I think.
Thanks

1 Like

We need to change the perspective. Or, more precise, we need to bring it back. We lost our ability to orient ourselves in space and time not because we wanted to but under the slogan of “help, manual, guide”.
How able we are to reach from point A to point B in a real world on our own, without soapy voice on our Google or whatever maps? Or to drive without blindly following road signs, not noticing surroundings and orienteering?
We are not able to function and decide on our own anymore.

Did you know that Qubes started with only about 2,500 lines of code? In terms of software it isn’t much more today. Isn’t that just amazing? Do we realize how that extremely decreases attack surface?

This leads us back to the first two sentences. Can our perspective in terms of Qubes actually be: if something “doesn’t work” in Qubes, could it be actually a safety feature? Qubes is far from perfect, but in most cases, it’s actually just about that.

And knowing this, sometimes “not having a manual” is maybe part of this perspective, but mostly because indeed there are really a few developers. But we have great user friendly community to help always and whenever it’s possible.

So, banal tradeoff analogy would be: in order to protect your home and beloved ones, would you prefer laser gun with a partial manual, or a baseball bat with manual? Well it depends on attackers, and I’d quote you that out there the word World, and not Linux only, means zoo. Without cages and fences.

I am older than you, and started occasionally with Linux at most 2 years ago, and switched to it as a daily driver via Qubes only since last November.

I switched to it because my thinking also began to work differently. I realized that I have to bring back my perspective. It’s the same with you, otherwise you wouldn’t be here just wanted to try some new fancy distro in your fifties.

If you found some post to resolve and helped you with your issue, please consider to mark it as a solution so it could help others, searching for it (searching I find is extremely good)

1 Like

Everything said is true. 2500 lines of code is awesome. Indeed, I did not just end up here. I really liked Qubes. Most of what I need is solved. But with a deeper acquaintance, deeper knowledge and features of Qubes are already required. I have already expressed my delight in some chats in which they have not even heard about this OS. First of all, bring it to stable operation, compatibility with iron, and then give it a comfortable attractive look that most people like. For example, my desktop cannot fully enter sleep mode. After the intervention, the desktop goes into sleep mode, but does not respond to any actions of the keyboard and mouse keys. Press the power button that blinks. The desktop wakes up, but nothing works - no network, no reaction to anything. It is necessary to hard turn off the desktop, and then make a cold start. Another bug or that when I choose to update on dom0, something is updated in the dom0 terminal. You can select this action several times, and the same action will happen. What it is, I haven’t figured out yet. It’s only been 24 hours since I met Qubes, and I will continue. I liked it so much that I created my own channel in telegrams, where I will write news, create a team of like-minded people to help newcomers like me, and promote this OS.

1 Like

1 Like

Moved the topic to User support, where it genuinely belongs.

1 Like

This is exactly what is expected from upcoming Qubes 4.2. See also: Qubes-specific App Menu · GitHub.

But as you said,

there are quite a few bugs in 4.1, and with few developers, contributions are welcome.

This is not so much a problem of Qubes but a problem of Linux and particularly Fedora running in dom0. Unless a device was targeting Linux (or Qubes), there is typically no documentation of sleep states and no drivers available, so the Linux community is in a very difficult position. If you want to be sure sleep will work for you, consider choosing one of the Community-recommended computers. For example, sleep works fine on my Librem 15.

Looks like a known bug with the update. I’m waiting for a fix, too. Meanwhile this is the recommended update procedure: How to update | Qubes OS.

Thank you for you contribution to spreading Qubes!